Keep getting mysql issues when running 'make initialize-database'

I’m working though my exercise of importing data from the Windows RT server
to the Linux RT server.

I have done this successfully once.

Here’s my process thus far.

  •      shutdown httpd
  •      shutdown mysqld
  •      remove the /var/lib/mysql directory
  •      startup mysqld (database gets created here)
  •      cd /usr/src/rt-3.0.12
  •      make initialize-database

At this point, I get the following output.

make initialize-database

/usr/bin/perl //opt/rt3/sbin/rt-setup-database --action init --dba root

In order to create a new database and grant RT access to that database,

Use of uninitialized value in concatenation (.) or string at
//opt/rt3/sbin/rt-setup-database line

this script needs to connect to your mysql instance on as root.

Please specify that user’s database password below. If the user has no

password, just press return.


Now creating a database for RT.

Creating mysql database rt3.

Now populating database schema.

Creating database schema.

schema sucessfully inserted

Now inserting database ACLs

Now inserting RT core system objects

[Wed Mar 30 15:37:21 2005] [crit]: Connect Failed Access denied for user
’rt_user’@‘localhost’ (us

ing password: YES)

at //opt/rt3/sbin/rt-setup-database line 334


make: *** [initialize-database] Error 255

I get the same result if I do the following:

  •      cd /usr/src/rt-3.0.12
  •      make dropdb
  •      make initialize-database

What gives? This worked yesterday, now today it’s broken? I have other
issues that I saw yesterday, but I can’t get to them until can get the
import working again.

Does anyone have a thought on this?? I checked Wiki and got nothing.

Paul C.