Issues with my ldap setup


I am trying to setup ldap for my RT instance (5.0.7). I’ve gotten the connection to work but I am having issues searching the OU.

Here is the ldap settings:

Set($LDAPBase, 'dc=my,dc=ad,dc=server');
Set($LDAPFilter, '(&(ou=users,ou=companyname))');
Set($LDAPMapping, {Name         => 'uid', # required
                       EmailAddress => 'mail',
                       RealName     => 'cn',
                       WorkPhone    => 'telephoneNumber',
                       Organization => 'departmentName',

This is how our AD environment is setup

  • base
    ** company name
    *** users
    *** groups

I’ve tried using groups in the groups ou with no luck, I’ve tried the users ou as well. Any ideas?

It seems you have not posted the entire config, or you’re missing a lot of parameters (like LDAP servers, password, etc). Obviously you’d want to anonymize that before posting, but completeness of information (anonymized) is usually a help for starters.

If you’re running microsoft active directory, the “Name” field should be pointing to sAMAccountName instead of uid.


Try changing Ldap filter to the following if you want AND for ou=user and ou=companyname:

Set($LDAPFilter, '(&(ou=users)(ou=companyname))');

Thank you all for the suggestions.

I tried doing Set($LDAPFilter, ‘(&(objectClass=user))’); like another post suggested and it’s working now.