Issues after a new install on new machine. Seen this before can not remember the cause

I see then when attempting to view the contains of the
/usr/local/rt3/share/html with a web browser

%# BEGIN LICENSE BLOCK %# %# Copyright © 1996-2003 Jesse Vincent %# %#
(Except where explictly
superceded by other copyright notices) %# %# This work is made available
to you under the terms of Version 2 of %# the GNU General Public
License. A copy of that license should have %# been provided with this
software, but in any event can be snarfed %# from www.gnu.org. %# %#
This work is distributed in the hope that it will be useful, but %#
WITHOUT ANY WARRANTY; without even the implied warranty of %#
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU %#
General Public License for more details. %# %# Unless otherwise
specified, all modifications, corrections or %# extensions to this work
which alter its source code become the %# property of Best Practical
Solutions, LLC when submitted for %# inclusion in the work. %# %# %# END
LICENSE BLOCK <& /Elements/Header, Title=>loc(“RT at a glance”), Refresh
=> $session{‘home_refresh_interval’} &> <& /Elements/Tabs,
current_toptab => ‘’, Title=>loc(“RT at a glance”) &>
<& /Elements/MyTickets &>
<& /Elements/MyRequests &> <& /Elements/Quicksearch &>

<& /Elements/Refresh, Name => ‘HomeRefreshInterval’, Default => $session
{‘home_refresh_interval’} &>

Reason of error: Your httpd is not well configured. You didn’t activate
RT::Mason handler for location of RT. apache alias is not enough.

You can find sample configs at wiki.bestpractical.com and in archives.
If this links wouldn’t help then You can share RT’s httpd.conf parts.

         Best regards. Ruslan.

Shawn Guillemette wrote:

I am curious, does anyone know if there is a page on the website below that
has information on the “PerlHandler” command? Apparently when I uncomment it
in my httpd.conf file, apache seems to say that the PerlHandler is either
misspelled or an unknown command. I checked the version of apache I am
running, and it is 1.3.3.

Dan Adams - dadams@aspect1.net
http://www.aspect1.net

[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Ruslan U.
ZakirovSent: Monday, August 23, 2004 11:42 PM
To: Shawn Guillemette
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Issues after a new install on new machine. Seen
thisbefore can not remember the cause.

Reason of error: Your httpd is not well configured. You didn’t activate
RT::Mason handler for location of RT. apache alias is not enough.

You can find sample configs at wiki.bestpractical.com and in archives.
If this links wouldn’t help then You can share RT’s httpd.conf parts.

         Best regards. Ruslan.

Shawn Guillemette wrote:

I see then when attempting to view the contains of the
/usr/local/rt3/share/html with a web browser

%# BEGIN LICENSE BLOCK %# %# Copyright © 1996-2003 Jesse Vincent %#
%#
(Except where explictly
superceded by other copyright notices) %# %# This work is made available
to you under the terms of Version 2 of %# the GNU General Public
License. A copy of that license should have %# been provided with this
software, but in any event can be snarfed %# from www.gnu.org. %# %#
This work is distributed in the hope that it will be useful, but %#
WITHOUT ANY WARRANTY; without even the implied warranty of %#
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU %#
General Public License for more details. %# %# Unless otherwise
specified, all modifications, corrections or %# extensions to this work
which alter its source code become the %# property of Best Practical
Solutions, LLC when submitted for %# inclusion in the work. %# %# %# END
LICENSE BLOCK <& /Elements/Header, Title=>loc(“RT at a glance”), Refresh
=> $session{‘home_refresh_interval’} &> <& /Elements/Tabs,
current_toptab => ‘’, Title=>loc(“RT at a glance”) &>
<& /Elements/MyTickets &>
<& /Elements/MyRequests &> <& /Elements/Quicksearch &>
<& /Elements/Refresh, Name => ‘HomeRefreshInterval’, Default => $session
{‘home_refresh_interval’} &>



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com

Dan Adams wrote:

I am curious, does anyone know if there is a page on the website below that
has information on the “PerlHandler” command? Apparently when I uncomment it
in my httpd.conf file, apache seems to say that the PerlHandler is either
misspelled or an unknown command. I checked the version of apache I am
running, and it is 1.3.3.
1.3.3? Are you shure? It’s very old.
PerlHandler - is apache config command that is installs with mod_perl.
Unless you apache runs mod_perl extension you don’t have ‘Perl*’ options.

Hmm, The other servers we have with apache use apache 1.3 so I am not
thinking it is too old, which version are you using?

Also, is there a way to check about the mod_perl extension? I thought it was
installed when the rt3 stuff was setup.

Dan Adams - dadams@aspect1.net
http://www.aspect1.netFrom: Ruslan U. Zakirov [mailto:cubic@acronis.ru]
Sent: Thursday, August 26, 2004 10:44 AM
To: Dan Adams
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Issues after a new install on new machine. Seen
thisbefore can not remember the cause.

Dan Adams wrote:

I am curious, does anyone know if there is a page on the website below
that has information on the “PerlHandler” command? Apparently when I
uncomment it in my httpd.conf file, apache seems to say that the
PerlHandler is either misspelled or an unknown command. I checked the
version of apache I am running, and it is 1.3.3.
1.3.3? Are you shure? It’s very old.
PerlHandler - is apache config command that is installs with mod_perl.
Unless you apache runs mod_perl extension you don’t have ‘Perl*’ options.

Dan Adams - dadams@aspect1.net
http://www.aspect1.net

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Ruslan
U. Zakirov
Sent: Monday, August 23, 2004 11:42 PM
To: Shawn Guillemette
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Issues after a new install on new machine.
Seen thisbefore can not remember the cause.

Reason of error: Your httpd is not well configured. You didn’t
activate
RT::Mason handler for location of RT. apache alias is not enough.

You can find sample configs at wiki.bestpractical.com and in archives.
If this links wouldn’t help then You can share RT’s httpd.conf parts.

         Best regards. Ruslan.

Shawn Guillemette wrote:

I see then when attempting to view the contains of the
/usr/local/rt3/share/html with a web browser

%# BEGIN LICENSE BLOCK %# %# Copyright © 1996-2003 Jesse Vincent %#
%#
(Except where explictly
superceded by other copyright notices) %# %# This work is made available
to you under the terms of Version 2 of %# the GNU General Public
License. A copy of that license should have %# been provided with this
software, but in any event can be snarfed %# from www.gnu.org. %# %#
This work is distributed in the hope that it will be useful, but %#
WITHOUT ANY WARRANTY; without even the implied warranty of %#
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU %#
General Public License for more details. %# %# Unless otherwise
specified, all modifications, corrections or %# extensions to this work
which alter its source code become the %# property of Best Practical
Solutions, LLC when submitted for %# inclusion in the work. %# %# %# END
LICENSE BLOCK <& /Elements/Header, Title=>loc(“RT at a glance”), Refresh
=> $session{‘home_refresh_interval’} &> <& /Elements/Tabs,
current_toptab => ‘’, Title=>loc(“RT at a glance”) &>
<& /Elements/MyTickets &>
<& /Elements/MyRequests &> <& /Elements/Quicksearch &>
<& /Elements/Refresh, Name => ‘HomeRefreshInterval’, Default => $session
{‘home_refresh_interval’} &>



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com

Dan Adams wrote:

Hmm, The other servers we have with apache use apache 1.3 so I am not
thinking it is too old, which version are you using?
You said 1.3.3. Latest version for 1.3.x family is 1.3.31.

Also, is there a way to check about the mod_perl extension? I thought it was
installed when the rt3 stuff was setup.
You didn’t read README well. RT doesn’t install/configure
apache/FastCGI/mod_perl for you. If you are using some distro based RT
packaged then you should consult with distributor.

If you are building from source then you have to read:
http://perl.apache.org/docs/1.0/guide/install.html
also:
http://perl.apache.org/docs/1.0/guide/install.html#How_can_I_tell_whether_mod_perl_is_running_