Issue with forwarding tickets and transactions in RT 5.0.2

We recently upgraded (fresh install of RT 5.0.2 on a new server, migrated the database from RT4.X, ran all the upgrade scripts, etc.) to RT 5.0.2 I am not sure if this was working on our 4.X instance or not.

When a user forwards a ticket or a transaction, the message they add is not included in the email sent, but is recorded in the ticket history.

When I tried to paste the logs here it said new users can only post 2 links, but I tried stripping all of the obvious links from the logs and it still gave me the error, but I am noticing the following error in the apache error log at the same time the RT log shows the forward scrip being run:

usage: html2text [-h] [–default-image-alt DEFAULT_IMAGE_ALT] [–pad-tables]
[–no-wrap-links] [–wrap-list-items] [–ignore-emphasis]
[–reference-links] [–ignore-links] [–protect-links]
[–ignore-images] [–images-as-html] [–images-to-alt]
[–images-with-size] [-g] [-d] [-e] [-b BODY_WIDTH]
[-i LIST_INDENT] [-s] [–escape-all] [–bypass-tables]
[–ignore-tables] [–single-line-break] [–unicode-snob]
[–no-automatic-links] [–no-skip-internal-links]
[–links-after-para] [–mark-code]
[–decode-errors DECODE_ERRORS] [–open-quote OPEN_QUOTE]
[–close-quote CLOSE_QUOTE] [–version]
[filename] [encoding]
html2text: error: unrecognized arguments: -nobs -width

So my thinking is the html2text error is what is causing the message to not be added to the email: “html2text: error: unrecognized arguments: -nobs -width”

But I have no idea where those arguments are being passed to html2text from.

Any help would be much appreciated.

I haven’t tried html2text and don’t have it installed, so I’m not quite sure what’s happening there. I can say that on our RT 5.0.3 server we just upgraded to, the w3m option we’ve specified in seems to be working to forward messages. You might install that and give it a shot. → Set($HTMLFormatter, w3m);

So I changed to that and it works now, but I don’t actually have w3m installed so it is just using the internal converter and giving a warning about needing to install one.

I installed w3m and it still works without the error.


1 Like

There is a Python module called the same thing I believe HTMLFormatter which gets called instead of the right tool

so its PATH stuff

1 Like

There is this:

Which is wrong, RT should use this:

1 Like