Internal Server Error 500

I’m getting an error trying to get the URL to load while setting up the site running RT 5 on Linux. The account has sudo permission.

Can’t locate /opt/rt5/etc/ Permission denied at /opt/rt5/sbin/…/lib/RT/ line 2252.

RT couldn’t load RT config file /opt/rt5/etc/ as:
user: www-data
group: www-data

The file is owned by user root and group rt.

This usually means that the user/group your webserver is running
as cannot read the file. Be careful not to make the permissions
on this file too liberal, because it contains database passwords.
You may need to put the webserver user in the appropriate group
(rt) or change permissions be able to run succesfully.

Can’t locate /opt/rt5/etc/ Permission denied at /opt/rt5/sbin/…/lib/RT/ line 2252.
[Wed Feb 15 18:01:29.848435 2023] [fcgid:warn] [pid 2407:tid 140154337470016] (104)Connection reset by peer: [client x.x.x.x:53527] mod_fcgid: error reading data from FastCGI server, referer:
[Wed Feb 15 18:01:29.848458 2023] [core:error] [pid 2407:tid 140154337470016] [client x.x.x.x:53527] End of script output before headers: rt-server.fcgi, referer:


Check the file /opt/rt5/etc/ exists. If it does not, you should use /opt/rt5/etc/ as a template for creating it. Once this is done, make sure the group of the directory /opt/rt5/etc is that of the www server running your RT site (apache typically runs under account www-data, group www-data). Under /opt/rt5/etc the files and should in your case also be readable by the group www-data.
If the installation of RT runs smoothly, the owners and groups and permissions of the above files (except should be set automatically.

Quickest solution: add www-data to the group rt and restart your web server.


I tried that, still showing the same error

What flavor of Linux are you on? What do you see if you run ls -l /opt/rt5/etc/

I’m running Ubuntu 22.04 LTS
This is the result after running the command:
-r–r----- 1 root rt 146180 Jan 24 17:43 /opt/rt5/etc/

You can run make fixperms from the unpacked source to confirm permissions are correct, www-data seems to be the right Apache default user. Also I forget what exactly the permissions should be but when running your ./configure command you can customize:

 --with-web-user=USER    user the web server runs as (default: www)
 --with-web-group=GROUP  group the web server runs as (default: www)

Since the defaults likely don’t work for you

I tried both the commands still showing the same error - not sure what I did wrong.

Additionally, I didn’t get any errors while running those commands. The error I was referring to is the Internal Error for the site

Can you share what you ran?

Here are the commands that I ran:

make fixperms
./configure --with-web-user=www-data
./configure --with-web-group=www-data

That configure command configures everything to then be installed, so you want to do it once with all of your flags:

./configure --with-web-user=www-data --with-web-group=www-data ...

Then you install these changes into /opt/rt5 (or wherever) with make install

1 Like

Thank you! I got the rt site shows up now.
I tried to run wsgetmail --debug --dry-run --config=wsgetmail.json, I received an error showing

“Missing required arguments: command_args at /usr/local/share/perl/5.34.0.App/ line 266.”

Everything is corrected in the wsgetmail.json file - Do you have any ideas?


Minh H