Installing RT on Red Hat 9

Hi all,

I installed RT on Red Hat 9, and it is not working very well. I am using
mod_perl 2 shipped with Red Hat, I suppose that is why. Problem is that
I have to install it on Red Hat 9. So, what is your suggestion ? To
downgrade to mod perl 1 ? Something else ?

Thanks in advance,
Eng. Dusan Djordjevic (RHCE) PlanetSky Ltd.
Tel: +357 22454896 * Fax: +357-22518022
http://www.planetsky.com dusan@planetsky.com

I installed RT on Red Hat 9, and it is not working very well. I am using
mod_perl 2 shipped with Red Hat, I suppose that is why. Problem is that
I have to install it on Red Hat 9. So, what is your suggestion ? To
downgrade to mod perl 1 ? Something else ?

What I did:

And everything is much much better.

Of course, you’ll still have that damn Storable.pm error that no one has
been able to get to the bottom of, but at least you’ll be suffering in
good company. :slight_smile:

Good luck.
Mick Szucs mick@onramp.ca
Onramp Network Services Inc.

For me it works after

setting LOCALE=C

and

  • with a self compiled apache 1.3.27
  • with a self compiled mod_fastcgi 2.4
  • with a self compiled perl 5.8.0
  • with a self compiled MySQL 4.x

Regards,
Harald

This one time, at band camp, Dusan Djordjevic wrote:

Hi all,

I installed RT on Red Hat 9, and it is not working very well. I am using
mod_perl 2 shipped with Red Hat, I suppose that is why. Problem is that
I have to install it on Red Hat 9. So, what is your suggestion ? To
downgrade to mod perl 1 ? Something else ?

Hunt in the archives, there’s an apache2+modperl2 configuration for redhat
8. if that doesn’t work for you, please elaborate on the symptoms of the
"not working very well".

jaq@spacepants.org http://spacepants.org/jaq.gpg

I’ve got RT 3.03 setup and running fine with the webinterface,
and modified the rtimportldap from 2.0 contrib to import all of my users
into MySQL.

I’m running Apache 1.x w/mod_auth_ldap setup, and all is good. Except,
rt-mailgate doesn’t work. Seems it posts to /REST/1.0/NoAuth/mail-gateway,
which due to the use of ExternalWebAuth is covered by my apache config:

<Directory /opt/rt3/share/html>
Options Indexes FollowSymLinks
AllowOverride None
order allow,deny
allow from all
AuthName "Request Tracker"
AuthType Basic
LDAP_Server 127.0.0.1
LDAP_Port 389
Base_DN "OU=People,DC=company,DC=com"
UID_Attr cn
require filter (cn=*)

And wants a username + password. I’ve tried to override the sub tree with:

<Directory /opt/rt3/share/html/REST/1.0>
Options Indexes FollowSymLinks
AllowOverride None
order allow,deny
allow from all

However it still wants a username + password. Is there a quick fix around
this? I can’t be the 1st person to run into this…

Ken Bantoft Super FreeS/WAN Maintainer
ken@freeswan.ca http://www.freeswan.ca
PGP Key: finger ken@bantoft.org

This one time, at band camp, Dusan Djordjevic wrote:

Hi all,

I installed RT on Red Hat 9, and it is not working very well. I am using
mod_perl 2 shipped with Red Hat, I suppose that is why. Problem is that
I have to install it on Red Hat 9. So, what is your suggestion ? To
downgrade to mod perl 1 ? Something else ?

Hunt in the archives, there’s an apache2+modperl2 configuration for redhat
8. if that doesn’t work for you, please elaborate on the symptoms of the
"not working very well".

There’s a specific problem with mod_perl-1.99_07 that ships with Redhat
9 that limits POST requests to 8192 bytes. This was confirmed by
mod_perl developer Stas Bekman.

In RT this leads to truncated messages and mail loops (at least with
Qmail, it gets SIGPIPE feeding the message to rt-mailgate and stores the
message for future delivery) and all sorts of fun things.

Redhat’s response to my bug report was: “Please rebuild mod_perl from
Rawhide source.”

Dunno if this is what Dusan is experiencing, but it should be
anticipated for everyone attempting to run RT under a stock Redhat 9
installation.

Plus the damn Storable.pm thing :slight_smile:
Mick Szucs mick@onramp.ca
Onramp Network Services Inc.

Wednesday 16 July 2003 17:19, Mick Szucs:

Dunno if this is what Dusan is experiencing, but it should be
anticipated for everyone attempting to run RT under a stock Redhat 9
installation.

Well, generally it works clunky :slight_smile: I am not quiet sure why, I do not
have time to examine in depth. Anyway I started rebuilding mod_perl
from rawhide (although I have some problems). So when I finish
everything than we will know.

Best regards,
Eng. Dusan Djordjevic (RHCE) PlanetSky Ltd.
Tel: +357 22454896 * Fax: +357-22518022
http://www.planetsky.com dusan@planetsky.com

This one time, at band camp, Mick Szucs wrote:

There’s a specific problem with mod_perl-1.99_07 that ships with Redhat
9 that limits POST requests to 8192 bytes. This was confirmed by
mod_perl developer Stas Bekman.

Oh, okay. I’m now glad I switched to mod_fastcgi.

jaq@spacepants.org http://spacepants.org/jaq.gpg

I believe just adding a “Satisfy Any” directive will solve you problem.
You may want to deny from all and allow access to just rt-mailgate’s IP in
combination with the satisfy directive.

Thanks,
Christian

Christian Gilmore
Technology Leader
GeT Support Application Development
IBM Software Group

Ken Bantoft ken@freeswan.ca
Sent by: rt-users-admin@lists.fsck.com
07/16/03 09:08 AMTo: rt-users@lists.fsck.com
cc:
Subject: [rt-users] External Web Auth breaks rt-mailgate?

I’ve got RT 3.03 setup and running fine with the webinterface,
and modified the rtimportldap from 2.0 contrib to import all of my users
into MySQL.

I’m running Apache 1.x w/mod_auth_ldap setup, and all is good. Except,
rt-mailgate doesn’t work. Seems it posts to
/REST/1.0/NoAuth/mail-gateway,
which due to the use of ExternalWebAuth is covered by my apache config:

<Directory /opt/rt3/share/html>
Options Indexes FollowSymLinks
AllowOverride None
order allow,deny
allow from all
AuthName "Request Tracker"
AuthType Basic
LDAP_Server 127.0.0.1
LDAP_Port 389
Base_DN "OU=People,DC=company,DC=com"
UID_Attr cn
require filter (cn=*)

And wants a username + password. I’ve tried to override the sub tree
with:

<Directory /opt/rt3/share/html/REST/1.0>
Options Indexes FollowSymLinks
AllowOverride None
order allow,deny
allow from all

However it still wants a username + password. Is there a quick fix around

this? I can’t be the 1st person to run into this…

Ken Bantoft Super FreeS/WAN Maintainer
ken@freeswan.ca http://www.freeswan.ca
PGP Key: finger ken@bantoft.org

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Thanks, got it working now.

Now I just have to deal with:

Jul 16 12:57:27 tor33517 RT: Cannot Encode::Guess; fallback to iso-8859-1 (/opt/rt3/lib/RT/I18N.pm:352)
Jul 16 12:57:28 tor33517 RT: rt-3.0.3-3-15.4.28537776260406@MDSP #3/15 - Scrip 7 (/opt/rt3/lib/RT/Action/SendEmail.pm:91)
Jul 16 12:57:28 tor33517 RT: rt-3.0.3-3-15.4.28537776260406@MDSP No recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:251)
Jul 16 12:57:28 tor33517 RT: rt-3.0.3-3-15.15.2182175694278@MDSP #3/15 - Scrip 8 (/opt/rt3/lib/RT/Action/SendEmail.pm:91)

It doesn’t seem to pull recipents out of the database, even tho they all
have email addresses. I know you’re running w/LDAP support - did you need
to change anything else to get the email working properly?On Wed, 16 Jul 2003, Christian Gilmore wrote:

I believe just adding a “Satisfy Any” directive will solve you problem.
You may want to deny from all and allow access to just rt-mailgate’s IP in
combination with the satisfy directive.

Thanks,
Christian


Christian Gilmore
Technology Leader
GeT Support Application Development
IBM Software Group

Ken Bantoft wrote:

Thanks, got it working now.

Now I just have to deal with:

Jul 16 12:57:27 tor33517 RT: Cannot Encode::Guess; fallback to iso-8859-1 (/opt/rt3/lib/RT/I18N.pm:352)
Jul 16 12:57:28 tor33517 RT: rt-3.0.3-3-15.4.28537776260406@MDSP #3/15 - Scrip 7 (/opt/rt3/lib/RT/Action/SendEmail.pm:91)
Jul 16 12:57:28 tor33517 RT: rt-3.0.3-3-15.4.28537776260406@MDSP No recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:251)
Jul 16 12:57:28 tor33517 RT: rt-3.0.3-3-15.15.2182175694278@MDSP #3/15 - Scrip 8 (/opt/rt3/lib/RT/Action/SendEmail.pm:91)

It doesn’t seem to pull recipents out of the database, even tho they all
have email addresses. I know you’re running w/LDAP support - did you need
to change anything else to get the email working properly?

I setup RT so that the user logs in via the web form once and then can
use the email afterwards. On their first web logon they are placed in
the RT database and after that all is well.

Ken Bantoft wrote:

Thanks, got it working now.

Now I just have to deal with:

Jul 16 12:57:27 tor33517 RT: Cannot Encode::Guess; fallback to iso-8859-1 (/opt/rt3/lib/RT/I18N.pm:352)
Jul 16 12:57:28 tor33517 RT: rt-3.0.3-3-15.4.28537776260406@MDSP #3/15 - Scrip 7 (/opt/rt3/lib/RT/Action/SendEmail.pm:91)
Jul 16 12:57:28 tor33517 RT: rt-3.0.3-3-15.4.28537776260406@MDSP No recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:251)
Jul 16 12:57:28 tor33517 RT: rt-3.0.3-3-15.15.2182175694278@MDSP #3/15 - Scrip 8 (/opt/rt3/lib/RT/Action/SendEmail.pm:91)

It doesn’t seem to pull recipents out of the database, even tho they all
have email addresses. I know you’re running w/LDAP support - did you need
to change anything else to get the email working properly?

I setup RT so that the user logs in via the web form once and then can
use the email afterwards. On their first web logon they are placed in
the RT database and after that all is well.

I’m using rtimportldap.pl that I tweaked to work with RT3, so it’s already
imported all of my users into the Users table, with email addresses and
whatnot. So everyone’s in the database already, it just seems to be
ignoring them/thier email addresses. When I create a new ticket, I get
emailed about it, however any subsequent updates to the ticket (ie: change
of ownership, or replies to it) get stuck in the scrips:

Jul 16 13:16:58 tor33517 RT: Cannot Encode::Guess; fallback to iso-8859-1 (/opt/rt3/lib/RT/I18N.pm:352)
Jul 16 13:16:59 tor33517 RT: RT::Scrip=HASH(0x93556fc): Couldn’t prepare Open Tickets (/opt/rt3/lib/RT/Scrip_Overlay.pm:338)
Jul 16 13:16:59 tor33517 RT: rt-3.0.3-4-19.8.28265725797976@MDSP #4/19 - Scrip 4 (/opt/rt3/lib/RT/Action/SendEmail.pm:91)
Jul 16 13:16:59 tor33517 RT: rt-3.0.3-4-19.8.28265725797976@MDSP No recipients found. Not sending. (/opt/rt3/lib/RT/Action/SendEmail.pm:251)

So any notifications never hit sendmail to be tossed out the door.

Ken

Of course, you’ll still have that damn Storable.pm error that no one has
been able to get to the bottom of, but at least you’ll be suffering in
good company. :slight_smile:

This is specific to Redhat9 or just the version of perl they ship with?

Plus the damn Storable.pm thing :slight_smile:

What’s that thing ? I can’t found anything on it neither in redhat
bugzilla nor in perl/cpan RT database…

I installed RT-3 on a RHL9 box. The main annoying thing I noticed is
that using the UTF-8 charset makes Perl module installation fails
(something wrong with RHL9 UTF-8 handling that affects the module
responsible on writing the Makefiles), which can be fixed by setting
LANG et LC_ALL to “C” (and exporting) just before compilation.

Guillaume Perréal.

Responsable informatique,
Cemagref, groupement de Lyon.

Tél: 04.72.20.87.87.
Fax: 04.78.47.78.75.
Web: http://www.lyon.cemagref.fr/

Of course, you’ll still have that damn Storable.pm error that no one has
been able to get to the bottom of, but at least you’ll be suffering in
good company. :slight_smile:

This is specific to Redhat9 or just the version of perl they ship with?

I’m still investigating, but it seems likely to be related to their
version of Perl. I reserve the right to reverse this conclusion,
though.

Jamie Wilkinson mentioned that he’s seeing the Storable.pm errors under
mod_fastcgi as well, so it’s not the mod_perl thing… Could still be
apache or mysql related, I guess.

It’s a friendly transient error, too. Seems that I can get it to occur
consistently right after server restart, but there’s no guarantee after
that.
Mick Szucs mick@onramp.ca
Onramp Network Services Inc.

Plus the damn Storable.pm thing :slight_smile:

What’s that thing ? I can’t found anything on it neither in redhat
bugzilla nor in perl/cpan RT database…

Here’s some other people talking about it (finally)

http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&threadm=rt-23004-60972.15.6145841393568%40rt.perl.org&rnum=2&prev=/groups%3Foi%3Ddjq%26as_q%3Dstorable.xs%20assertion

Noticable in RT under Redhat9 when you click on a queue, or attempt to
add more than two criteria to a search, you get:

error:
Assertion flags == 0 failed: file “Storable.xs”, line 2342 at
blib/lib/Storable.pm (autosplit into blib/lib/auto/Storable/_freeze.al)
line 282.

And a bunch of other stuff at the bottom, and your last-added search
critera isn’t stored (although the search results display correctly.)

Seems transient, too, although it occurrs more often than not.

Should maybe be a FAQ now :slight_smile:
Mick Szucs mick@onramp.ca
Onramp Network Services Inc.

Jamie Wilkinson mentioned that he’s seeing the Storable.pm errors under
mod_fastcgi as well, so it’s not the mod_perl thing… Could still be
apache or mysql related, I guess.

I think I’ve ruled out the possibility that mysql is involved, as the
error still occurs if you tell RT to store sessions to File, instead of
DB. Must be occurring during the actual serialization of the session
for storage.

Some test code to produce the error without involving Apache::Session
would be handy to find out whether or not Apache2 is implicated. Would
be useful for a bug report to Redhat, too.

Confirmed that this still occurs under the latest Apache::Session, too.
Mick Szucs mick@onramp.ca
Onramp Network Services Inc.

Thursday 17 July 2003 15:23, Mick Szucs:

Noticable in RT under Redhat9 when you click on a queue, or attempt
to add more than two criteria to a search, you get:
error:
Assertion flags == 0 failed: file “Storable.xs”, line 2342 at
blib/lib/Storable.pm (autosplit into
blib/lib/auto/Storable/_freeze.al) line 282.

Well, I installed RT on fresh Red Hat 9, and now this part is not
working at all. On my test computer simptoms were like stated, when you
click on queue you get results with bunch of errors. Now, when I click
on queue I just get bunch of errors, like:

System error
error:
Assertion flags == 0 failed: file “Storable.xs”, line 2336 at
…/…/lib/Storable.pm (autosplit into
…/…/lib/auto/Storable/_freeze.al) line 282.

and so on.

Any ideas ?

From the beginning of installation I set LANG to C since Perl on RH has
problems with locales.
Eng. Dusan Djordjevic (RHCE) PlanetSky Ltd.
Tel: +357 22454896 * Fax: +357-22518022
http://www.planetsky.com dusan@planetsky.com

Well, I installed RT on fresh Red Hat 9, and now this part is not
working at all. On my test computer simptoms were like stated, when you
click on queue you get results with bunch of errors. Now, when I click
on queue I just get bunch of errors, like:

System error
error:
Assertion flags == 0 failed: file “Storable.xs”, line 2336 at
…/…/lib/Storable.pm (autosplit into
…/…/lib/auto/Storable/_freeze.al) line 282.

and so on.

Any ideas ?

Not yet, unfortunately. Surely there are enough of us having trouble
with this now to get to the bottom of it, though.

Mick Szucs mick@onramp.ca
Onramp Network Services Inc.

Recompile perl without threading enabled.
Threading is non-standard, yet RH ship with it turned on…

Gordon Smith CCNA
Network Operations Manager

MoreNet Ltd

PGP Fingerprint: 4B12 FBE4 784A 3294 6637 4587 AB6F C893 AB2C 952C