Installing RT on FreeBSD 4.5?

OK, I’ve finally satisfied all the dependencies, but now I’m getting an
"Internal Server Error" from the web server.

When I start Apache, I get this message:
Unquoted string “true” may clash with future reserved word at
/usr/local/rt/rt2/ etc/config.pm line 118.

I have Apache 1.3.22
mod_perl 1.26
Perl 5.6.1

I have been following the installation guidelines from the RT doc, fwiw.
Any hints appreciated.

“CB” == Chris Boyd cboyd@goal.apogeetelecom.com writes:

CB> I have Apache 1.3.22
CB> mod_perl 1.26
CB> Perl 5.6.1

RT works great on FreeBSD 4.x

Be sure that you have the latest apache 1.3. Then, make sure your
mod_perl is built and linked against perl5.6.1 (not the system perl).

Then make sure that your modules are all up to date:

perl -MCPAN -e shell

make sure your CPAN is the newest “install Bundle::CPAN” and then
"reload CPAN".

then type “r” to see the outdated modules, then “install XXX” for each
outdated module.

Also, make sure the dependency script that comes with RT reports
nothing outdated.

Chris Boyd wrote:

When I start Apache, I get this message:
Unquoted string “true” may clash with future reserved word at
/usr/local/rt/rt2/ etc/config.pm line 118.

Looks like its a syntax error in your config.pm on line 118

make sure your setting stuff like

$ParseNewMessageForTicketCcs = undef;
to
$ParseNewMessageForTicketCcs = 1;

instead of the word true.

-seth