Installing as non-virual server

I’d like to install rt as a subfolder of main html server, rather than
virtual, as I don’t have any other need for virtual hosts. How hard is
that? I don’t see documentation on it, all the installation docs presume
a virtual host.

Chris Mason
masonc@masonc.com
Box 340, The Valley, Anguilla, British West Indies
Tel: 264 497 5670 Fax: 264 497 8463 Cell: 264 235 5670
http://www.anguillaguide.com/ The Anguilla Guide
Talk to me in real time:
Yahoo:netconcepts_anguilla
US Fax and Voicemail: (815)301-9759

Zitat von Chris Mason masonc@masonc.com:

I’d like to install rt as a subfolder of main html server, rather than
virtual, as I don’t have any other need for virtual hosts. How hard is
that? I don’t see documentation on it, all the installation docs presume
a virtual host.

Thanks to someone from this list I got a httpd.conf snippet allowing just that:

unfortunately I can’t access the server from here, so here’s the link with the
helpful mail (thanks Christian):

http://lists.fsck.com/pipermail/rt-users/2002-July/009105.html

MfG
Andreas

I’d like to install rt as a subfolder of main html server, rather than
virtual, as I don’t have any other need for virtual hosts. How hard is
that? I don’t see documentation on it, all the installation docs presume
a virtual host.

Take all the VirtualHost specific info, and put them into a
<Location /rt> … block. HTML::Mason, and therefore
WebRT and all that it entails, is designed to work on a
Location/Files/etc block, of which VirtualHost is merely a specialized
version.

(darren)

Sigmund Freud is alleged to have said that in the last analysis
the entire field of psychology may reduce to biological
electrochemistry.

Seems to be working in that sort of arrangement on our testbed server
pretty well. (And I did it, so it can’t have been to terribly hard.)

The important bit, as I recall, was making sure that $WebPath got set
correctly in /path-to-rt/etc/config.pm.

Mark Roedel | "Blessed is he who has learned to laugh
Systems Programmer | at himself, for he shall never cease
LeTourneau University | to be entertained."
Longview, Texas, USA | – John Powell

That might be the problem. Is this correct?
The server is http://loki.altamer.home and the URL for RT would be
http://loki.altamer.home/rt2/

$WebPath = “/var/www/rt2”;

This is the Scheme, server and port for constructing urls to webrt

$WebBaseURL doesn’t need a trailing /

$WebBaseURL = “http://RT::loki.altamer.home:80”;

$WebURL = $WebBaseURL . $WebPath . “/”;From: Roedel, Mark [mailto:MarkRoedel@letu.edu]
Sent: Monday, September 09, 2002 5:26 PM
To: Chris Mason
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] Installing as non-virual server

Seems to be working in that sort of arrangement on our testbed server
pretty well. (And I did it, so it can’t have been to terribly hard.)

The important bit, as I recall, was making sure that $WebPath got set
correctly in /path-to-rt/etc/config.pm.

Mark Roedel | "Blessed is he who has learned to laugh
Systems Programmer | at himself, for he shall never cease
LeTourneau University | to be entertained."
Longview, Texas, USA | – John Powell

-----Original Message-----
From: Chris Mason [mailto:masonc@masonc.com]
Sent: Monday, September 09, 2002 3:37 PM
To: rt-users@lists.fsck.com
Subject: [rt-users] Installing as non-virual server

I’d like to install rt as a subfolder of main html server, rather than
virtual, as I don’t have any other need for virtual hosts. How hard is
that? I don’t see documentation on it, all the installation docs
presume a virtual host.

-----Original Message-----
From: Chris Mason [mailto:masonc@masonc.com]
Sent: Monday, September 09, 2002 4:40 PM
To: Roedel, Mark
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] Installing as non-virual server

That might be the problem. Is this correct?
The server is http://loki.altamer.home and the URL for RT would be
http://loki.altamer.home/rt2/

[snip]

$WebBaseURL = “http://RT::loki.altamer.home:80”;

This looks funny to me (unless it’s just a typo).

Have you tried making it just
$WebBaseURL = “http://loki.altamer.home:80”;
?

Other than that, the snippet you posted substantially matches what I’ve
got.

Mark Roedel | "The most overlooked advantage to owning a
Systems Programmer | computer is that if they foul up there’s no
LeTourneau University | law against whacking them around a little."
Longview, Texas USA | – Owen Porterfield

Chris;

What you need to do first of all is to edit your httpd.conf and add the rt
alias as per Andraeas mail to you earlier;
and say you name the alias “rt2”(remember to restart httpd)

in /path-to-rt2/etc/config.pm
define the following as:

$WebPath = “/rt2”
$WebBaseURL = http://loki.altamer.home

and thats it; from a browser you will see the rt login at
http://loki.altamer.home/rt2/

Good Luck

Roy

Now I have the following, but it still doesn’t work, I get “Internal
Server Error” when I access http://loki.altamer.home/rt2

/var/www/rt2/etc/config.pm

$WebPath = “/rt2”;

$WebBaseURL = “http://loki.altamer.home”;

$WebURL = $WebBaseURL . $WebPath . “/”;

and in Apache:

Alias /perl/ /var/www/perl/ SetHandler perl-script PerlHandler Apache::Registry Options +ExecCGI

PerlModule Apache::DBI
PerlFreshRestart On
PerlRequire /var/www/rt2/bin/webmux.pl
<Location /rt2>
SetHandler perl-script
PerlHandler RT::Mason

Alias /rt2/ /var/www/rt2/WebRT/html/From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Chris Mason
Sent: Monday, September 09, 2002 5:40 PM
To: 'Roedel, Mark’
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] Installing as non-virual server

That might be the problem. Is this correct?
The server is http://loki.altamer.home and the URL for RT would be
http://loki.altamer.home/rt2/

$WebPath = “/var/www/rt2”;

This is the Scheme, server and port for constructing urls to webrt

$WebBaseURL doesn’t need a trailing /

$WebBaseURL = “http://RT::loki.altamer.home:80”;

$WebURL = $WebBaseURL . $WebPath . “/”;

From: Roedel, Mark [mailto:MarkRoedel@letu.edu]
Sent: Monday, September 09, 2002 5:26 PM
To: Chris Mason
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] Installing as non-virual server

Seems to be working in that sort of arrangement on our testbed server
pretty well. (And I did it, so it can’t have been to terribly hard.)

The important bit, as I recall, was making sure that $WebPath got set
correctly in /path-to-rt/etc/config.pm.

Mark Roedel | "Blessed is he who has learned to laugh
Systems Programmer | at himself, for he shall never cease
LeTourneau University | to be entertained."
Longview, Texas, USA | – John Powell

-----Original Message-----
From: Chris Mason [mailto:masonc@masonc.com]
Sent: Monday, September 09, 2002 3:37 PM
To: rt-users@lists.fsck.com
Subject: [rt-users] Installing as non-virual server

I’d like to install rt as a subfolder of main html server, rather than
virtual, as I don’t have any other need for virtual hosts. How hard is
that? I don’t see documentation on it, all the installation docs
presume a virtual host.

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

What happens when you try http://loki.altamer.home/rt2/ (note the trailing
slash)

RoyFrom: “Chris Mason” masonc@masonc.com
To: “‘Chris Mason’” masonc@masonc.com; "‘Roedel, Mark’"
MarkRoedel@letu.edu
Cc: rt-users@lists.fsck.com
Sent: Monday, September 09, 2002 11:27 PM
Subject: RE: [rt-users] Installing as non-virual server

Now I have the following, but it still doesn’t work, I get “Internal
Server Error” when I access http://loki.altamer.home/rt2

/var/www/rt2/etc/config.pm

$WebPath = “/rt2”;

$WebBaseURL = “http://loki.altamer.home”;

$WebURL = $WebBaseURL . $WebPath . “/”;

and in Apache:

Alias /perl/ /var/www/perl/ SetHandler perl-script PerlHandler Apache::Registry Options +ExecCGI

PerlModule Apache::DBI
PerlFreshRestart On
PerlRequire /var/www/rt2/bin/webmux.pl
<Location /rt2>
SetHandler perl-script
PerlHandler RT::Mason

Alias /rt2/ /var/www/rt2/WebRT/html/

-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Chris Mason
Sent: Monday, September 09, 2002 5:40 PM
To: 'Roedel, Mark’
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] Installing as non-virual server

That might be the problem. Is this correct?
The server is http://loki.altamer.home and the URL for RT would be
http://loki.altamer.home/rt2/

$WebPath = “/var/www/rt2”;

This is the Scheme, server and port for constructing urls to webrt

$WebBaseURL doesn’t need a trailing /

$WebBaseURL = “http://RT::loki.altamer.home:80”;

$WebURL = $WebBaseURL . $WebPath . “/”;

-----Original Message-----
From: Roedel, Mark [mailto:MarkRoedel@letu.edu]
Sent: Monday, September 09, 2002 5:26 PM
To: Chris Mason
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] Installing as non-virual server

Seems to be working in that sort of arrangement on our testbed server
pretty well. (And I did it, so it can’t have been to terribly hard.)

The important bit, as I recall, was making sure that $WebPath got set
correctly in /path-to-rt/etc/config.pm.


Mark Roedel | "Blessed is he who has learned to laugh
Systems Programmer | at himself, for he shall never cease
LeTourneau University | to be entertained."
Longview, Texas, USA | – John Powell

-----Original Message-----
From: Chris Mason [mailto:masonc@masonc.com]
Sent: Monday, September 09, 2002 3:37 PM
To: rt-users@lists.fsck.com
Subject: [rt-users] Installing as non-virual server

I’d like to install rt as a subfolder of main html server, rather than
virtual, as I don’t have any other need for virtual hosts. How hard is
that? I don’t see documentation on it, all the installation docs
presume a virtual host.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm