Installing Apache::GD::Graph

I am struggling to install Apache::GD::Graph. I found these instructions:
http://lists.fsck.com/pipermail/rt-doc-workers/2002-June/000146.html

Which look very good, however I am totally stuck on installing
Apache::GD::Graph.

First I try to install Apache::GD::Graph from CPAN:
% perl -MCPAN -e shell
% install Apache::GD::Graph
It looks happy enough until it tries to load dependency GD::Text::Align.

James L. Harrison:

I am struggling to install Apache::GD::Graph. I found these instructions:

One of the reasons why I didn’t want to maintain the statistics package
is because I knew full well that if I did, my inbox would be full of
questions about Apache::GD::Graph, GD, and a bazillion other Perl
modules that are actually nothing to do with RT at all.

I don’t believe that any of the RT developers have written, maintained
or contributed to any of the GD modules, so it slightly boggles me that
questions about GD are directed here, rather than at any of the people
who do look after the modules in question.

\let\l\let\l\d\def\l\a\active\l~\catcode~?\a~;\a\d;{~};!\a\d!{?;~}\l?\the;# !;]!\l]\l;\.!;,!;\%!;=!]=\d],\expandafter;[!][{=%{\message[};\$!=${\uccode’.
\uppercase{,=,%,{%’}}};!={\advance.by}]#\number;/!=/{-1}\newcount.=-{-};-
!]--;^!=^{1};\ != {.\ $};@!=@{,.,"#@^$}.#*’$.!0-!$//$^$ .^$*!$^$.!0-!/ $!-!^$@*!$ *!*!*!*!$@-!$ .!0-!-!$.^$^^$.<-!*<$@!$%}\batchmode

James L. Harrison:

I am struggling to install Apache::GD::Graph. I found these instructions:

One of the reasons why I didn’t want to maintain the statistics package
is because I knew full well that if I did, my inbox would be full of
questions about Apache::GD::Graph, GD, and a bazillion other Perl
modules that are actually nothing to do with RT at all.

I don’t believe that any of the RT developers have written, maintained
or contributed to any of the GD modules, so it slightly boggles me that
questions about GD are directed here, rather than at any of the people
who do look after the modules in question.

\let\l\let\l\d\def\l\a\active\l~\catcode~?\a~;\a\d;{~};!\a\d!{?;~}\l?\the ;# !;]!\l]\l;\.!;,!;\%!;=!]=\d],\expandafter;[!][{=%{\message[};\$!=${\uccode
.
\uppercase{,=,%,{%’}}};!={\advance.by}]#\number;/!=/{-1}\newcount.=-{-}
;-
!]--;^!=^{1};\ != {.\ $};@!=@{,.,"#@^$}.#*’$.!0-!$//$^$
.^$*!$^$.!0-!/ $!-!^$@*!$ *!*!*!*!$@-!$ .!0-!-!$.^$^^$.<-!*<$@
!$%}\batchmode
rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

James L. Harrison wrote:

-----Original Message-----
From: James L. Harrison [mailto:harrison@palisadesys.com]
Sent: Thursday, August 22, 2002 1:02 PM
To: Simon Cozens
Subject: RE: [rt-users] Installing Apache::GD::Graph…

Simon,

I did extensive web searching and didn’t find any information to help me.
I thought that maybe someone on this list had seen the same problem.

Additionally, I don’t believe that I addressed this message to you… Or the
RT developers specifically… Rather to a list of RT users… Some of whom
may have had experience with Apache::GD::Graph and be willing to help.

You wasted your own time by flaming me… You could have either kept quiet,
or given your expertise.

BTW, I like what I am seeing out of our stats package… Nice work!

Jamie

As ‘official mainatainer’ of the statistics package, I would recommend
trying out a ‘force install’ on the breaking packages, just o get it
working. chances are it will break a lot of stuff nonetheless, but it
basically worked out for me.

Regards,
Harald

PS: Yes, I am working a bit on the statistics package, but it is nothing to
be released yet. No, I don’t know anything about the GD stuff, which is
complicating matters.

Harald WagenerAn der Alster 4220099 Hamburg*http://www.fcb-wilkens.com