Installation rt-2-0-15 with fastcgi

Hello,

I have installed rt-2-0-15 with fastcgi.
Now - everything works fine since weeks

  • except for some requests : ist about 1%:

It seems there is a communication problem
betwenn fastcgi and mason_handler.fcgi.
The error log says:

[Mon Feb 17 12:57:07 2003] [error] [client 143.164.98.120] FastCGI: comm
with server “/usr/local/rt2/bin/mason_handler.fcgi” aborted: idle
timeout (300 sec)
[Mon Feb 17 12:57:07 2003] [error] [client 143.164.98.120] FastCGI:
incomplete headers (0 bytes) received from server
"/usr/local/rt2/bin/mason_handler.fcgi"
[Mon Feb 17 12:59:00 2003] [error] [client 212.86.197.105] FastCGI: comm
with server /usr/local/rt2/bin/mason_handler.fcgi" aborted: idle
timeout (300 sec)
[Mon Feb 17 12:59:00 2003] [error] [client 212.86.197.105] FastCGI:
incomplete headers (0 bytes) received from server
"/usr/local/rt2/bin/mason_handler.fcgi"
[Mon Feb 17 12:59:16 2003] [error] [client 143.164.98.120] FastCGI: comm
with server “/usr/local/rt2/bin/mason_handler.fcgi” aborted: idle
timeout (300 sec)
[Mon Feb 17 12:59:16 2003] [error] [client 143.164.98.120] FastCGI:
incomplete headers (0 bytes) received from server
"/usr/local/rt2/bin/mason_handler.fcgi"
[Mon Feb 17 13:00:00 2003] [error] [client 212.114.211.42] FastCGI: comm
with server “/usr/local/rt2/bin/mason_handler.fcgi” aborted: idle
timeout (300 sec)
[Mon Feb 17 13:00:00 2003] [error] [client 212.114.211.42] FastCGI:
incomplete headers (0 bytes) received from server
"/usr/local/rt2/bin/mason_handler.fcgi"

The user gets an ‘Internal Server Error’ message.
This is independently of the requested page.
This happens independently of the socket-type:
unix-pipes as well as tcp connections
between fastcgi and perl don’t work.

Has anyone a solution? I’d be eager for suggestions.

Kind Regards
Andreas

Andreas Warnke
3SOFT GmbH, Frauenweiherst. 14, 91058 Erlangen
Tel.: +49-9131-7701-274 mailto:Andreas.Warnke@3SOFT.de
Fax: +49-9131-7701-333 http://www.3SOFT.de

Hi Andreas,

The time I ran into that error with rt-2-0-15 on Solaris with fastcgi 

is when my scripts were trying to access a file that didn’t exist. The
situation was that we have several Solaris machines and the file systems
are all shared. One of the computers was down there for when RT tried to go
to …/computer-name/path/to/file via the web it hung and I started getting
those time out errors. Maybe you have a file that RT is trying to access
that it cannot. I can’t say exactly though since you are also getting the
incomplete header errors which I did not get.

 Try and see what those requests have in common, ie if they are trying 

to access the same page? the same ticket? etc. and maybe that will give you
a lead on the problem.

HTH
John

At 09:01 AM 2/24/2003, you wrote:

Hello,

I have installed rt-2-0-15 with fastcgi.
Now - everything works fine since weeks

  • except for some requests : ist about 1%:

It seems there is a communication problem
betwenn fastcgi and mason_handler.fcgi.
The error log says:

[Mon Feb 17 12:57:07 2003] [error] [client 143.164.98.120] FastCGI: comm
with server “/usr/local/rt2/bin/mason_handler.fcgi” aborted: idle
timeout (300 sec)
[Mon Feb 17 12:57:07 2003] [error] [client 143.164.98.120] FastCGI:
incomplete headers (0 bytes) received from server
"/usr/local/rt2/bin/mason_handler.fcgi"
[Mon Feb 17 12:59:00 2003] [error] [client 212.86.197.105] FastCGI: comm
with server /usr/local/rt2/bin/mason_handler.fcgi" aborted: idle
timeout (300 sec)
[Mon Feb 17 12:59:00 2003] [error] [client 212.86.197.105] FastCGI:
incomplete headers (0 bytes) received from server
"/usr/local/rt2/bin/mason_handler.fcgi"
[Mon Feb 17 12:59:16 2003] [error] [client 143.164.98.120] FastCGI: comm
with server “/usr/local/rt2/bin/mason_handler.fcgi” aborted: idle
timeout (300 sec)
[Mon Feb 17 12:59:16 2003] [error] [client 143.164.98.120] FastCGI:
incomplete headers (0 bytes) received from server
"/usr/local/rt2/bin/mason_handler.fcgi"
[Mon Feb 17 13:00:00 2003] [error] [client 212.114.211.42] FastCGI: comm
with server “/usr/local/rt2/bin/mason_handler.fcgi” aborted: idle
timeout (300 sec)
[Mon Feb 17 13:00:00 2003] [error] [client 212.114.211.42] FastCGI:
incomplete headers (0 bytes) received from server
"/usr/local/rt2/bin/mason_handler.fcgi"

The user gets an ‘Internal Server Error’ message.
This is independently of the requested page.
This happens independently of the socket-type:
unix-pipes as well as tcp connections
between fastcgi and perl don’t work.

Has anyone a solution? I’d be eager for suggestions.

Kind Regards
Andreas


Andreas Warnke
3SOFT GmbH, Frauenweiherst. 14, 91058 Erlangen
Tel.: +49-9131-7701-274 mailto:Andreas.Warnke@3SOFT.de
Fax: +49-9131-7701-333 http://www.3SOFT.de


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

<>< Proverbs 3:5 “Trust in the Lord with all your heart and lean not on
your own understanding;”