Installation of RT-Extension-SLA-0.03

I am having problems with getting RT to start again aftter installing The
SLA 0.03 extension.

I get the following error in the Web Logs.

[error] Require of RT::Condition::SLA_RequireDefault failed.\nCan’t locate
RT/Condition/SLA_RequireDefault.pm in @INC (@INC contains:
/usr/local/lib/rt3/lib /usr/local/lib/rt3/plugins/RT-FM/lib
/usr/local/lib/rt3/plugins/RT-IR/lib
/usr/local/lib/rt3/plugins/RT-Extension-JSGantt/lib /usr/share/perl5
/usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5
/usr/local/lib64/perl5/site_perl/5.10.0/x86_64-linux-thread-multi
/usr/local/lib/perl5/site_perl/5.10.0
/usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl /usr/lib/perl5/site_perl . /etc/httpd) at (eval
2651) line 2.\n\nCompilation failed in require at (eval 2) line 1.\n

I can’t seem to find where the path to the SLA_RequireDefault.pm needs to be
added so that RT will start.

Base OS is Fedora Core 14, web server Build
RT 3.8.8 installed via YUM
Mysqld installed via YUM
RTFM 2.4.2 installed
RT-IR 2.4.2 installed
RT-Authen-ExternalAuth-0.08 installed
RT-Action-NotifyGroup-0.02 installed
bestpractical-rt-extension-jsgantt0d1cacc1 installed

Gary L. Bristol
CISSP, CRISC, RHCE
405-623-9503

I am having problems with getting RT to start again aftter installing The SLA 0.03 extension.

I get the following error in the Web Logs.

You don’t appear to have added RT::Extension::SLA to your @Plugins
line with all the other extensions you have installed

-kevin

Kevin Falcone <falcone bestpractical.com> writes:

I am having problems with getting RT to start again aftter installing The
SLA 0.03 extension.

I get the following error in the Web Logs.

You don’t appear to have added RT::Extension::SLA to your @Plugins
line with all the other extensions you have installed

-kevin

[error] Require of RT::Condition::SLA_RequireDefault failed.\nCan’t locate
RT/Condition/SLA_RequireDefault.pm in @INC (@INC contains:
/usr/local/lib/rt3/lib

/usr/local/lib/rt3/plugins/RT-FM/lib /usr/local/lib/rt3/plugins/RT-IR/lib
/usr/local/lib/rt3/plugins/RT-Extension-JSGantt/lib /usr/share/perl5
/usr/local/lib64/perl5

/usr/local/share/perl5 /usr/lib64/perl5
/usr/local/lib64/perl5/site_perl/5.10.0/x86_64-linux-thread-multi
/usr/local/lib/perl5/site_perl/5.10.0
/usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl

/usr/lib/perl5/site_perl . /etc/httpd) at (eval 2651) line
2.\n\nCompilation failed in require

at (eval 2) line 1.\n

I can’t seem to find where the path to the SLA_RequireDefault.pm needs to
be added so that RT

will start.

Base OS is Fedora Core 14, web server Build
RT 3.8.8 installed via YUM
Mysqld installed via YUM
RTFM 2.4.2 installed
RT-IR 2.4.2 installed
RT-Authen-ExternalAuth-0.08 installed
RT-Action-NotifyGroup-0.02 installed
bestpractical-rt-extension-jsgantt0d1cacc1 installed

Gary L. Bristol
CISSP, CRISC, RHCE
405-623-9503

Hi Kevin, I am having the same issue and struggling for the past few days
without any luck, appreciate if you can point me in the right direction

Thanks and Best Regards

i’m dealing with missing @INC by adding a line such this one at the
begining of the RT_SiteConfig.pm file :

use lib ‘/opt/rt3/local/plugins/xxxyourplguin/lib’;

and there it goes, RT si starting ok

Rapha�l

Message: 8Date: Wed, 6 Apr 2011 06:05:40 +0000 (UTC)
From: Asanka asanka_gunasekera@yahoo.co.uk
To: rt-users@lists.fsck.com
Subject: Re: [rt-users] installation of RT-Extension-SLA-0.03
Message-ID: loom.20110406T080133-835@post.gmane.org
Content-Type: text/plain; charset=us-ascii

Kevin Falcone <falcone bestpractical.com> writes:

I am having problems with getting RT to start again aftter
installing The
SLA 0.03 extension.

I get the following error in the Web Logs.

You don’t appear to have added RT::Extension::SLA to your @Plugins
line with all the other extensions you have installed

-kevin

[error] Require of RT::Condition::SLA_RequireDefault failed.\nCan’t
locate

RT/Condition/SLA_RequireDefault.pm in @INC (@INC contains:
/usr/local/lib/rt3/lib

/usr/local/lib/rt3/plugins/RT-FM/lib
/usr/local/lib/rt3/plugins/RT-IR/lib

/usr/local/lib/rt3/plugins/RT-Extension-JSGantt/lib
/usr/share/perl5
/usr/local/lib64/perl5

/usr/local/share/perl5 /usr/lib64/perl5
/usr/local/lib64/perl5/site_perl/5.10.0/x86_64-linux-thread-multi
/usr/local/lib/perl5/site_perl/5.10.0
/usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl

/usr/lib/perl5/site_perl . /etc/httpd) at (eval 2651) line
2.\n\nCompilation failed in require

at (eval 2) line 1.\n

I can’t seem to find where the path to the SLA_RequireDefault.pm
needs to
be added so that RT

will start.

Base OS is Fedora Core 14, web server Build
RT 3.8.8 installed via YUM
Mysqld installed via YUM
RTFM 2.4.2 installed
RT-IR 2.4.2 installed
RT-Authen-ExternalAuth-0.08 installed
RT-Action-NotifyGroup-0.02 installed
bestpractical-rt-extension-jsgantt0d1cacc1 installed

Gary L. Bristol
CISSP, CRISC, RHCE
405-623-9503

Hi Kevin, I am having the same issue and struggling for the past few days
without any luck, appreciate if you can point me in the right direction

Thanks and Best Regards
" Ce courriel et les documents qui lui sont joints peuvent contenir des
informations confidentielles ou ayant un caract�re priv�. S’ils ne vous sont
pas destin�s, nous vous signalons qu’il est strictement interdit de les
divulguer, de les reproduire ou d’en utiliser de quelque mani�re que ce
soit le contenu. Si ce message vous a �t� transmis par erreur, merci d’en
informer l’exp�diteur et de supprimer imm�diatement de votre syst�me
informatique ce courriel ainsi que tous les documents qui y sont attach�s."

" This e-mail and any attached documents may contain confidential or
proprietary information. If you are not the intended recipient, you are
notified that any dissemination, copying of this e-mail and any attachments
thereto or use of their contents by any means whatsoever is strictly
prohibited. If you have received this e-mail in error, please advise the
sender immediately and delete this e-mail and all attached documents
from your computer system."

Raphaël MOUNEYRES <raphael.mouneyres sagemcom.com> writes:

i’m dealing with missing INC by adding
a line such this one at the begining of the RT_SiteConfig.pm file :
use lib ‘/opt/rt3/local/plugins/xxxyourplguin/lib’;
and there it goes, RT si starting ok
Raphaël

Hi Raphaël, I added a line as below but the error still
comes and RT would not start

use lib’/usr/local/rt-3.8.8-ora/local/plugins/RT-Extension-SLA/lib’;

try with a space afeter “lib” and with a leading /, i forgotted to mention
that

so your line would be :
use lib ‘/usr/local/rt-3.8.8-ora/local/plugins/RT-Extension-SLA/lib/’;

and maybe also verify that SLA_RequireDefault.pm really is in this
directory

Rapha�l

i’m dealing with missing INC by adding
a line such this one at the begining of the RT_SiteConfig.pm file :
use lib ‘/opt/rt3/local/plugins/xxxyourplguin/lib’;
and there it goes, RT si starting ok
Rapha?l

Hi Rapha?l, I added a line as below but the error still
comes and RT would not start

use lib’/usr/local/rt-3.8.8-ora/local/plugins/RT-Extension-SLA/lib’;

" Ce courriel et les documents qui lui sont joints peuvent contenir des
informations confidentielles ou ayant un caract�re priv�. S’ils ne vous sont
pas destin�s, nous vous signalons qu’il est strictement interdit de les
divulguer, de les reproduire ou d’en utiliser de quelque mani�re que ce
soit le contenu. Si ce message vous a �t� transmis par erreur, merci d’en
informer l’exp�diteur et de supprimer imm�diatement de votre syst�me
informatique ce courriel ainsi que tous les documents qui y sont attach�s."

" This e-mail and any attached documents may contain confidential or
proprietary information. If you are not the intended recipient, you are
notified that any dissemination, copying of this e-mail and any attachments
thereto or use of their contents by any means whatsoever is strictly
prohibited. If you have received this e-mail in error, please advise the
sender immediately and delete this e-mail and all attached documents
from your computer system."

Raphaël MOUNEYRES <raphael.mouneyres sagemcom.com> writes:

try with a space afeter “lib” and with a
leading /, i forgotted to mention that
so your line would be :
use lib ‘/usr/local/rt-3.8.8-ora/local/plugins/RT-Extension-SLA/lib/’;
and maybe also verify that SLA_RequireDefault.pm really
is in this directory
Raphaël

Hi Raphaël

I did try all that with out any luck and the file it looking
for is under

/usr/local/rt-3.8.8-ora/local/plugins/RT-Extension-SLA/
lib/RT/Condition/SLA_RequireDefault.pm

Apache is running as apache:apache and the permission
is there too

I am totally lost on this

i’m dealing with missing @INC by adding a line such this one at the begining of the
RT_SiteConfig.pm file :

use lib ‘/opt/rt3/local/plugins/xxxyourplguin/lib’;

This should never be required if you’ve configured @Plugins correctly

-kevin

Hi,

Go to Configuration -> Tools -> System Configuration and make sure
@Plugins option lists all extensions you’re using.On Wed, Apr 6, 2011 at 10:05 AM, Asanka asanka_gunasekera@yahoo.co.uk wrote:

Kevin Falcone <falcone bestpractical.com> writes:

On Wed, Jan 12, 2011 at 09:35:41PM -0600, Gary Bristol wrote:

I am having problems with getting RT to start again aftter installing The
SLA 0.03 extension.

I get the following error in the Web Logs.

You don’t appear to have added RT::Extension::SLA to your @Plugins
line with all the other extensions you have installed

-kevin

[error] Require of RT::Condition::SLA_RequireDefault failed.\nCan’t locate
RT/Condition/SLA_RequireDefault.pm in @INC (@INC contains:
/usr/local/lib/rt3/lib

/usr/local/lib/rt3/plugins/RT-FM/lib /usr/local/lib/rt3/plugins/RT-IR/lib
/usr/local/lib/rt3/plugins/RT-Extension-JSGantt/lib /usr/share/perl5
/usr/local/lib64/perl5

/usr/local/share/perl5 /usr/lib64/perl5
/usr/local/lib64/perl5/site_perl/5.10.0/x86_64-linux-thread-multi
/usr/local/lib/perl5/site_perl/5.10.0
/usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl

/usr/lib/perl5/site_perl . /etc/httpd) at (eval 2651) line
2.\n\nCompilation failed in require

at (eval 2) line 1.\n

I can’t seem to find where the path to the SLA_RequireDefault.pm needs to
be added so that RT

will start.

Base OS is Fedora Core 14, web server Build
RT 3.8.8 installed via YUM
Mysqld installed via YUM
RTFM 2.4.2 installed
RT-IR 2.4.2 installed
RT-Authen-ExternalAuth-0.08 installed
RT-Action-NotifyGroup-0.02 installed
bestpractical-rt-extension-jsgantt0d1cacc1 installed

Gary L. Bristol
CISSP, CRISC, RHCE
405-623-9503

Hi Kevin, I am having the same issue and struggling for the past few days
without any luck, appreciate if you can point me in the right direction

Thanks and Best Regards

Best regards, Ruslan.

Asanka <asanka_gunasekera yahoo.co.uk> writes:

Hi all found the solution by writing to the author, all that I had to do was add
RT::Extension::SLA to @plugin

Set(@Plugins, qw(
RT::Authen::ExternalAuth
RT::Extension::SLA
) );

and it works!!!

Thank you all for your help
Best Regards