Install problems

I’ve installed RT 3.8.14 and RTIR 2.6.1 and followed the instructions in
the relevant README files.

When connecting I see the RT login page and I can log in as root, but
even after installing RTIR, there is RTIR at a glance option or an RTIR
view of tickets etc.

I’ve added RT::IR to the list of plugins in the RT_Siteconfig file.

In an older version I had to do a require to pull in an RTIR_COnfig file
but that doesn’t seem to exist.

Any clues please?

Regards,
Tony.
Tony Arnold, Tel: +44 (0) 161 275 6093
Head of IT Security, Fax: +44 (0) 705 344 3082
University of Manchester, Mob: +44 (0) 773 330 0039
Manchester M13 9PL. Email: tony.arnold@manchester.ac.uk

I’ve installed RT 3.8.14 and RTIR 2.6.1 and followed the instructions in
the relevant README files.

When connecting I see the RT login page and I can log in as root, but
even after installing RTIR, there is RTIR at a glance option or an RTIR
view of tickets etc.

I’ve added RT::IR to the list of plugins in the RT_Siteconfig file.

In an older version I had to do a require to pull in an RTIR_COnfig file
but that doesn’t seem to exist.

Any clues please?

It exists in local/plugins/RT-IR/etc and you don’t need to pull it anymore.

For customizations of those options you either use RT_SiteConfig.pm or
RTIR_SiteConfig.pm file. The latter file you can create in main etc dir or
plugin’s.

Regards,
Tony.

Tony Arnold, Tel: +44 (0) 161 275 6093
Head of IT Security, Fax: +44 (0) 705 344 3082
University of Manchester, Mob: +44 (0) 773 330 0039
Manchester M13 9PL. Email: tony.arnold@manchester.ac.uk


Rtir mailing list
Rtir@lists.bestpractical.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rtir

Best regards, Ruslan.

Ruslan,

Thanks. I’ve found my config file!

But by default I still get the RT view, not the RTIR. If I go to
my.site/RTIR/index.html I get the RTIR at a glance view but then I click
on an incident and I get the RT view of an incident. How can I make this
the default and ensure I get RTIR view every time?

Regards,
Tony.On 11/10/12 21:17, Ruslan Zakirov wrote:

On Thu, Oct 11, 2012 at 11:40 PM, Tony Arnold tony.arnold@manchester.ac.uk wrote:

I’ve installed RT 3.8.14 and RTIR 2.6.1 and followed the instructions in
the relevant README files.

When connecting I see the RT login page and I can log in as root, but
even after installing RTIR, there is RTIR at a glance option or an RTIR
view of tickets etc.

I’ve added RT::IR to the list of plugins in the RT_Siteconfig file.

In an older version I had to do a require to pull in an RTIR_COnfig file
but that doesn’t seem to exist.

Any clues please?

It exists in local/plugins/RT-IR/etc and you don’t need to pull it anymore.

For customizations of those options you either use RT_SiteConfig.pm or
RTIR_SiteConfig.pm file. The latter file you can create in main etc dir or
plugin’s.

Regards,
Tony.

Tony Arnold, Tel: +44 (0) 161 275 6093
Head of IT Security, Fax: +44 (0) 705 344 3082
University of Manchester, Mob: +44 (0) 773 330 0039
Manchester M13 9PL. Email: tony.arnold@manchester.ac.uk


Rtir mailing list
Rtir@lists.bestpractical.com
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rtir

Tony Arnold, Tel: +44 (0) 161 275 6093
Head of IT Security, Fax: +44 (0) 705 344 3082
University of Manchester, Mob: +44 (0) 773 330 0039
Manchester M13 9PL. Email: tony.arnold@manchester.ac.uk

But by default I still get the RT view, not the RTIR.

RTIR doesn’t change your default homepage. Many people bookmark
/RTIR/index.html or make some minor local modifications to redirect.

If I go to my.site/RTIR/index.html I get the RTIR at a glance view but
then I click on an incident and I get the RT view of an incident. How
can I make this the default and ensure I get RTIR view every time?

Can you explain what you mean by “the RT view” ?

Please provide the URL of the incident, as well as an explanation of
what is different about the view.

-kevin

Kevin,

But by default I still get the RT view, not the RTIR.

RTIR doesn’t change your default homepage. Many people bookmark
/RTIR/index.html or make some minor local modifications to redirect.

OK, I can do that. ON the default home page should there be a menu item
to take you to RTIR? I can’t see on on my system and there was on a much
older version that we run.

If I go to my.site/RTIR/index.html I get the RTIR at a glance view but
then I click on an incident and I get the RT view of an incident. How
can I make this the default and ensure I get RTIR view every time?

Can you explain what you mean by “the RT view” ?

When looking at an incident report, I would expect to see details about
the incident it is linked to, options for launching an investigation and
blocks, but there is none of that. Also, I would expect IP addresses etc
to have options in square brackets to look up the IP address or block it
etc, again, not showing.

Please provide the URL of the incident, as well as an explanation of
what is different about the view.

Here is a sample URL http://my.uni.ac.uk/Ticket/Display.html?id=3

You can find a screenshot here:

http://picpaste.com/Screenshot_from_2012-10-12_08_09_02-vQKlS4Sp.png

Thanks for your help.

Regards,
Tony.
Tony Arnold, Tel: +44 (0) 161 275 6093
Head of IT Security, Fax: +44 (0) 705 344 3082
University of Manchester, Mob: +44 (0) 773 330 0039
Manchester M13 9PL. Email: tony.arnold@manchester.ac.uk

OK, I can do that. ON the default home page should there be a menu item
to take you to RTIR? I can’t see on on my system and there was on a much
older version that we run.

There is a menu. Based on your screenshot, I’m surprised you can go
to RTIR/index.html and have it work at all.

http://picpaste.com/Screenshot_from_2012-10-12_08_09_02-vQKlS4Sp.png

This is what that should look like
http://user.bestpractical.com/~falcone/tmp/2012-10-12nI3ESL4p-rtir.png

So, let’s back up to exactly how you installed RTIR.

-kevin

Kevin,

OK, I can do that. ON the default home page should there be a menu item
to take you to RTIR? I can’t see on on my system and there was on a much
older version that we run.

There is a menu. Based on your screenshot, I’m surprised you can go
to RTIR/index.html and have it work at all.

Nope, no menu for RTIR!

http://picpaste.com/Screenshot_from_2012-10-12_08_09_02-vQKlS4Sp.png

This is what that should look like
http://user.bestpractical.com/~falcone/tmp/2012-10-12nI3ESL4p-rtir.png

So, let’s back up to exactly how you installed RTIR.

I basically followed the instructions in the README file. Similarly for
RTFM which also doesn’t show up in the menu.

Unpacked the tar ball; ran ‘perl Makefile.PL’; installed some missing
perl modules such as the business hours, business SLA and the Regex CIDR
modules; I ran the Makefile.PL again to confirm the missing modules were
now there and it reported all was OK.

I then ran ‘make install’ followed by ‘make initdb’. I also modified the
RT_SiteConfig.pm file to set @Plugins to include RT::FM and RT::IR.
Finally I restarted the Apache web server.

I didn’t install any of the suggested extensions. Neither did I do any
configuring.

Step 5 of the Configuring RTIR section of the README mentions a
"require" line. I presume this means the Set(@Plugins line?

And that’s it.

All of the above was done as root on the machine. RT etc is installed in
/opt/rt3/

Regards,
Tony.
Tony Arnold, Tel: +44 (0) 161 275 6093
Head of IT Security, Fax: +44 (0) 705 344 3082
University of Manchester, Mob: +44 (0) 773 330 0039
Manchester M13 9PL. Email: tony.arnold@manchester.ac.uk

I then ran ‘make install’ followed by ‘make initdb’. I also modified the
RT_SiteConfig.pm file to set @Plugins to include RT::FM and RT::IR.
Finally I restarted the Apache web server.

The two most common errors around this would be having multiple
Plugins lines and forgetting to clear your mason cache.
I suggest checking the former by going to the System Configuration
page and checking what plugins RT believes are loaded, and the latter by
deleting everything in /opt/rt3/var/mason_data/obj/.

-kevin

I then ran ‘make install’ followed by ‘make initdb’. I also modified the
RT_SiteConfig.pm file to set @Plugins to include RT::FM and RT::IR.
Finally I restarted the Apache web server.

The two most common errors around this would be having multiple
Plugins lines and forgetting to clear your mason cache.
I suggest checking the former by going to the System Configuration
page and checking what plugins RT believes are loaded, and the latter by
deleting everything in /opt/rt3/var/mason_data/obj/.

I’ve checked both of these but it’s still not working. I’m wondering if
I should re-install everything from scratch?

I’ve attached a pdf of the system configuration page. Could you cast an
eye over it and see if there is anything obviously wrong please?

Putting this back on list.

Since your configuration looks ok, you’re now stuck with weird “RT can
read local libraries but not mason files” if you’re not seeing the
menus you’d expect. Check for both permission problems and SELinux
problems where apache can’t load things.

-kevin

I’m attempting to install RT 3.10 on a Suse 9.3 box to prepare for a
hardware migration.
Perl=5.87 Apache=2.0.52 mod_perl=2.0.1

My dependencies check has come up clean, I’ve installed the RT software,
and I’m now attempting to bring up Apache after configuring the RT host.
I’ve had a series of @INC errors, which I’ve been able to resolve by
tweaking paths, but I’m now stumped. I’m getting this error on apache
start:
[Tue Jan 24 14:16:25 2006] [error] Can’t locate Apache/compat.pm in @INC
(@INC
contains: /usr/lib/perl5/site_perl/5.8.7/i686-linux/Bundle/ /usr/local/rt3/local/lib /usr/local/rt3/lib /usr/lib/perl5/5.8.7/i686-linux /usr/lib/perl5/5.8.7 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl . /usr/local/apache2) at (eval 221) line 3.\n

I have an Apache2/compat.pm installed. Can anyone tell me what might be
pointing Apache in the wrong direction?

TIA

DT
Dave Thacker, Senior Systems Administrator
Omni Hotels Reservation Center
V: 402.952.6535 F: 402-334-8013 M: 402-981-4613 (24/7)