Install problems rt-2-1-84

Hi Folks!

I’m setting up a test installation on the same server as my rt-2-0-12
installation. Make install went well. Trying to make
initialize-database, and I get the following error:

make initialize-database

/usr/bin/perl //usr/local/rt3/sbin/rt-setup-database --action init --dba
root – prompt-for-dba-password Can’t locate Encode/compat.pm in @INC
(@INC contains: /usr/local/rt3/lib /usr/lo
cal/lib/perl5/5.6.1/sun4-solaris /usr/local/lib/perl5/5.6.1
/usr/local/lib/perl5 /site_perl/5.6.1/sun4-solaris
/usr/local/lib/perl5/site_perl/5.6.1 /usr/local/li b/perl5/site_perl .)
at /usr/local/rt3/lib/RT/I18N.pm line 40. BEGIN failed–compilation
aborted at /usr/local/rt3/lib/RT/I18N.pm line 42. Compilation failed in
require at /usr/local/rt3/lib/RT.pm line 29. BEGIN failed–compilation
aborted at /usr/local/rt3/lib/RT.pm line 29. Compilation failed in
require at //usr/local/rt3/sbin/rt-setup-database line 37. BEGIN
failed–compilation aborted at //usr/local/rt3/sbin/rt-setup-database
line 37.
make: *** [initialize-database] Error 2

Just wondering if it’s a bug, or something in my set-up.

Existing set-up is rt-2-0-12 (customized) with mysql, apache,
mod_perl1.26. Testing of beta rt3 will be with fastcgi. I have
customized RT_SiteConfig.pm, but haven’t done the httpd.conf file yet,
since I can’t get the database installed.

Hope that helps!

/Mike

-----BEGIN PGP SIGNED MESSAGE-----On 11-Mar-2003 Michael K. Brown wrote:

Can’t locate Encode/compat.pm

You haven’t finished with your dependencies. Install this perl module.


Andy Harrison
Great Works Internet
System Operations
ajharrison@gwi.net
RSA 1024 pgp key: http://www.nachoz.com/andy.pub

-----BEGIN PGP SIGNATURE-----
Version: PGP 6.5.8

iQCVAwUBPm4UxVPEkLgodAWVAQFUAwQArkrD2ZAZcT569eJmpTyJm37jWE7cTENJ
ToGYbl1bThnVemdL23CGpv1e3y6US2CWtbENWWYP4kOMoBUJvShNgHlKg11lumVD
/24cZaJH40FbVuGExzVntYJHwKNRtYZ8s9AUce1OYuQAr+2OwYx9WuDgc9xoj2wD
0swbtCD9hC4=
=CrCk
-----END PGP SIGNATURE-----

OK… I had run the automated install of dependencies, and now that I’m
trying to install manually, I’m seeing where there were some problems.
Here’s the results from the attempted install from CPAN:

cpan> install Encode::compat
CPAN: Storable loaded ok
Going to read /var/tmp/.cpan/Metadata
Database was generated on Mon, 10 Mar 2003 13:40:55 GMT
Running install for module Encode::compat
Running make for A/AU/AUTRIJUS/Encode-compat-0.05.tar.gz
CPAN: MD5 loaded ok
CPAN: Compress::Zlib loaded ok
Checksum for
/var/tmp/.cpan/sources/authors/id/A/AU/AUTRIJUS/Encode-compat-0.05.
tar.gz ok
x Encode-compat-0.05, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib/Encode, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib/Encode/compat, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib/Encode/compat/common.pm, 2570 bytes, 6 tape
blocks
x Encode-compat-0.05/lib/Encode/compat/5006001.pm, 583 bytes, 2 tape
blocks
x Encode-compat-0.05/lib/Encode/compat/Alias.pm, 9723 bytes, 19 tape
blocks
x Encode-compat-0.05/lib/Encode/compat.pm, 2338 bytes, 5 tape blocks
x Encode-compat-0.05/Changes, 3511 bytes, 7 tape blocks
x Encode-compat-0.05/t, 0 bytes, 0 tape blocks
x Encode-compat-0.05/t/1-basic.t, 610 bytes, 2 tape blocks
x Encode-compat-0.05/MANIFEST, 184 bytes, 1 tape blocks
x Encode-compat-0.05/Makefile.PL, 652 bytes, 2 tape blocks
x Encode-compat-0.05/README, 672 bytes, 2 tape blocks
x Encode-compat-0.05/SIGNATURE, 1289 bytes, 3 tape blocks

CPAN.pm: Going to build A/AU/AUTRIJUS/Encode-compat-0.05.tar.gz

Checking if your kit is complete…
Looks good
Writing Makefile for Encode::compat
cp lib/Encode/compat/5006001.pm blib/lib/Encode/compat/5006001.pm
cp lib/Encode/compat/common.pm blib/lib/Encode/compat/common.pm
cp lib/Encode/compat/Alias.pm blib/lib/Encode/compat/Alias.pm
cp lib/Encode/compat.pm blib/lib/Encode/compat.pm
Manifying blib/man3/Encode::compat::Alias.3
Manifying blib/man3/Encode::compat.3
/usr/local/bin/make -j3 – OK
Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
-I/usr/local/lib/perl5/5.
6.1/sun4-solaris -I/usr/local/lib/perl5/5.6.1 -e ‘use Test::Harness
qw(&runtests
$verbose); $verbose=0; runtests @ARGV;’ t/*.t
t/1-basic…ok 2/8Unsupported conversion: Invalid argument at
blib/lib/Encode/c
ompat/common.pm line 115.
t/1-basic…dubious
Test returned status 22 (wstat 5632, 0x1600)
DIED. FAILED tests 3-8
Failed 6/8 tests, 25.00% okay
Failed Test Stat Wstat Total Fail Failed List of Failed
t/1-basic.t 22 5632 8 6 75.00% 3-8
Failed 1/1 test scripts, 0.00% okay. 6/8 subtests failed, 25.00% okay.
make: *** [test_dynamic] Error 2
/usr/local/bin/make test – NOT OK
Running make install
make test had returned bad status, won’t install without force

cpan>

Wondering if anyone can help me here.

Thanks for your time!

/Mike-----Original Message-----
From: Michael K. Brown [mailto:michael.k.brown@alcatel.com]
Sent: Tuesday, March 11, 2003 11:48 AM
To: Rt-Users (rt-users@lists.fsck.com)
Subject: Install problems rt-2-1-84

Hi Folks!

I’m setting up a test installation on the same server as my rt-2-0-12
installation. Make install went well. Trying to make
initialize-database, and I get the following error:

make initialize-database

/usr/bin/perl //usr/local/rt3/sbin/rt-setup-database --action init --dba
root – prompt-for-dba-password Can’t locate Encode/compat.pm in @INC
(@INC contains: /usr/local/rt3/lib /usr/lo
cal/lib/perl5/5.6.1/sun4-solaris /usr/local/lib/perl5/5.6.1
/usr/local/lib/perl5 /site_perl/5.6.1/sun4-solaris
/usr/local/lib/perl5/site_perl/5.6.1 /usr/local/li b/perl5/site_perl .)
at /usr/local/rt3/lib/RT/I18N.pm line 40. BEGIN failed–compilation
aborted at /usr/local/rt3/lib/RT/I18N.pm line 42. Compilation failed in
require at /usr/local/rt3/lib/RT.pm line 29. BEGIN failed–compilation
aborted at /usr/local/rt3/lib/RT.pm line 29. Compilation failed in
require at //usr/local/rt3/sbin/rt-setup-database line 37. BEGIN
failed–compilation aborted at //usr/local/rt3/sbin/rt-setup-database
line 37.
make: *** [initialize-database] Error 2

Just wondering if it’s a bug, or something in my set-up.

Existing set-up is rt-2-0-12 (customized) with mysql, apache,
mod_perl1.26. Testing of beta rt3 will be with fastcgi. I have
customized RT_SiteConfig.pm, but haven’t done the httpd.conf file yet,
since I can’t get the database installed.

Hope that helps!

/Mike

Maybe you need a new Test::Harness? or an older one?-----Original Message-----
From: Michael K. Brown [mailto:michael.k.brown@alcatel.com]
Sent: Tue, March 11, 2003 7:11 PM
To: Rt-Users
Subject: [rt-users] RE: Install problems rt-2-1-84

OK… I had run the automated install of dependencies, and now that I’m
trying to install manually, I’m seeing where there were some problems.
Here’s the results from the attempted install from CPAN:

cpan> install Encode::compat
CPAN: Storable loaded ok
Going to read /var/tmp/.cpan/Metadata
Database was generated on Mon, 10 Mar 2003 13:40:55 GMT
Running install for module Encode::compat
Running make for A/AU/AUTRIJUS/Encode-compat-0.05.tar.gz
CPAN: MD5 loaded ok
CPAN: Compress::Zlib loaded ok
Checksum for
/var/tmp/.cpan/sources/authors/id/A/AU/AUTRIJUS/Encode-compat-0.05.
tar.gz ok
x Encode-compat-0.05, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib/Encode, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib/Encode/compat, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib/Encode/compat/common.pm, 2570 bytes, 6 tape
blocks
x Encode-compat-0.05/lib/Encode/compat/5006001.pm, 583 bytes, 2 tape
blocks
x Encode-compat-0.05/lib/Encode/compat/Alias.pm, 9723 bytes, 19 tape
blocks
x Encode-compat-0.05/lib/Encode/compat.pm, 2338 bytes, 5 tape blocks
x Encode-compat-0.05/Changes, 3511 bytes, 7 tape blocks
x Encode-compat-0.05/t, 0 bytes, 0 tape blocks
x Encode-compat-0.05/t/1-basic.t, 610 bytes, 2 tape blocks
x Encode-compat-0.05/MANIFEST, 184 bytes, 1 tape blocks
x Encode-compat-0.05/Makefile.PL, 652 bytes, 2 tape blocks
x Encode-compat-0.05/README, 672 bytes, 2 tape blocks
x Encode-compat-0.05/SIGNATURE, 1289 bytes, 3 tape blocks

CPAN.pm: Going to build A/AU/AUTRIJUS/Encode-compat-0.05.tar.gz

Checking if your kit is complete…
Looks good
Writing Makefile for Encode::compat
cp lib/Encode/compat/5006001.pm blib/lib/Encode/compat/5006001.pm
cp lib/Encode/compat/common.pm blib/lib/Encode/compat/common.pm
cp lib/Encode/compat/Alias.pm blib/lib/Encode/compat/Alias.pm
cp lib/Encode/compat.pm blib/lib/Encode/compat.pm
Manifying blib/man3/Encode::compat::Alias.3
Manifying blib/man3/Encode::compat.3
/usr/local/bin/make -j3 – OK
Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
-I/usr/local/lib/perl5/5.
6.1/sun4-solaris -I/usr/local/lib/perl5/5.6.1 -e ‘use Test::Harness
qw(&runtests
$verbose); $verbose=0; runtests @ARGV;’ t/*.t
t/1-basic…ok 2/8Unsupported conversion: Invalid argument at
blib/lib/Encode/c
ompat/common.pm line 115.
t/1-basic…dubious
Test returned status 22 (wstat 5632, 0x1600)
DIED. FAILED tests 3-8
Failed 6/8 tests, 25.00% okay
Failed Test Stat Wstat Total Fail Failed List of Failed
t/1-basic.t 22 5632 8 6 75.00% 3-8
Failed 1/1 test scripts, 0.00% okay. 6/8 subtests failed, 25.00% okay.
make: *** [test_dynamic] Error 2
/usr/local/bin/make test – NOT OK
Running make install
make test had returned bad status, won’t install without force

cpan>

Wondering if anyone can help me here.

Thanks for your time!

/Mike

-----Original Message-----
From: Michael K. Brown [mailto:michael.k.brown@alcatel.com]
Sent: Tuesday, March 11, 2003 11:48 AM
To: Rt-Users (rt-users@lists.fsck.com)
Subject: Install problems rt-2-1-84

Hi Folks!

I’m setting up a test installation on the same server as my rt-2-0-12
installation. Make install went well. Trying to make
initialize-database, and I get the following error:

make initialize-database

/usr/bin/perl //usr/local/rt3/sbin/rt-setup-database --action init --dba
root – prompt-for-dba-password Can’t locate Encode/compat.pm in @INC
(@INC contains: /usr/local/rt3/lib /usr/lo
cal/lib/perl5/5.6.1/sun4-solaris /usr/local/lib/perl5/5.6.1
/usr/local/lib/perl5 /site_perl/5.6.1/sun4-solaris
/usr/local/lib/perl5/site_perl/5.6.1 /usr/local/li b/perl5/site_perl .)
at /usr/local/rt3/lib/RT/I18N.pm line 40. BEGIN failed–compilation
aborted at /usr/local/rt3/lib/RT/I18N.pm line 42. Compilation failed in
require at /usr/local/rt3/lib/RT.pm line 29. BEGIN failed–compilation
aborted at /usr/local/rt3/lib/RT.pm line 29. Compilation failed in
require at //usr/local/rt3/sbin/rt-setup-database line 37. BEGIN
failed–compilation aborted at //usr/local/rt3/sbin/rt-setup-database
line 37.
make: *** [initialize-database] Error 2

Just wondering if it’s a bug, or something in my set-up.

Existing set-up is rt-2-0-12 (customized) with mysql, apache,
mod_perl1.26. Testing of beta rt3 will be with fastcgi. I have
customized RT_SiteConfig.pm, but haven’t done the httpd.conf file yet,
since I can’t get the database installed.

Hope that helps!

/Mike

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Hi folks!

I did a cpan > force install Encode::compat, and that seemed to install
OK, even though the tests complained. I’ve installed rt-2-1-85, and
I’ll see how that goes when I finish configuring it…

I’m looking at running it using fastcgi, under the same apache instance
as rt-2-0-12/apache/mod_perl1.26. Will that cause me problems, or
should I do something different?

Thanks again for all the help!

/Mike-----Original Message-----
From: Michael K. Brown [mailto:michael.k.brown@alcatel.com]
Sent: Tuesday, March 11, 2003 12:11 PM
To: Rt-Users (rt-users@lists.fsck.com)
Subject: RE: Install problems rt-2-1-84

OK… I had run the automated install of dependencies, and now that I’m
trying to install manually, I’m seeing where there were some problems.
Here’s the results from the attempted install from CPAN:

cpan> install Encode::compat
CPAN: Storable loaded ok
Going to read /var/tmp/.cpan/Metadata
Database was generated on Mon, 10 Mar 2003 13:40:55 GMT Running
install for module Encode::compat Running make for
A/AU/AUTRIJUS/Encode-compat-0.05.tar.gz
CPAN: MD5 loaded ok
CPAN: Compress::Zlib loaded ok
Checksum for
/var/tmp/.cpan/sources/authors/id/A/AU/AUTRIJUS/Encode-compat-0.05.
tar.gz ok
x Encode-compat-0.05, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib/Encode, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib/Encode/compat, 0 bytes, 0 tape blocks x
Encode-compat-0.05/lib/Encode/compat/common.pm, 2570 bytes, 6 tape
blocks x Encode-compat-0.05/lib/Encode/compat/5006001.pm, 583 bytes, 2
tape blocks x Encode-compat-0.05/lib/Encode/compat/Alias.pm, 9723 bytes,
19 tape blocks x Encode-compat-0.05/lib/Encode/compat.pm, 2338 bytes, 5
tape blocks x Encode-compat-0.05/Changes, 3511 bytes, 7 tape blocks x
Encode-compat-0.05/t, 0 bytes, 0 tape blocks x
Encode-compat-0.05/t/1-basic.t, 610 bytes, 2 tape blocks x
Encode-compat-0.05/MANIFEST, 184 bytes, 1 tape blocks x
Encode-compat-0.05/Makefile.PL, 652 bytes, 2 tape blocks x
Encode-compat-0.05/README, 672 bytes, 2 tape blocks x
Encode-compat-0.05/SIGNATURE, 1289 bytes, 3 tape blocks

CPAN.pm: Going to build A/AU/AUTRIJUS/Encode-compat-0.05.tar.gz

Checking if your kit is complete…
Looks good
Writing Makefile for Encode::compat
cp lib/Encode/compat/5006001.pm blib/lib/Encode/compat/5006001.pm cp
lib/Encode/compat/common.pm blib/lib/Encode/compat/common.pm cp
lib/Encode/compat/Alias.pm blib/lib/Encode/compat/Alias.pm cp
lib/Encode/compat.pm blib/lib/Encode/compat.pm Manifying
blib/man3/Encode::compat::Alias.3 Manifying blib/man3/Encode::compat.3
/usr/local/bin/make -j3 – OK
Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
-I/usr/local/lib/perl5/5. 6.1/sun4-solaris -I/usr/local/lib/perl5/5.6.1
-e ‘use Test::Harness qw(&runtests $verbose); $verbose=0; runtests
@ARGV;’ t/*.t t/1-basic…ok 2/8Unsupported conversion: Invalid
argument at blib/lib/Encode/c ompat/common.pm line 115.
t/1-basic…dubious
Test returned status 22 (wstat 5632, 0x1600)
DIED. FAILED tests 3-8
Failed 6/8 tests, 25.00% okay
Failed Test Stat Wstat Total Fail Failed List of Failed
t/1-basic.t 22 5632 8 6 75.00% 3-8
Failed 1/1 test scripts, 0.00% okay. 6/8 subtests failed, 25.00% okay.
make: *** [test_dynamic] Error 2
/usr/local/bin/make test – NOT OK
Running make install
make test had returned bad status, won’t install without force

cpan>

Wondering if anyone can help me here.

Thanks for your time!

/Mike

I have same problem. Manual install of Encode-compat-0.05:

make test

PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib -I/opt/gnu/lib/perl5/5.6.1/i86pc-solaris -I/opt/gnu/lib/perl5/5.6.1 -e ‘use Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;’ t/*.t
t/1-basic…ok 2/8Unsupported conversion: Invalid argument at blib/lib/Encode/compat/common.pm line 115.
t/1-basic…dubious
Test returned status 22 (wstat 5632, 0x1600)
DIED. FAILED tests 3-8
Failed 6/8 tests, 25.00% okay
Failed Test Stat Wstat Total Fail Failed List of Failed
t/1-basic.t 22 5632 8 6 75.00% 3-8
Failed 1/1 test scripts, 0.00% okay. 6/8 subtests failed, 25.00% okay.
make: *** [test_dynamic] Error 2

Test-Harness-2.26 is installed.

I need to upgrade perl?

Best regards,
DavidOn Tue, 11 Mar 2003 19:34:28 +0200, Shmulik Gazit wrote:

Maybe you need a new Test::Harness? or an older one?

-----Original Message-----
From: Michael K. Brown [mailto:michael.k.brown@alcatel.com]
Sent: Tue, March 11, 2003 7:11 PM
To: Rt-Users
Subject: [rt-users] RE: Install problems rt-2-1-84

OK… I had run the automated install of dependencies, and now that I’m
trying to install manually, I’m seeing where there were some problems.
Here’s the results from the attempted install from CPAN:

cpan> install Encode::compat
CPAN: Storable loaded ok
Going to read /var/tmp/.cpan/Metadata
Database was generated on Mon, 10 Mar 2003 13:40:55 GMT
Running install for module Encode::compat
Running make for A/AU/AUTRIJUS/Encode-compat-0.05.tar.gz
CPAN: MD5 loaded ok
CPAN: Compress::Zlib loaded ok
Checksum for
/var/tmp/.cpan/sources/authors/id/A/AU/AUTRIJUS/Encode-compat-0.05.
tar.gz ok
x Encode-compat-0.05, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib/Encode, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib/Encode/compat, 0 bytes, 0 tape blocks
x Encode-compat-0.05/lib/Encode/compat/common.pm, 2570 bytes, 6 tape
blocks
x Encode-compat-0.05/lib/Encode/compat/5006001.pm, 583 bytes, 2 tape
blocks
x Encode-compat-0.05/lib/Encode/compat/Alias.pm, 9723 bytes, 19 tape
blocks
x Encode-compat-0.05/lib/Encode/compat.pm, 2338 bytes, 5 tape blocks
x Encode-compat-0.05/Changes, 3511 bytes, 7 tape blocks
x Encode-compat-0.05/t, 0 bytes, 0 tape blocks
x Encode-compat-0.05/t/1-basic.t, 610 bytes, 2 tape blocks
x Encode-compat-0.05/MANIFEST, 184 bytes, 1 tape blocks
x Encode-compat-0.05/Makefile.PL, 652 bytes, 2 tape blocks
x Encode-compat-0.05/README, 672 bytes, 2 tape blocks
x Encode-compat-0.05/SIGNATURE, 1289 bytes, 3 tape blocks

CPAN.pm: Going to build A/AU/AUTRIJUS/Encode-compat-0.05.tar.gz

Checking if your kit is complete…
Looks good
Writing Makefile for Encode::compat
cp lib/Encode/compat/5006001.pm blib/lib/Encode/compat/5006001.pm
cp lib/Encode/compat/common.pm blib/lib/Encode/compat/common.pm
cp lib/Encode/compat/Alias.pm blib/lib/Encode/compat/Alias.pm
cp lib/Encode/compat.pm blib/lib/Encode/compat.pm
Manifying blib/man3/Encode::compat::Alias.3
Manifying blib/man3/Encode::compat.3
/usr/local/bin/make -j3 – OK
Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
-I/usr/local/lib/perl5/5.
6.1/sun4-solaris -I/usr/local/lib/perl5/5.6.1 -e ‘use Test::Harness
qw(&runtests
$verbose); $verbose=0; runtests @ARGV;’ t/*.t
t/1-basic…ok 2/8Unsupported conversion: Invalid argument at
blib/lib/Encode/c
ompat/common.pm line 115.
t/1-basic…dubious
Test returned status 22 (wstat 5632, 0x1600)
DIED. FAILED tests 3-8
Failed 6/8 tests, 25.00% okay
Failed Test Stat Wstat Total Fail Failed List of Failed


t/1-basic.t 22 5632 8 6 75.00% 3-8
Failed 1/1 test scripts, 0.00% okay. 6/8 subtests failed, 25.00% okay.
make: *** [test_dynamic] Error 2
/usr/local/bin/make test – NOT OK
Running make install
make test had returned bad status, won’t install without force

cpan>

Wondering if anyone can help me here.

Thanks for your time!

/Mike

-----Original Message-----
From: Michael K. Brown [mailto:michael.k.brown@alcatel.com]
Sent: Tuesday, March 11, 2003 11:48 AM
To: Rt-Users (rt-users@lists.fsck.com)
Subject: Install problems rt-2-1-84

Hi Folks!

I’m setting up a test installation on the same server as my rt-2-0-12
installation. Make install went well. Trying to make
initialize-database, and I get the following error:

make initialize-database

/usr/bin/perl //usr/local/rt3/sbin/rt-setup-database --action init --dba
root – prompt-for-dba-password Can’t locate Encode/compat.pm in @INC
(@INC contains: /usr/local/rt3/lib /usr/lo
cal/lib/perl5/5.6.1/sun4-solaris /usr/local/lib/perl5/5.6.1
/usr/local/lib/perl5 /site_perl/5.6.1/sun4-solaris
/usr/local/lib/perl5/site_perl/5.6.1 /usr/local/li b/perl5/site_perl .)
at /usr/local/rt3/lib/RT/I18N.pm line 40. BEGIN failed–compilation
aborted at /usr/local/rt3/lib/RT/I18N.pm line 42. Compilation failed in
require at /usr/local/rt3/lib/RT.pm line 29. BEGIN failed–compilation
aborted at /usr/local/rt3/lib/RT.pm line 29. Compilation failed in
require at //usr/local/rt3/sbin/rt-setup-database line 37. BEGIN
failed–compilation aborted at //usr/local/rt3/sbin/rt-setup-database
line 37.
make: *** [initialize-database] Error 2

Just wondering if it’s a bug, or something in my set-up.

Existing set-up is rt-2-0-12 (customized) with mysql, apache,
mod_perl1.26. Testing of beta rt3 will be with fastcgi. I have
customized RT_SiteConfig.pm, but haven’t done the httpd.conf file yet,
since I can’t get the database installed.

Hope that helps!

/Mike


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

I have same problem. Manual install of Encode-compat-0.05:

make test

PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib -I/opt/gnu/lib/perl5/5.6.1/i86pc-solaris -I/opt/gnu/lib/perl5/5.6.1 -e ‘use Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;’ t/*.t
t/1-basic…ok 2/8Unsupported conversion: Invalid argument at blib/lib/Encode/compat/common.pm line 115.
t/1-basic…dubious
Test returned status 22 (wstat 5632, 0x1600)
DIED. FAILED tests 3-8
Failed 6/8 tests, 25.00% okay
Failed Test Stat Wstat Total Fail Failed List of Failed

t/1-basic.t 22 5632 8 6 75.00% 3-8
Failed 1/1 test scripts, 0.00% okay. 6/8 subtests failed, 25.00% okay.
make: *** [test_dynamic] Error 2

Can you try installing GNU libiconv and reinstall Text::Iconv linking
against that?

Thanks,
/Autrijus/

Hi Autrijus!

I tried that on Solaris 8, and it really broke things (using libiconv
package from SunFreeware). After installing it, then installing
Text::Iconv, it wouldn’t make it past make test. I ended up backing out
libiconv, and then Text::Iconv was happy. Still having problems with
Encode::compat. I’m in the process of upgrading perl to 5.8.0 to see if
that helps!

/MikeFrom: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Autrijus Tang
Sent: Thursday, March 13, 2003 8:44 AM
To: David Vrtin
Cc: Shmulik Gazit; Rt-Users
Subject: Re: [rt-users] RE: Install problems rt-2-1-84

I have same problem. Manual install of Encode-compat-0.05:

make test

PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
-I/opt/gnu/lib/perl5/5.6.1/i86pc-solaris -I/opt/gnu/lib/perl5/5.6.1 -e
’use Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;'
t/*.t
t/1-basic…ok 2/8Unsupported conversion: Invalid argument at
blib/lib/Encode/compat/common.pm line 115.
t/1-basic…dubious

    Test returned status 22 (wstat 5632, 0x1600)

DIED. FAILED tests 3-8
Failed 6/8 tests, 25.00% okay
Failed Test Stat Wstat Total Fail Failed List of Failed

t/1-basic.t 22 5632 8 6 75.00% 3-8
Failed 1/1 test scripts, 0.00% okay. 6/8 subtests failed, 25.00% okay.
make: *** [test_dynamic] Error 2

Can you try installing GNU libiconv and reinstall Text::Iconv linking
against that?

Thanks,
/Autrijus/

Installation of Perl 5.8.0 from SunFreeware solved my problems with
Encode::compat. Using Solaris’ version of iconv, in /usr/bin/iconv

Hope that helps someone!

/MikeFrom: Michael K. Brown [mailto:michael.k.brown@alcatel.com]
Sent: Thursday, March 13, 2003 2:56 PM
To: 'Autrijus Tang’
Cc: 'Rt-Users’
Subject: RE: [rt-users] RE: Install problems rt-2-1-84

Hi Autrijus!

I tried that on Solaris 8, and it really broke things (using libiconv
package from SunFreeware). After installing it, then installing
Text::Iconv, it wouldn’t make it past make test. I ended up backing out
libiconv, and then Text::Iconv was happy. Still having problems with
Encode::compat. I’m in the process of upgrading perl to 5.8.0 to see if
that helps!

/Mike

From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Autrijus Tang
Sent: Thursday, March 13, 2003 8:44 AM
To: David Vrtin
Cc: Shmulik Gazit; Rt-Users
Subject: Re: [rt-users] RE: Install problems rt-2-1-84

I have same problem. Manual install of Encode-compat-0.05:

make test

PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
-I/opt/gnu/lib/perl5/5.6.1/i86pc-solaris -I/opt/gnu/lib/perl5/5.6.1 -e
’use Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;'
t/*.t t/1-basic…ok 2/8Unsupported conversion: Invalid argument at
blib/lib/Encode/compat/common.pm line 115.
t/1-basic…dubious

    Test returned status 22 (wstat 5632, 0x1600)

DIED. FAILED tests 3-8
Failed 6/8 tests, 25.00% okay
Failed Test Stat Wstat Total Fail Failed List of Failed

t/1-basic.t 22 5632 8 6 75.00% 3-8
Failed 1/1 test scripts, 0.00% okay. 6/8 subtests failed, 25.00% okay.
make: *** [test_dynamic] Error 2

Can you try installing GNU libiconv and reinstall Text::Iconv linking
against that?

Thanks,
/Autrijus/