Install problem using a db server on a different host

Hello,

I’m installing RT 3.8.0 on a CentOS box but using a mysql server on a
different box. I’ve finished all the steps in the README up to the stage
of doing make initialize-database. When I do that, it appears to be
creating an ACL for my rt db user as user@localhost instead of user@% or
user@rt_host.

The configure statement I used was:

./configure --with-db-type=mysql --with-db-host=db01.prl.ab.ca
–with-db-dba=root --with-db-database=ref_ill_rt --with-db-rt-user=refrt
–with-db-rt-pass= --with-web-user=apache
–with-web-group=apache

Looking at Makefile, I see that the initialize-database runs create
schema acl coredata insert. It appears to complete up to acl, but dies
when running coredata.

I manually applied the permissions on the database for the user@% (GRANT
ALL PRIVILEGES ON ref_ill_rt TO ‘refrt’@’%’ IDENTIFIED BY ‘’:wink:
and was then able to successfully run rt-setup-database --action
coredata --dba root --prompt-for-dba-password.

I’m now stuck on the final action (insert). When I try running it
(either manually via a command or by creating another stanza in the
Makefile), I get the following error results:

/usr/bin/perl sbin/rt-setup-database --action insert --dba root
–prompt-for-dba-password
In order to create or update your RT database, this script needs to
connect to your mysql instance on db01.prl.ab.ca as root
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password:
Working with:
Type: mysql
Host: db01.prl.ab.ca
Name: ref_ill_rt
User: refrt
DBA: root
Now inserting data
[Wed Aug 6 17:02:23 2008] [warning]: Use of uninitialized value in
concatenation (.) or string at sbin/rt-setup-database line 253,
line 1. (sbin/rt-setup-database:253)
Couldn’t finish ‘insert’ step.

ERROR: Couldn’t load data from ‘/content’ for import:

ERROR:Can’t locate /content in @INC (@INC contains:
/root/rt-3.8.0/sbin/…/local/lib /root/rt-3.8.0/sbin/…/lib
/usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/5.8.8 .) at /root/rt-3.8.0/sbin/…/lib/RT/Handle.pm line
690, line 1.

make: *** [insert-database] Error 255

I can successfully connect to the db server from this host using mysql
-h db01.prl.ab.ca -u refrt -p and can successfully select data from the
tables (e.g. the entries in the ACL table).

I’m quite happy to admit I’ve missed something. I’ve read the
appropriate docs (although I could have missed something) and Googled
without much luck. Everything seems to assume you’re running mysql on
the same server.

Can anyone point me in the right direction to get this up and running?
My perl-fu isn’t strong enough for me to look at the source and figure a
way around this. I am not averse to starting the RT installation over if
that’s what it takes - the perl dependencies are resolved, and that’s
always been the hardest part before. If I missed a step or a configure
element, I would like to know what it was so I know how to avoid this in
the future.

I appreciate any help anyone can give me on or off list.

Michael

Michael Silver, Network Administrator
Parkland Regional Library
5404 56 Avenue Lacombe, AB T4L 1G1
Phone: 403.782.3850 msilver@prl.ab.ca
Fax: 403.782.4650 http://www.prl.ab.ca/

  1. check option --with-db-rt-host
  2. try --enable-layout=RT3

Also want to note that you should run setup-database from dir where RT
is installed.On Thu, Aug 7, 2008 at 3:22 AM, Michael Silver msilver.lists@prl.ab.ca wrote:

Hello,

I’m installing RT 3.8.0 on a CentOS box but using a mysql server on a
different box. I’ve finished all the steps in the README up to the stage
of doing make initialize-database. When I do that, it appears to be
creating an ACL for my rt db user as user@localhost instead of user@% or
user@rt_host.

The configure statement I used was:

./configure --with-db-type=mysql --with-db-host=db01.prl.ab.ca
–with-db-dba=root --with-db-database=ref_ill_rt --with-db-rt-user=refrt
–with-db-rt-pass= --with-web-user=apache
–with-web-group=apache

Looking at Makefile, I see that the initialize-database runs create
schema acl coredata insert. It appears to complete up to acl, but dies
when running coredata.

I manually applied the permissions on the database for the user@% (GRANT
ALL PRIVILEGES ON ref_ill_rt TO ‘refrt’@’%’ IDENTIFIED BY ‘’:wink:
and was then able to successfully run rt-setup-database --action
coredata --dba root --prompt-for-dba-password.

I’m now stuck on the final action (insert). When I try running it
(either manually via a command or by creating another stanza in the
Makefile), I get the following error results:

/usr/bin/perl sbin/rt-setup-database --action insert --dba root
–prompt-for-dba-password
In order to create or update your RT database, this script needs to
connect to your mysql instance on db01.prl.ab.ca as root
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password:
Working with:
Type: mysql
Host: db01.prl.ab.ca
Name: ref_ill_rt
User: refrt
DBA: root
Now inserting data
[Wed Aug 6 17:02:23 2008] [warning]: Use of uninitialized value in
concatenation (.) or string at sbin/rt-setup-database line 253,
line 1. (sbin/rt-setup-database:253)
Couldn’t finish ‘insert’ step.

ERROR: Couldn’t load data from ‘/content’ for import:

ERROR:Can’t locate /content in @INC (@INC contains:
/root/rt-3.8.0/sbin/…/local/lib /root/rt-3.8.0/sbin/…/lib
/usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi
/usr/lib/perl5/5.8.8 .) at /root/rt-3.8.0/sbin/…/lib/RT/Handle.pm line
690, line 1.

make: *** [insert-database] Error 255

I can successfully connect to the db server from this host using mysql
-h db01.prl.ab.ca -u refrt -p and can successfully select data from the
tables (e.g. the entries in the ACL table).

I’m quite happy to admit I’ve missed something. I’ve read the
appropriate docs (although I could have missed something) and Googled
without much luck. Everything seems to assume you’re running mysql on
the same server.

Can anyone point me in the right direction to get this up and running?
My perl-fu isn’t strong enough for me to look at the source and figure a
way around this. I am not averse to starting the RT installation over if
that’s what it takes - the perl dependencies are resolved, and that’s
always been the hardest part before. If I missed a step or a configure
element, I would like to know what it was so I know how to avoid this in
the future.

I appreciate any help anyone can give me on or off list.

Michael

Michael Silver, Network Administrator
Parkland Regional Library
5404 56 Avenue Lacombe, AB T4L 1G1
Phone: 403.782.3850 msilver@prl.ab.ca
Fax: 403.782.4650 http://www.prl.ab.ca/


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Best regards, Ruslan.

Hello,

Thank you! That solved the problem. I don’t know how I missed the
–with-db-rt-host variable, but I removed everything I had done (except
perl modules - I’m not that stupid!) and started with the configure
statement again - this time using the above variable. Everything went
tickety-boo. The only thing I can think of is that I didn’t read closely
enough and assumed I had the db host setting taken care of with the
–with-db-host. Duh.

At any rate, thank you for the help and thanks to Best Practical for a
wonderful product.

Michael

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-
bounces@lists.bestpractical.com] On Behalf Of Ruslan Zakirov
Sent: Wednesday, August 06, 2008 6:45 PM
To: msilver@prl.ab.ca
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Install problem using a db server on a
different host

  1. check option --with-db-rt-host
  2. try --enable-layout=RT3

Also want to note that you should run setup-database from dir where
RT
is installed.

Hello,

I’m installing RT 3.8.0 on a CentOS box but using a mysql server
on a
different box. I’ve finished all the steps in the README up to
the stage
of doing make initialize-database. When I do that, it appears to
be
creating an ACL for my rt db user as user@localhost instead of
user@% or
user@rt_host.

Michael

Michael Silver, Network Administrator
Parkland Regional Library
5404 56 Avenue Lacombe, AB T4L 1G1
Phone: 403.782.3850 msilver@prl.ab.ca
Fax: 403.782.4650 http://www.prl.ab.ca/