Install of RT 4.4.3 on CentOs7

Hello, I try to install Request Tracker 4.4.3 on CentOs7 with this procedure of installation
( https://rt-wiki.bestpractical.com/wiki/CentOS7Install ), I could configure the web interface using SQLite
but postegresql does not work.
from there I get like connect failed error.
Same things when firewall disabled or configurate on port 80.

Are you able to access the Postgres shell using the user/password you provide the RT installer?

Hello, no I can’t, but if i choose on 1rst web interface installation, SQLite i can connect with this user but i can’t connect if i choose type of database: PostgreSQL.
the server answers that it could not connect and reports an error 255.

If RT doesn’t have a Postgres user that it can access Postgres as then it cannot create/edit the database

in the Postgres shell you can create a user for RT by doing something like this

       postgres=# CREATE ROLE root WITH LOGIN PASSWORD 'password';
       postgres=# ALTER ROLE root WITH LOGIN PASSWORD 'password' Superuser;
       postgres=#\du
1 Like

Hello, i used your command and i got this.
But i replace “root” by “rt_user” that’s correct?


In English the error says:
Failed to connect to the database: could not connect to the server: Connection refused Is the server active on the “localhost” host (:: 1) and accepts- Does the TCP / IP connections on port 8080? could not connect to the server: Connection refused Is the server active on the “localhost” host (127.0.0.1) and does it accept TCP / IP connections on port 8080 ?

Is the Postgres server running on port 8080? Try leaving that blank since thats a non standard port I believe

1 Like

My quick test in cases like this is to first get telnet installed on the machine and then telnet by hand to the host and port (localhost port 8080 in this case). If telnet can make a TCP connection, then the issue is at the RT end. If telnet can’t connect your problem is with either Postgres or firewalls (Postgres config most likely seeing as this host is “localhost”).

You might also want to check if you have SELinux running as that can cause odd issues too.

Hi, the firewall has been configured, Selinux has been disabled and connection was possible.
I think the problem is related to the Rt user who cannot connect to the database.
I get this error message: authentication authentication for user “rt_user” failed.
I modify this


image
If you got another Idea, i take everything ^^

I don’t believe all of these are needed, do you have these values set in your RT_SiteConfig?

Set( $DatabaseUser,     'some user' );
Set( $DatabasePassword, 'some pass' );
Set( $DatabaseAdmin,    'some user');
Set( $DatabaseName,     'rt4');

When you ran the ./configure line did you include any database connection info? You can see that by running head -5 /opt/rt4/etc/RT_Config.pm

Just configure db_type: tell that :
image

Did you confirm you can manually access your database using the username and password you are providing RT?