Install bug

i installed happily on one system. but went to another and

make install

mkdir -p //usr/local/rt2/bin
mkdir -p //usr/local/rt2/WebRT/data
mkdir -p //usr/local/rt2/WebRT/sessiondata
mkdir -p //usr/local/rt2/etc
mkdir -p //usr/local/rt2/lib
mkdir -p //usr/local/rt2/WebRT/html
mkdir -p //usr/local/rt2/local/WebRT/html
/usr/bin/perl tools/initdb ‘mysql’ ‘/usr/local’ ‘localhost’ ‘’ ‘root’ ‘rt’ create
Now creating a database for RT.
Enter the mysql password for root:
Creating mysql database rt.
cp etc/acl.mysql ‘//usr/local/rt2/etc/acl.mysql’
/usr/bin/perl -p -i -e " s’!!DB_TYPE!!’“mysql”‘g; s’!!DB_HOST!!’“localhost”‘g; s’!!DB_RT_PASS!!’“fooledya”‘g; s’!!DB_RT_HOST!!’“localhost”‘g; s’!!DB_RT_USER!!’“rt_user”‘g; s’!!DB_DATABASE!!’“rt”'g;" //usr/local/rt2/etc/acl.mysql
bin/initacls.mysql ‘/usr/local’ ‘localhost’ ‘’ ‘root’ ‘again’ ‘rt’ '//usr/local/rt2/etc/acl.mysql’
Enter the mysql administrator’s database password to create a new user for RT
ERROR 1175 at line 2: You are using safe update mode and you tried to update a table without a WHERE that uses a KEY column

randy

i installed happily on one system. but went to another and

make install

mkdir -p //usr/local/rt2/bin
mkdir -p //usr/local/rt2/WebRT/data
mkdir -p //usr/local/rt2/WebRT/sessiondata
mkdir -p //usr/local/rt2/etc
mkdir -p //usr/local/rt2/lib
mkdir -p //usr/local/rt2/WebRT/html
mkdir -p //usr/local/rt2/local/WebRT/html
/usr/bin/perl tools/initdb ‘mysql’ ‘/usr/local’ ‘localhost’
’’ ‘root’ ‘rt’ create
Now creating a database for RT.
Enter the mysql password for root:
Creating mysql database rt.
cp etc/acl.mysql ‘//usr/local/rt2/etc/acl.mysql’
/usr/bin/perl -p -i -e " s’!!DB_TYPE!!’“mysql”‘g;
s’!!DB_HOST!!’“localhost”‘g; s’!!DB_RT_PASS!!’“fooledya”‘g;
s’!!DB_RT_HOST!!’“localhost”‘g; s’!!DB_RT_USER!!’“rt_user”‘g;
s’!!DB_DATABASE!!’“rt”'g;" //usr/local/rt2/etc/acl.mysql
bin/initacls.mysql ‘/usr/local’ ‘localhost’ ‘’ ‘root’ ‘again’
‘rt’ '//usr/local/rt2/etc/acl.mysql’
Enter the mysql administrator’s database password to create a
new user for RT
ERROR 1175 at line 2: You are using safe update mode and you
tried to update a table without a WHERE that uses a KEY column

Not sure what versions of what you’re using there, but a temp solution
would be to disable safe-updates.

I believe the option is read from /etc/my.cnf - as in (mine for
example):

[mysql]
no-auto-rehash

Remove the next comment character if you are not familiar with SQL

#safe-updates

So just comment out your entry (which should be uncommented if its
enabled). I don’t know much about the rt install script to comment on
whether it is actually unsafe, but in this case it looks fine :slight_smile:

Andy.