Insecure dependency with FastCGI

Hi,

I’m trying to install RT on a Debian Stable box. Since Debian doesn’t
come with Perl 5.8 yet, I compiled my own 5.8.2. It runs Apache 1.3.26
with FastCGI.

I followed all the installation instructions for RT.

In RT 3.0.6, I get

For the Homepage:

Error during compilation of /opt/rt/share/html/index.html:
Insecure dependency in require while running setgid at
/opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm line 568
context: …
code stack:
/opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:580
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:317
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:198
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:166
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:265
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:343
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:213
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:207
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:89
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:72
g /opt/rt/bin/mason_handler.fcgi:53
g

For the /Admin/ page:

error: Insecure dependency in mkdir while running setgid at
/opt/perl/lib/5.8.2/File/Path.pm line 159.
context:

155: unless (-d $parent or $path eq $parent) {
156: push(@created,mkpath($parent, $verbose, $mode));
157: }
158: print “mkdir $path\n” if $verbose;
159: unless (mkdir($path,$mode)) {
160: my $e = $!;
161: # allow for another process to have created it meanwhile
162: croak “mkdir $path: $e” unless -d $path;
163: }

code stack: /opt/perl/lib/5.8.2/File/Path.pm:159
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Compiler/ToObject.pm:102
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:309
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:198
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:166
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:265
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:343
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:213
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:207
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:89
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:72
g /opt/rt/bin/mason_handler.fcgi:53
g

In RT 3.0.5, I get for the Homepage:

Insecure dependency in mkdir while running setgid at
/opt/perl/lib/5.8.2/File/Path.pm line 159
context: mkdir
code stack: /opt/perl/lib/5.8.2/File/Path.pm:159
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Compiler/ToObject.pm:102
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:309
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:198
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:166
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:265
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:343
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:213
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:207
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:89
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:72
g /opt/rt/bin/mason_handler.fcgi:53
g

I’m a bit stuck and the mailing list doesn’t mention this problem for
recent versions. Yet, I cannot use RT with mod_perl on this particular
server.

Any suggestions?

Greetings,

Hanno

Hanno Mueller wrote:

I’m trying to install RT on a Debian Stable box. Since Debian doesn’t
come with Perl 5.8 yet, I compiled my own 5.8.2. It runs Apache 1.3.26
with FastCGI.

I followed all the installation instructions for RT.

[…]

I’m a bit stuck and the mailing list doesn’t mention this problem for
recent versions. Yet, I cannot use RT with mod_perl on this particular
server.

Any suggestions?

I also tried to run 3.0.7 RC1 on the same box, no luck. Again, Perl
complains about the mkdir() call.

I’ve tried to untaint the CGI variables, but actually, I don’t want to
hunt for the symptom until I actually know the cause.

Is anyone else running RT 3.0.6 as a CGI or as a FastCGI? I cannot
install mod_perl on this server, so any help is greatly appreciated.

Thanks,

Hanno

Hanno Mueller wrote:

I’m trying to install RT on a Debian Stable box. Since Debian doesn’t
come with Perl 5.8 yet, I compiled my own 5.8.2. It runs Apache 1.3.26
with FastCGI.

....

Is anyone else running RT 3.0.6 as a CGI or as a FastCGI? I cannot
install mod_perl on this server, so any help is greatly appreciated.

I have RT 3.0.6 running with FastCGI, perl 5.8.1.
I have mod_perl installed, but I prefer fastcgi for RT
so that I can run multiple instances of RT.

In the process of flailing at this originally, I set
apache to run as group 'rt'.  So I think perl doesn't see
the fastcgi as running setgid, since RGID == EGID,
and so doesn't run taint checks.  (That wasn't
my original intention, just worked out that way.)

In my case, I'm not using this server or apache instance
for anything but RT, so tuning it to run RT is ok.
That may or may not be ok for you.

  bobg

I have seen this symptom in other contexts. Simply put, File::Path does not
play well with taint mode. In your case, the $path variable in the mkdir()
call is considered tainted. The only way around this I have ever found was
to create File::PathTaint which is a copy of File::Path, but includes some
really unpleasant taint cleaning ( usually something along the lines of:
my $clean_path;

$clean_path = $1 if ( $path =~ /^(.+)$/;
$path = $clean_path;

Yes, I know. It completely circumvents the idea of taint checking. But it
fixed the problem :slight_smile:

Mik

Hanno Mueller writes:

Hanno Mueller wrote:

I’m trying to install RT on a Debian Stable box. Since Debian doesn’t
come with Perl 5.8 yet, I compiled my own 5.8.2. It runs Apache 1.3.26
with FastCGI.

I followed all the installation instructions for RT.

[…]

I’m a bit stuck and the mailing list doesn’t mention this problem for
recent versions. Yet, I cannot use RT with mod_perl on this particular
server.

Any suggestions?

I also tried to run 3.0.7 RC1 on the same box, no luck. Again, Perl
complains about the mkdir() call.

I’ve tried to untaint the CGI variables, but actually, I don’t want to
hunt for the symptom until I actually know the cause.

Is anyone else running RT 3.0.6 as a CGI or as a FastCGI? I cannot install
mod_perl on this server, so any help is greatly appreciated.

Thanks,

Hanno


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Mik Firestone
Vice Principal
Rule of Ten, Inc.

Hello,
I’ve just set up RT 3-0-6 (with MySQL 4.0.16, apache 1.3.29, mod_perl
1.29, and RTFM 2.0.1) and have a few questions.

After using the default install, the image comes up as broken in the
upper left corner. I missed modifying it during the install, so I’m
trying to add it afterwards. I have seen several mentions on here about
modifying RT-Config.pm, although the file states at the top to not
modify it directly. So which is true?

What directory does RT look within for the logo? I changed it to
"image.gif" and put a file called “image.gif” in /opt/rt3/share/html
(and restarted Apache just in case it loads the config only at http
start).

I’ll hold on to my questions about RTFM until I rtfm :slight_smile:

Thanks,
John

Change your Debian box to testing and run:

apt-get update;
apt-get dist-upgrade.

I have rt 3.0.6 running on a Debian Testing box.

[]'s

Daniel A. Melo
Consultor em Segurança da Tecnologia da Informação
MCSO - Modulo Certified Security OfficerEm Seg, 2003-11-17 às 11:10, Hanno Mueller escreveu:

Hanno Mueller wrote:

I’m trying to install RT on a Debian Stable box. Since Debian doesn’t
come with Perl 5.8 yet, I compiled my own 5.8.2. It runs Apache 1.3.26
with FastCGI.

I followed all the installation instructions for RT.

[…]

I’m a bit stuck and the mailing list doesn’t mention this problem for
recent versions. Yet, I cannot use RT with mod_perl on this particular
server.

Any suggestions?

I also tried to run 3.0.7 RC1 on the same box, no luck. Again, Perl
complains about the mkdir() call.

I’ve tried to untaint the CGI variables, but actually, I don’t want to
hunt for the symptom until I actually know the cause.

Is anyone else running RT 3.0.6 as a CGI or as a FastCGI? I cannot
install mod_perl on this server, so any help is greatly appreciated.

Thanks,

Hanno


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Hi,

michael.firestone wrote:

Yes, I know. It completely circumvents the idea of taint checking. But
it fixed the problem :slight_smile:

Thanks, that was a possible fix. Although I don’t quite like it, to be
honest. Is there no “clean” way to fix this? Why doesn’t this problem
break the mod_perl variant?

Thanks a lot so far!

Hanno

Hanno Mueller wrote:

“5-10 seconds for each request?”

Sorry about the subject line. I wanted to write about the sluggy
response of RT now that I got it running, but then I realized that my
FCGI setup for this virtual server was broken. I fixed that, rewrote my
mail but forgot the adjust the subject. Sorry about that…

Thanks again,

Hanno

Hi,

michael.firestone wrote:

Yes, I know. It completely circumvents the idea of taint checking. But
it fixed the problem :slight_smile:

Thanks, that was a possible fix. Although I don’t quite like it, to be
honest. Is there no “clean” way to fix this? Why doesn’t this problem
break the mod_perl variant?

Because with mod_perl, you don’t run an external process,
you load the perl code right into apache, so there is
no sgid involved, and no taint checking. The RT code
runs intrinsically with the gid (and uid) of the apache
process, not a whole lot different from my solution
of having the apache gid be the same as fcgi.

Here’s an idea, but I haven’t checked the details. I’m using
apache to launch the fastcgi process, so obviously the
apache uid/gid needs adequate privs. But instead, you
can launch the fastcgi by hand (or by cron) separately.
That may fix your priv problem provided the launching process
has group ‘rt’, different from apache. But it means you
need a separate way to ensure the fastcgi process stays
up, since apache can’t re-launch it. In fact, I think apache
and fastcgi can be on different machines if that’s useful.

  bobg

John Schubert wrote:

Hello,
I’ve just set up RT 3-0-6 (with MySQL 4.0.16, apache 1.3.29, mod_perl
1.29, and RTFM 2.0.1) and have a few questions.

After using the default install, the image comes up as broken in the
upper left corner. I missed modifying it during the install, so I’m
trying to add it afterwards. I have seen several mentions on here about
modifying RT-Config.pm, although the file states at the top to not
modify it directly. So which is true?

What directory does RT look within for the logo? I changed it to
"image.gif" and put a file called “image.gif” in /opt/rt3/share/html
(and restarted Apache just in case it loads the config only at http
start).

I’ll hold on to my questions about RTFM until I rtfm :slight_smile:

Thanks,
John


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

I played with that for hours, I finally just gave in and put the full
path to the images directory in the config:

Set($WebImagesURL , “http://server.com:8080/NoAuth/images”);

No combination of $WebURL , $WebBaseURL and $WebPath worked for me. Of
course, I can be an idiot sometimes… :slight_smile:

HTH

Tom

Hanno et. al:

I’m having the same problem on a Solaris 9 box… It would seem to me that
it’s a symptom of rolling our own Perl 5.8.2.

Eric Fesh
Customer Support Engineer/Software Test Engineer
MPI Software Technology Inc.
http://www.mpi-softtech.com

The information contained in this communication may be confidential and is
intended only for the use of the recipient(s) named above. If the reader of
this communication is not the intended recipient(s), you are hereby notified
that any dissemination, distribution, or copying of this communication, or
any of its contents, is strictly prohibited. If you are not a named
recipient or received this communication by mistake, please notify the sender
and delete the communication and all copies of it.On Fri, 14 Nov 2003, Hanno Mueller wrote:

Hi,

I’m trying to install RT on a Debian Stable box. Since Debian doesn’t
come with Perl 5.8 yet, I compiled my own 5.8.2. It runs Apache 1.3.26
with FastCGI.

I followed all the installation instructions for RT.

In RT 3.0.6, I get

For the Homepage:

Error during compilation of /opt/rt/share/html/index.html:
Insecure dependency in require while running setgid at
/opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm line 568
context: …
code stack:
/opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:580
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:317
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:198
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:166
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:265
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:343
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:213
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:207
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:89
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:72
g /opt/rt/bin/mason_handler.fcgi:53
g

For the /Admin/ page:

error: Insecure dependency in mkdir while running setgid at
/opt/perl/lib/5.8.2/File/Path.pm line 159.
context:

155: unless (-d $parent or $path eq $parent) {
156: push(@created,mkpath($parent, $verbose, $mode));
157: }
158: print “mkdir $path\n” if $verbose;
159: unless (mkdir($path,$mode)) {
160: my $e = $!;
161: # allow for another process to have created it meanwhile
162: croak “mkdir $path: $e” unless -d $path;
163: }

code stack: /opt/perl/lib/5.8.2/File/Path.pm:159
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Compiler/ToObject.pm:102
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:309
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:198
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:166
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:265
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:343
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:213
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:207
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:89
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:72
g /opt/rt/bin/mason_handler.fcgi:53
g

In RT 3.0.5, I get for the Homepage:

Insecure dependency in mkdir while running setgid at
/opt/perl/lib/5.8.2/File/Path.pm line 159
context: mkdir
code stack: /opt/perl/lib/5.8.2/File/Path.pm:159
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Compiler/ToObject.pm:102
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:309
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:198
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:166
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:265
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:343
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:213
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:207
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:89
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:72
g /opt/rt/bin/mason_handler.fcgi:53
g

I’m a bit stuck and the mailing list doesn’t mention this problem for
recent versions. Yet, I cannot use RT with mod_perl on this particular
server.

Any suggestions?

Greetings,

Hanno


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

No, what happens is that apache is running as one gid,
but the fastcgi script is setgid to another. This forces
perl to turn on taint checking, and the fastsci script
is not taint-safe. This would happen with any
version of perl.

The simplest solution, if it doesn’t break anything else,
is to change the gid of apache or fastcgi to match.

Another solution is to start the fastcgi server by hand,
rather than have apache start it. Apache still talks
to it over a socket in any case. But if you start the
fastcgi by hand, using the uid/gid of the script itself,
then perl doesn’t force taint checking.

bobg

Bingo!

Thanks much…

Eric Fesh
Customer Support Engineer/Software Test Engineer
MPI Software Technology Inc.
http://www.mpi-softtech.com

The information contained in this communication may be confidential and is
intended only for the use of the recipient(s) named above. If the reader of
this communication is not the intended recipient(s), you are hereby notified
that any dissemination, distribution, or copying of this communication, or
any of its contents, is strictly prohibited. If you are not a named
recipient or received this communication by mistake, please notify the sender
and delete the communication and all copies of it.On Tue, 16 Dec 2003, Bob Goldstein wrote:

No, what happens is that apache is running as one gid,
but the fastcgi script is setgid to another. This forces
perl to turn on taint checking, and the fastsci script
is not taint-safe. This would happen with any
version of perl.

The simplest solution, if it doesn’t break anything else,
is to change the gid of apache or fastcgi to match.

Another solution is to start the fastcgi server by hand,
rather than have apache start it. Apache still talks
to it over a socket in any case. But if you start the
fastcgi by hand, using the uid/gid of the script itself,
then perl doesn’t force taint checking.

bobg

Hanno et. al:

I’m having the same problem on a Solaris 9 box… It would seem to me that
it’s a symptom of rolling our own Perl 5.8.2.


Eric Fesh
Customer Support Engineer/Software Test Engineer
MPI Software Technology Inc.
http://www.mpi-softtech.com

The information contained in this communication may be confidential and is
intended only for the use of the recipient(s) named above. If the reader of
this communication is not the intended recipient(s), you are hereby notified
that any dissemination, distribution, or copying of this communication, or
any of its contents, is strictly prohibited. If you are not a named
recipient or received this communication by mistake, please notify the sender
and delete the communication and all copies of it.

On Fri, 14 Nov 2003, Hanno Mueller wrote:

Hi,

I’m trying to install RT on a Debian Stable box. Since Debian doesn’t
come with Perl 5.8 yet, I compiled my own 5.8.2. It runs Apache 1.3.26
with FastCGI.

I followed all the installation instructions for RT.

In RT 3.0.6, I get

For the Homepage:

Error during compilation of /opt/rt/share/html/index.html:
Insecure dependency in require while running setgid at
/opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm line 568
context: …
code stack:
/opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:580
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:317
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:198
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:166
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:265
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:343
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:213
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:207
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:89
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:72
g /opt/rt/bin/mason_handler.fcgi:53
g

For the /Admin/ page:

error: Insecure dependency in mkdir while running setgid at
/opt/perl/lib/5.8.2/File/Path.pm line 159.
context:

155: unless (-d $parent or $path eq $parent) {
156: push(@created,mkpath($parent, $verbose, $mode));
157: }
158: print “mkdir $path\n” if $verbose;
159: unless (mkdir($path,$mode)) {
160: my $e = $!;
161: # allow for another process to have created it meanwhile
162: croak “mkdir $path: $e” unless -d $path;
163: }

code stack: /opt/perl/lib/5.8.2/File/Path.pm:159
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Compiler/ToObject.pm:102
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:309
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:198
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:166
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:265
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:343
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:213
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:207
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:89
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:72
g /opt/rt/bin/mason_handler.fcgi:53
g

In RT 3.0.5, I get for the Homepage:

Insecure dependency in mkdir while running setgid at
/opt/perl/lib/5.8.2/File/Path.pm line 159
context: mkdir
code stack: /opt/perl/lib/5.8.2/File/Path.pm:159
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Compiler/ToObject.pm:102
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:309
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:198
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Request.pm:166
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:265
g /opt/perl/lib/site_perl/5.8.2/Class/Container.pm:343
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:213
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/Interp.pm:207
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:89
g /opt/perl/lib/site_perl/5.8.2/HTML/Mason/CGIHandler.pm:72
g /opt/rt/bin/mason_handler.fcgi:53
g

I’m a bit stuck and the mailing list doesn’t mention this problem for
recent versions. Yet, I cannot use RT with mod_perl on this particular
server.

Any suggestions?

Greetings,

Hanno


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm