Incorrect URLs in some searches after upgrade to rt 3.8.0

For some reason, some of the links to tickets are using an incorrect URL.

I just upgraded our test system to RT 3.8.0 from 3.6.5 (Which was a
debian native package). The previous config for the url was
/rt, the new url is simply .

This works most of the time, except for some of the previous ticket
queries, which still use the old URLs.

I’ve been hunting through the apache2 config data, and can’t find
anything that would seem to affect it.

I have also been looking around the database to see if there is a
reference there.

I’ve attached my RT config files as well.

RT_Config.pm (33.4 KB)

RT_SiteConfig.pm (874 Bytes)

It seems to be affecting saved searches (custom searches, owned tickets,
etc)

Anytime I create a NEW server, it works fine.

Chris Crow wrote:

I’m not sure where problem came from, but looks like your saved
searches have wrong format strings. Add WebPath prefix to href
attribute of a tag like in default format.

To do that login as SuperUser into the UI -> Edit near a box on “RT At
Glance” -> “You can also edit the predefined search itself” ->
Advanced -> Change format -> Apply -> Update saved search.On Tue, Jul 22, 2008 at 10:13 PM, Chris Crow chrisc.email@abshernw.com wrote:

It seems to be affecting saved searches (custom searches, owned tickets,
etc)

Anytime I create a NEW server, it works fine.

Chris Crow wrote:

For some reason, some of the links to tickets are using an incorrect URL.

I just upgraded our test system to RT 3.8.0 from 3.6.5 (Which was a
debian native package). The previous config for the url was
/rt, the new url is simply .

This works most of the time, except for some of the previous ticket
queries, which still use the old URLs.

I’ve been hunting through the apache2 config data, and can’t find
anything that would seem to affect it.

I have also been looking around the database to see if there is a
reference there.

I’ve attached my RT config files as well.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Best regards, Ruslan.

Chris Crow wrote:

It seems to be affecting saved searches (custom searches, owned tickets,
etc)

Anytime I create a NEW server, it works fine.

Chris Crow wrote:

For some reason, some of the links to tickets are using an incorrect URL.

I just upgraded our test system to RT 3.8.0 from 3.6.5 (Which was a
debian native package). The previous config for the url was
/rt, the new url is simply .

This works most of the time, except for some of the previous ticket
queries, which still use the old URLs.

I’ve been hunting through the apache2 config data, and can’t find
anything that would seem to affect it.

I have also been looking around the database to see if there is a
reference there.

I’ve attached my RT config files as well.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

I have gotten around the problem by putting this into my
settings:

    RewriteRule ^/rt/(.*) http://rt.example.com/$1 [R]