Httpd's are more than 10%

I am using RT-3-0-4/Mysql4.0.13/Apache 1.3.27+mod_perl1/Perl 5.8

I noticed three out of 10 of my httpd sessions are taking more than 10% of CPU
and they are excruciatingly slow. Not sure if we need to switch to a different
product at this time. I really had very good experience with RT2 and not with
RT3. I followed the instruction while upgrading to RT3.

Someone else experiencing the same way ?

Sorry I needed to vent out :frowning:

Thanks

Asif Iqbal
http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x8B686E08
There’s no place like 127.0.0.1

RT3 in our environment hasn’t been great. Usable, but it’s not uncommon for
a trivial ticket to take 8-15 seconds to come up. Our webservers are oldish
Sun E250s. The single best performance improvement I’ve found was switching
from Mod_Perl to FastCGI. In my test environments I’m seeing between 30% and
45% speed improvements. I’m guessing this has a lot to do with the weight of
a FastCGI HTTPD vis-a-vis ModPerl HTTPD, which is about 4.5MB for a FastCGI
HTTPD and about 30MB for a ModPerl HTTPD.

Come to think of it, RT’s caching should be generally more effective in a
FastCGI environment then a simple ModPerl environment. FastCGI works by having
the “Application” in its own process space rather then as part of the httpd.
You generally have less “Application” processes then httpd processes so load
isn’t as high with fastcgi relative a simple mod_perl install. The mod_perl
folks are smart and found a way to approximate the same behaviors using two
httpds and mod_proxy … but ew.

Matt

HW configuration?
mysql config?
Tried 3.0.5pre3?

A.-----Original Message-----
From: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com]
On Behalf Of Asif Iqbal
Sent: Thursday, August 21, 2003 3:58 PM
To: rt-users@lists.fsck.com
Cc: rt-devel@lists.fsck.com
Subject: [rt-users] httpd’s are more than 10%

I am using RT-3-0-4/Mysql4.0.13/Apache 1.3.27+mod_perl1/Perl 5.8

I noticed three out of 10 of my httpd sessions are taking more than 10% of
CPU
and they are excruciatingly slow. Not sure if we need to switch to a
different
product at this time. I really had very good experience with RT2 and not
with
RT3. I followed the instruction while upgrading to RT3.

Someone else experiencing the same way ?

Sorry I needed to vent out :frowning:

Thanks

Asif Iqbal
http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x8B686E08
There’s no place like 127.0.0.1

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

HW configuration?
Soalris 420R, 4x450 Mhz/4 GB Ram

mysql config?
my-medium.cnf

I commented out all the references to innodb to avoid any further crash in my
mysql. Also I noticed my ibdata1 which is 1.6 gig now is slowly growing. Wonder
what I should do when it fills up my partition. I have only 1 gb space left on
that partition

Tried 3.0.5pre3?
No, should I ?

A.

-----Original Message-----
From: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com]
On Behalf Of Asif Iqbal
Sent: Thursday, August 21, 2003 3:58 PM
To: rt-users@lists.fsck.com
Cc: rt-devel@lists.fsck.com
Subject: [rt-users] httpd’s are more than 10%

I am using RT-3-0-4/Mysql4.0.13/Apache 1.3.27+mod_perl1/Perl 5.8

I noticed three out of 10 of my httpd sessions are taking more than 10% of
CPU
and they are excruciatingly slow. Not sure if we need to switch to a
different
product at this time. I really had very good experience with RT2 and not
with
RT3. I followed the instruction while upgrading to RT3.

Someone else experiencing the same way ?

Sorry I needed to vent out :frowning:

Thanks

Asif Iqbal
http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x8B686E08
There’s no place like 127.0.0.1

Try to go with my-large.cnf, the amount of RAM you’ve got is plenty for
my-large.

And yes try 3.0.5pre3.

A.From: Asif Iqbal [mailto:iqbala@qwestip.net]
Sent: Thursday, August 21, 2003 4:46 PM
To: Aleš Sušnik
Subject: RE: [rt-users] httpd’s are more than 10%

HW configuration?

Soalris 420R, 4x450 Mhz/4 GB Ram

mysql config?

my-medium.cnf

Tried 3.0.5pre3?

No, should I ?

A.

-----Original Message-----
From: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com]
On Behalf Of Asif Iqbal
Sent: Thursday, August 21, 2003 3:58 PM
To: rt-users@lists.fsck.com
Cc: rt-devel@lists.fsck.com
Subject: [rt-users] httpd’s are more than 10%

I am using RT-3-0-4/Mysql4.0.13/Apache 1.3.27+mod_perl1/Perl 5.8

I noticed three out of 10 of my httpd sessions are taking more than 10% of
CPU
and they are excruciatingly slow. Not sure if we need to switch to a
different
product at this time. I really had very good experience with RT2 and not
with
RT3. I followed the instruction while upgrading to RT3.

Someone else experiencing the same way ?

Sorry I needed to vent out :frowning:

Thanks

Asif Iqbal
http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x8B686E08
There’s no place like 127.0.0.1

mysql config?
my-medium.cnf

I commented out all the references to innodb to avoid any further
crash in my
mysql.

Are Your rt databases innodb or MyISAM? They will be faster if You run
an optimized innodb setup.

Also I noticed my ibdata1 which is 1.6 gig now is slowly growing.
Wonder
what I should do when it fills up my partition. I have only 1 gb space
left on
that partition

Tried 3.0.5pre3?
No, should I ?

The announcements promise a big speed increase. I only remember one
positive report and no negative reports about the 3.0.5pre series
regarding speed.

Regards,
Harald Wagener

mysql config?
my-medium.cnf

I commented out all the references to innodb to avoid any further
crash in my
mysql.

Are Your rt databases innodb or MyISAM? They will be faster if You run

Innodb I think. How can I confirm that ?

an optimized innodb setup.

How do you run an optimized innodb setup ?

Sorry for all these newbie questions ?

Also I noticed my ibdata1 which is 1.6 gig now is slowly growing.
Wonder
what I should do when it fills up my partition. I have only 1 gb space
left on
that partition

Tried 3.0.5pre3?
No, should I ?

The announcements promise a big speed increase. I only remember one
positive report and no negative reports about the 3.0.5pre series
regarding speed.

I will give 3.0.5pre a shot. Is there a way to revert to current (3.0.4) in case
I want to ?

Regards,
Harald Wagener

Asif Iqbal
http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x8B686E08
There’s no place like 127.0.0.1

mysql config?
my-medium.cnf

I commented out all the references to innodb to avoid any further
crash in my
mysql.

Are Your rt databases innodb or MyISAM? They will be faster if You run

Innodb I think. How can I confirm that ?

You can change the table type by issuing

ALTER TABLE tablename TYPE=InnoDB;

at the mysql prompt.

I don’t know of a quick method to find out if You are currently using
InnoDB databases.

an optimized innodb setup.

How do you run an optimized innodb setup ?

Sorry for all these newbie questions ?

This is documented in the mysql documentation. I did do it ‘by the
book’, have a look at http://www.mysql.com/doc/en/index.html. There are
three or four variables controlling how much memory MySQL uses, and
another three or four that control innodb. InnoDB is described in
Chapter 7.5

Another good resource is Jeremy Zawodny’s web site at

Although this is for version 3.x, most of the information is still
correct.

Regards,
Harald

mysql config?
my-medium.cnf

I commented out all the references to innodb to avoid any further
crash in my
mysql.

Are Your rt databases innodb or MyISAM? They will be faster if You run

Innodb I think. How can I confirm that ?

You can change the table type by issuing

ALTER TABLE tablename TYPE=InnoDB;

at the mysql prompt.

I don’t know of a quick method to find out if You are currently using
InnoDB databases.

If it’s a default RT3 install the information is in
/etc/schema.

/rhb

Innodb I think. How can I confirm that ?

mysql> use rt3;
Database changed
mysql> show table status;

Should give you the table type.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail.

All outgoing e-mail scanned by Sybari Antigen v7.5 build 1133

mysql config?
my-medium.cnf

I commented out all the references to innodb to avoid any further
crash in my
mysql.

Are Your rt databases innodb or MyISAM? They will be faster if You run

Innodb I think. How can I confirm that ?

You can change the table type by issuing

ALTER TABLE tablename TYPE=InnoDB;

at the mysql prompt.

I don’t know of a quick method to find out if You are currently using
InnoDB databases.

If it’s a default RT3 install the information is in
/etc/schema.

Thanks. So the answer is all my tables are InnoDB according to schema.mysql

/rhb

an optimized innodb setup.

How do you run an optimized innodb setup ?

Sorry for all these newbie questions ?

This is documented in the mysql documentation. I did do it ‘by the
book’, have a look at http://www.mysql.com/doc/en/index.html. There are
three or four variables controlling how much memory MySQL uses, and
another three or four that control innodb. InnoDB is described in
Chapter 7.5

Another good resource is Jeremy Zawodny’s web site at
Jeremy's MySQL Stuff

Although this is for version 3.x, most of the information is still
correct.

Regards,
Harald


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Asif Iqbal
http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x8B686E08
There’s no place like 127.0.0.1

Try to go with my-large.cnf, the amount of RAM you’ve got is plenty for
my-large.

I will give that a shot

And yes try 3.0.5pre3.

I assume I can just download 3.0.5pre and follow the instructions to upgrade
from 3.0.4 to 3.0.5pre

Am I correct ?

A.

Asif Iqbal
http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x8B686E08
There’s no place like 127.0.0.1

mysql config?
my-medium.cnf

I commented out all the references to innodb to avoid any further
crash in my
mysql.

Are Your rt databases innodb or MyISAM? They will be faster if You run

Innodb I think. How can I confirm that ?

You can change the table type by issuing

ALTER TABLE tablename TYPE=InnoDB;

at the mysql prompt.

I don’t know of a quick method to find out if You are currently using
InnoDB databases.

an optimized innodb setup.

How do you run an optimized innodb setup ?

Sorry for all these newbie questions ?

This is documented in the mysql documentation. I did do it ‘by the
book’, have a look at http://www.mysql.com/doc/en/index.html. There are
three or four variables controlling how much memory MySQL uses, and
another three or four that control innodb. InnoDB is described in
Chapter 7.5

Another good resource is Jeremy Zawodny’s web site at
Jeremy's MySQL Stuff

Thanks a lot. Let me get back to RTFM. Hopefully this and an upgrade to
RT3.0.5pre should solve my issue.

Although this is for version 3.x, most of the information is still
correct.

Regards,
Harald

Asif Iqbal
http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x8B686E08
There’s no place like 127.0.0.1

Try to go with my-large.cnf, the amount of RAM you’ve got is plenty for
my-large.

And yes try 3.0.5pre3.

A.

using my-large instead of my-medium and upgraded from RT-3-0-4 to RT-3-0-5pre3
and now the same ticket takes 9.5 sec to retrieve instead of 58 secs

Now I am not sure if I need to be concerned about the httpds that are
still over 10%

Thanks for all the help

-----Original Message-----
From: Asif Iqbal [mailto:iqbala@qwestip.net]
Sent: Thursday, August 21, 2003 4:46 PM
To: Ale¹ Su¹nik
Subject: RE: [rt-users] httpd’s are more than 10%

HW configuration?

Soalris 420R, 4x450 Mhz/4 GB Ram

mysql config?

my-medium.cnf

Tried 3.0.5pre3?

No, should I ?

A.

-----Original Message-----
From: rt-users-admin@lists.fsck.com [mailto:rt-users-admin@lists.fsck.com]
On Behalf Of Asif Iqbal
Sent: Thursday, August 21, 2003 3:58 PM
To: rt-users@lists.fsck.com
Cc: rt-devel@lists.fsck.com
Subject: [rt-users] httpd’s are more than 10%

I am using RT-3-0-4/Mysql4.0.13/Apache 1.3.27+mod_perl1/Perl 5.8

I noticed three out of 10 of my httpd sessions are taking more than 10% of
CPU
and they are excruciatingly slow. Not sure if we need to switch to a
different
product at this time. I really had very good experience with RT2 and not
with
RT3. I followed the instruction while upgrading to RT3.

Someone else experiencing the same way ?

Sorry I needed to vent out :frowning:

Thanks

Asif Iqbal
http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x8B686E08
There’s no place like 127.0.0.1

Try optimizing your mysql (there’s plenty of info about that on the web).
You said you’ve got 4gb of RAM, use it well…

A.From: Asif Iqbal [mailto:iqbala@qwestip.net]
Sent: Saturday, August 23, 2003 11:55 PM
To: Aleš Sušnik
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] httpd’s are more than 10%

Try to go with my-large.cnf, the amount of RAM you’ve got is plenty for
my-large.

And yes try 3.0.5pre3.

A.

using my-large instead of my-medium and upgraded from RT-3-0-4 to
RT-3-0-5pre3
and now the same ticket takes 9.5 sec to retrieve instead of 58 secs

Now I am not sure if I need to be concerned about the httpds that are
still over 10%

Thanks for all the help

-----Original Message-----
From: Asif Iqbal [mailto:iqbala@qwestip.net]
Sent: Thursday, August 21, 2003 4:46 PM
To: Aleš Sušnik
Subject: RE: [rt-users] httpd’s are more than 10%

HW configuration?

Soalris 420R, 4x450 Mhz/4 GB Ram

mysql config?

my-medium.cnf

Tried 3.0.5pre3?

No, should I ?

A.

-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]
On Behalf Of Asif Iqbal
Sent: Thursday, August 21, 2003 3:58 PM
To: rt-users@lists.fsck.com
Cc: rt-devel@lists.fsck.com
Subject: [rt-users] httpd’s are more than 10%

I am using RT-3-0-4/Mysql4.0.13/Apache 1.3.27+mod_perl1/Perl 5.8

I noticed three out of 10 of my httpd sessions are taking more than 10%
of
CPU
and they are excruciatingly slow. Not sure if we need to switch to a
different
product at this time. I really had very good experience with RT2 and not
with
RT3. I followed the instruction while upgrading to RT3.

Someone else experiencing the same way ?

Sorry I needed to vent out :frowning:

Thanks

Asif Iqbal
http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x8B686E08
There’s no place like 127.0.0.1

My RT3 is still slow afetr upgrading it from 3.04. to 3.0.5pre3. This is how my
cnf file looks like

[client]
port = 3306
socket = /tmp/mysql.sock

[mysqld]
port = 3306
socket = /tmp/mysql.sock
skip-locking
key_buffer = 384M
max_allowed_packet = 1M
table_cache = 512
sort_buffer_size = 2M
read_buffer_size = 2M
myisam_sort_buffer_size = 64M
thread_cache = 8
query_cache_size = 32M
thread_concurrency = 8

server-id = 1

innodb_data_home_dir = /usr/local/mysql/data/
innodb_data_file_path = ibdata1:1882M;ibdata2:10M:autoextend
innodb_log_group_home_dir = /usr/local/mysql/data/
innodb_log_arch_dir = /usr/local/mysql/data/
innodb_buffer_pool_size = 384M
innodb_additional_mem_pool_size = 20M
innodb_log_file_size = 100M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash

[isamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

I have only InnoDB and MyISAM tables as part of the default setup

Any suggestion for improvement now ?

Thanks a lotOn Sun, 24 Aug 2003, [iso-8859-2] Ale¹ Su¹nik wrote:

Try optimizing your mysql (there’s plenty of info about that on the web).
You said you’ve got 4gb of RAM, use it well…

A.

-----Original Message-----
From: Asif Iqbal [mailto:iqbala@qwestip.net]
Sent: Saturday, August 23, 2003 11:55 PM
To: Ale¹ Su¹nik
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] httpd’s are more than 10%

On Thu, 21 Aug 2003, [iso-8859-2] Ale¹ Su¹nik wrote:

Try to go with my-large.cnf, the amount of RAM you’ve got is plenty for
my-large.

And yes try 3.0.5pre3.

A.

using my-large instead of my-medium and upgraded from RT-3-0-4 to
RT-3-0-5pre3
and now the same ticket takes 9.5 sec to retrieve instead of 58 secs

Now I am not sure if I need to be concerned about the httpds that are
still over 10%

Thanks for all the help

-----Original Message-----
From: Asif Iqbal [mailto:iqbala@qwestip.net]
Sent: Thursday, August 21, 2003 4:46 PM
To: Ale¹ Su¹nik
Subject: RE: [rt-users] httpd’s are more than 10%

On Thu, 21 Aug 2003, [iso-8859-2] Ale¹ Su¹nik wrote:

HW configuration?

Soalris 420R, 4x450 Mhz/4 GB Ram

mysql config?

my-medium.cnf

Tried 3.0.5pre3?

No, should I ?

A.

-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]
On Behalf Of Asif Iqbal
Sent: Thursday, August 21, 2003 3:58 PM
To: rt-users@lists.fsck.com
Cc: rt-devel@lists.fsck.com
Subject: [rt-users] httpd’s are more than 10%

I am using RT-3-0-4/Mysql4.0.13/Apache 1.3.27+mod_perl1/Perl 5.8

I noticed three out of 10 of my httpd sessions are taking more than 10%
of
CPU
and they are excruciatingly slow. Not sure if we need to switch to a
different
product at this time. I really had very good experience with RT2 and not
with
RT3. I followed the instruction while upgrading to RT3.

Someone else experiencing the same way ?

Sorry I needed to vent out :frowning:

Thanks

Asif Iqbal
http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x8B686E08
There’s no place like 127.0.0.1

This is my my.cnf (copy from my-large.cnf), hope it helps you, a quick check
shows some differences:

Example mysql config file for large systems.

This is for large system with memory = 512M where the system runs mainly

MySQL.

You can copy this file to

/etc/my.cnf to set global options,

mysql-data-dir/my.cnf to set server-specific options (in this

installation this directory is /usr/local/mysql/var) or

~/.my.cnf to set user-specific options.

One can in this file use all long options that the program supports.

If you want to know which options a program support, run the program

with --help option.

The following options will be passed to all MySQL clients

[client]
#password = your_password
port = 3306
socket = /tmp/mysql.sock

Here follows entries for some specific programs

The MySQL server

[mysqld]
port = 3306
socket = /tmp/mysql.sock
skip-locking
key_buffer = 256M
max_allowed_packet = 16M
table_cache = 256
sort_buffer_size = 1M
read_buffer_size = 1M
myisam_sort_buffer_size = 64M
thread_cache = 8
query_cache_size= 16M
query_cache_type=1

Try number of CPU’s*2 for thread_concurrency

thread_concurrency = 8

Don’t listen on a TCP/IP port at all. This can be a security enhancement,

if all processes that need to connect to mysqld run on the same host.

All interaction with mysqld must be made via Unix sockets or named pipes.

Note that using this option without enabling named pipes on Windows

(via the “enable-named-pipe” option) will render mysqld useless!

#skip-networking

Replication Master Server (default)

binary logging is required for replication

log-bin

required unique id between 1 and 2^32 - 1

defaults to 1 if master-host is not set

but will not function as a master if omitted

#server-id = 2

The replication master for this slave - required

#master-host =

The username the slave will use for authentication when connecting

to the master - required

#master-user =

The password the slave will authenticate with when connecting to

the master - required

#master-password =

The port the master is listening on.

optional - defaults to 3306

#master-port =

binary logging - not required for slaves, but recommended

#log-bin

Point the following paths to different dedicated disks

#tmpdir = /tmp/
#log-update = /path-to-dedicated-directory/hostname

Uncomment the following if you are using BDB tables

#bdb_cache_size = 64M
#bdb_max_lock = 100000

Uncomment the following if you are using InnoDB tables

#innodb_data_home_dir = /usr/local/mysql/var/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /usr/local/mysql/var/
#innodb_log_arch_dir = /usr/local/mysql/var/

You can set …_buffer_pool_size up to 50 - 80 %

of RAM but beware of setting memory usage too high

innodb_buffer_pool_size = 256M
innodb_additional_mem_pool_size = 20M

Set …_log_file_size to 25 % of buffer pool size

#innodb_log_file_size = 64M
#innodb_log_buffer_size = 8M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash

Remove the next comment character if you are not familiar with SQL

#safe-updates

[isamchk]
key_buffer = 128M
sort_buffer_size = 128M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 128M
sort_buffer_size = 128M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

<== cut here ==>

A.From: Asif Iqbal [mailto:iqbala@qwestip.net]
Sent: Wednesday, August 27, 2003 5:46 PM
To: Aleš Sušnik
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] httpd’s are more than 10%

My RT3 is still slow afetr upgrading it from 3.04. to 3.0.5pre3. This is how
my
cnf file looks like

[client]
port = 3306
socket = /tmp/mysql.sock

[mysqld]
port = 3306
socket = /tmp/mysql.sock
skip-locking
key_buffer = 384M
max_allowed_packet = 1M
table_cache = 512
sort_buffer_size = 2M
read_buffer_size = 2M
myisam_sort_buffer_size = 64M
thread_cache = 8
query_cache_size = 32M
thread_concurrency = 8

server-id = 1

innodb_data_home_dir = /usr/local/mysql/data/
innodb_data_file_path = ibdata1:1882M;ibdata2:10M:autoextend
innodb_log_group_home_dir = /usr/local/mysql/data/
innodb_log_arch_dir = /usr/local/mysql/data/
innodb_buffer_pool_size = 384M
innodb_additional_mem_pool_size = 20M
innodb_log_file_size = 100M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash

[isamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

I have only InnoDB and MyISAM tables as part of the default setup

Any suggestion for improvement now ?

Thanks a lot

Try optimizing your mysql (there’s plenty of info about that on the web).
You said you’ve got 4gb of RAM, use it well…

A.

-----Original Message-----
From: Asif Iqbal [mailto:iqbala@qwestip.net]
Sent: Saturday, August 23, 2003 11:55 PM
To: Aleš Sušnik
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] httpd’s are more than 10%

Try to go with my-large.cnf, the amount of RAM you’ve got is plenty for
my-large.

And yes try 3.0.5pre3.

A.

using my-large instead of my-medium and upgraded from RT-3-0-4 to
RT-3-0-5pre3
and now the same ticket takes 9.5 sec to retrieve instead of 58 secs

Now I am not sure if I need to be concerned about the httpds that are
still over 10%

Thanks for all the help

-----Original Message-----
From: Asif Iqbal [mailto:iqbala@qwestip.net]
Sent: Thursday, August 21, 2003 4:46 PM
To: Aleš Sušnik
Subject: RE: [rt-users] httpd’s are more than 10%

HW configuration?

Soalris 420R, 4x450 Mhz/4 GB Ram

mysql config?

my-medium.cnf

Tried 3.0.5pre3?

No, should I ?

A.

-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]
On Behalf Of Asif Iqbal
Sent: Thursday, August 21, 2003 3:58 PM
To: rt-users@lists.fsck.com
Cc: rt-devel@lists.fsck.com
Subject: [rt-users] httpd’s are more than 10%

I am using RT-3-0-4/Mysql4.0.13/Apache 1.3.27+mod_perl1/Perl 5.8

I noticed three out of 10 of my httpd sessions are taking more than
10%
of
CPU
and they are excruciatingly slow. Not sure if we need to switch to a
different
product at this time. I really had very good experience with RT2 and
not
with
RT3. I followed the instruction while upgrading to RT3.

Someone else experiencing the same way ?

Sorry I needed to vent out :frowning:

Thanks

Asif Iqbal
http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x8B686E08
There’s no place like 127.0.0.1

I am using my-huge.cnf and using these three parameters from your conf for the
[mysqld] section. It did not help.

max_allowed_packet = 16M
query_cache_type=1
log-binOn Wed, 27 Aug 2003, [iso-8859-2] Ale¹ Su¹nik wrote:

This is my my.cnf (copy from my-large.cnf), hope it helps you, a quick check
shows some differences:

Example mysql config file for large systems.

This is for large system with memory = 512M where the system runs mainly

MySQL.

You can copy this file to

/etc/my.cnf to set global options,

mysql-data-dir/my.cnf to set server-specific options (in this

installation this directory is /usr/local/mysql/var) or

~/.my.cnf to set user-specific options.

One can in this file use all long options that the program supports.

If you want to know which options a program support, run the program

with --help option.

The following options will be passed to all MySQL clients

[client]
#password = your_password
port = 3306
socket = /tmp/mysql.sock

Here follows entries for some specific programs

The MySQL server

[mysqld]
port = 3306
socket = /tmp/mysql.sock
skip-locking
key_buffer = 256M
max_allowed_packet = 16M
table_cache = 256
sort_buffer_size = 1M
read_buffer_size = 1M
myisam_sort_buffer_size = 64M
thread_cache = 8
query_cache_size= 16M
query_cache_type=1

Try number of CPU’s*2 for thread_concurrency

thread_concurrency = 8

Don’t listen on a TCP/IP port at all. This can be a security enhancement,

if all processes that need to connect to mysqld run on the same host.

All interaction with mysqld must be made via Unix sockets or named pipes.

Note that using this option without enabling named pipes on Windows

(via the “enable-named-pipe” option) will render mysqld useless!

#skip-networking

Replication Master Server (default)

binary logging is required for replication

log-bin

required unique id between 1 and 2^32 - 1

defaults to 1 if master-host is not set

but will not function as a master if omitted

#server-id = 2

The replication master for this slave - required

#master-host =

The username the slave will use for authentication when connecting

to the master - required

#master-user =

The password the slave will authenticate with when connecting to

the master - required

#master-password =

The port the master is listening on.

optional - defaults to 3306

#master-port =

binary logging - not required for slaves, but recommended

#log-bin

Point the following paths to different dedicated disks

#tmpdir = /tmp/
#log-update = /path-to-dedicated-directory/hostname

Uncomment the following if you are using BDB tables

#bdb_cache_size = 64M
#bdb_max_lock = 100000

Uncomment the following if you are using InnoDB tables

#innodb_data_home_dir = /usr/local/mysql/var/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /usr/local/mysql/var/
#innodb_log_arch_dir = /usr/local/mysql/var/

You can set …_buffer_pool_size up to 50 - 80 %

of RAM but beware of setting memory usage too high

innodb_buffer_pool_size = 256M
innodb_additional_mem_pool_size = 20M

Set …_log_file_size to 25 % of buffer pool size

#innodb_log_file_size = 64M
#innodb_log_buffer_size = 8M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash

Remove the next comment character if you are not familiar with SQL

#safe-updates

[isamchk]
key_buffer = 128M
sort_buffer_size = 128M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 128M
sort_buffer_size = 128M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

<== cut here ==>

A.

-----Original Message-----
From: Asif Iqbal [mailto:iqbala@qwestip.net]
Sent: Wednesday, August 27, 2003 5:46 PM
To: Ale¹ Su¹nik
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] httpd’s are more than 10%

My RT3 is still slow afetr upgrading it from 3.04. to 3.0.5pre3. This is how
my
cnf file looks like

[client]
port = 3306
socket = /tmp/mysql.sock

[mysqld]
port = 3306
socket = /tmp/mysql.sock
skip-locking
key_buffer = 384M
max_allowed_packet = 1M
table_cache = 512
sort_buffer_size = 2M
read_buffer_size = 2M
myisam_sort_buffer_size = 64M
thread_cache = 8
query_cache_size = 32M
thread_concurrency = 8

server-id = 1

innodb_data_home_dir = /usr/local/mysql/data/
innodb_data_file_path = ibdata1:1882M;ibdata2:10M:autoextend
innodb_log_group_home_dir = /usr/local/mysql/data/
innodb_log_arch_dir = /usr/local/mysql/data/
innodb_buffer_pool_size = 384M
innodb_additional_mem_pool_size = 20M
innodb_log_file_size = 100M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash

[isamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

I have only InnoDB and MyISAM tables as part of the default setup

Any suggestion for improvement now ?

Thanks a lot

On Sun, 24 Aug 2003, [iso-8859-2] Ale¹ Su¹nik wrote:

Try optimizing your mysql (there’s plenty of info about that on the web).
You said you’ve got 4gb of RAM, use it well…

A.

-----Original Message-----
From: Asif Iqbal [mailto:iqbala@qwestip.net]
Sent: Saturday, August 23, 2003 11:55 PM
To: Ale¹ Su¹nik
Cc: rt-users@lists.fsck.com
Subject: RE: [rt-users] httpd’s are more than 10%

On Thu, 21 Aug 2003, [iso-8859-2] Ale¹ Su¹nik wrote:

Try to go with my-large.cnf, the amount of RAM you’ve got is plenty for
my-large.

And yes try 3.0.5pre3.

A.

using my-large instead of my-medium and upgraded from RT-3-0-4 to
RT-3-0-5pre3
and now the same ticket takes 9.5 sec to retrieve instead of 58 secs

Now I am not sure if I need to be concerned about the httpds that are
still over 10%

Thanks for all the help

-----Original Message-----
From: Asif Iqbal [mailto:iqbala@qwestip.net]
Sent: Thursday, August 21, 2003 4:46 PM
To: Ale¹ Su¹nik
Subject: RE: [rt-users] httpd’s are more than 10%

On Thu, 21 Aug 2003, [iso-8859-2] Ale¹ Su¹nik wrote:

HW configuration?

Soalris 420R, 4x450 Mhz/4 GB Ram

mysql config?

my-medium.cnf

Tried 3.0.5pre3?

No, should I ?

A.

-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]
On Behalf Of Asif Iqbal
Sent: Thursday, August 21, 2003 3:58 PM
To: rt-users@lists.fsck.com
Cc: rt-devel@lists.fsck.com
Subject: [rt-users] httpd’s are more than 10%

I am using RT-3-0-4/Mysql4.0.13/Apache 1.3.27+mod_perl1/Perl 5.8

I noticed three out of 10 of my httpd sessions are taking more than
10%
of
CPU
and they are excruciatingly slow. Not sure if we need to switch to a
different
product at this time. I really had very good experience with RT2 and
not
with
RT3. I followed the instruction while upgrading to RT3.

Someone else experiencing the same way ?

Sorry I needed to vent out :frowning:

Thanks

Asif Iqbal
http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x8B686E08
There’s no place like 127.0.0.1