HTML email with inline images

Hello List

Have just installed a clean RT4.2.5 system running on centos.

I’m testing at the moment and have run into issues with HTML formatted
email.

Scenario1
I’m using fetchmail to pull email form google via imap
Google appears to be creating a plain text version of all html formatted
email.
when the email reaches the ticket in RT the plain text email is listed but
not displays anything and the HTML formatted email is displayed correctly.
then the inline images are listed below as in screenshot.


OK

Problem1
The Autoreply in HTML is replying with only the first plaintext part of the
email inside

 html tags.it completely ignores the html part.
Think this may be what
http://lists.bestpractical.com/pipermail/rt-users/2014-June/083637.html may
be experiencing.

Scenario 2
I’m using fetchmail to pull email form exchange via imap
when the email reaches the ticket in RT the HTML formatted email is
displayed correctly. Then the inline images are listed. Good

Problem2
The Autoreply in HTML is replying, however the inline images have not been
added to the email so are displayed as empty boxes with red crosses. :frowning:

Have I missed something?

This at the moment is a bit of a show stopper as our customer user base
mostly use html formatted emails from outlook clients.

Improvements.
It would be nice if there was an option for inline pictures not to be
listed as attachments. only list files that have been attached such as
pdf’s spreadsheets, photos, documents etc. similar to how outlook works at
present.

Hopefully someone can help with pointer in the right direction.
Derek

Hi Derek,
We had a similar problem as well, and we submitted a simple change to Transaction.pm that solved the problem for us.

See In Line Images in Emails.
The change was submitted on 2nd June 2014

Regards

KevinFrom: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Derek keith
Sent: 16 July 2014 12:16
To: rt-users@lists.bestpractical.com
Subject: [rt-users] HTML email with inline images.

Hello List
Have just installed a clean RT4.2.5 system running on centos.
I’m testing at the moment and have run into issues with HTML formatted email.
Scenario1
I’m using fetchmail to pull email form google via imap
Google appears to be creating a plain text version of all html formatted email.
when the email reaches the ticket in RT the plain text email is listed but not displays anything and the HTML formatted email is displayed correctly. then the inline images are listed below as in screenshot. http://static.bestpractical.com/blog/whats-new-in-4.2/ticket-history-inline-image.png OK
Problem1
The Autoreply in HTML is replying with only the first plaintext part of the email inside

 html tags.ithttp://tags.it completely ignores the html part.
Think this may be what http://lists.bestpractical.com/pipermail/rt-users/2014-June/083637.html may be experiencing.

Scenario 2
I’m using fetchmail to pull email form exchange via imap
when the email reaches the ticket in RT the HTML formatted email is displayed correctly. Then the inline images are listed. Good
Problem2
The Autoreply in HTML is replying, however the inline images have not been added to the email so are displayed as empty boxes with red crosses. :frowning:
Have I missed something?
This at the moment is a bit of a show stopper as our customer user base mostly use html formatted emails from outlook clients.
Improvements.
It would be nice if there was an option for inline pictures not to be listed as attachments. only list files that have been attached such as pdf’s spreadsheets, photos, documents etc. similar to how outlook works at present.
Hopefully someone can help with pointer in the right direction.
Derek

Thanks Kevin

That appears to have fixed Problem1.

Now just need to get inline pictures to show on the email.

derekOn 16 July 2014 12:24, Kevin Curtis Kevin.Curtis@farsite.com wrote:

Hi Derek,

We had a similar problem as well, and we submitted a simple change to

Transaction.pm that solved the problem for us.

See In Line Images in Emails.

The change was submitted on 2nd June 2014

Regards

Kevin

From: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] *On
Behalf Of *Derek keith
Sent: 16 July 2014 12:16
To: rt-users@lists.bestpractical.com
Subject: [rt-users] HTML email with inline images.

Hello List

Have just installed a clean RT4.2.5 system running on centos.

I’m testing at the moment and have run into issues with HTML formatted
email.

Scenario1

I’m using fetchmail to pull email form google via imap

Google appears to be creating a plain text version of all html formatted
email.

when the email reaches the ticket in RT the plain text email is listed but
not displays anything and the HTML formatted email is displayed correctly.
then the inline images are listed below as in screenshot.
http://static.bestpractical.com/blog/whats-new-in-4.2/ticket-history-inline-image.png
OK

Problem1

The Autoreply in HTML is replying with only the first plaintext part of
the email inside

 html tags.it completely ignores the html part.

Think this may be what
http://lists.bestpractical.com/pipermail/rt-users/2014-June/083637.html
may be experiencing.

Scenario 2

I’m using fetchmail to pull email form exchange via imap
when the email reaches the ticket in RT the HTML formatted email is
displayed correctly. Then the inline images are listed. Good

Problem2
The Autoreply in HTML is replying, however the inline images have not been
added to the email so are displayed as empty boxes with red crosses. :frowning:

Have I missed something?

This at the moment is a bit of a show stopper as our customer user base
mostly use html formatted emails from outlook clients.

Improvements.

It would be nice if there was an option for inline pictures not to be
listed as attachments. only list files that have been attached such as
pdf’s spreadsheets, photos, documents etc. similar to how outlook works at
present.

Hopefully someone can help with pointer in the right direction.

Derek

Thanks Kevin

That appears to have fixed Problem1.

Now just need to get inline pictures to show on the email.

you may have a look at the last patch here:

http://issues.bestpractical.com/Ticket/Display.html?id=29967

Easter-eggs Spécialiste GNU/Linux
44-46 rue de l’Ouest - 75014 Paris - France - Métro Gaité
Phone: +33 (0) 1 43 35 00 37 - Fax: +33 (0) 1 43 35 00 76
mailto:elacour@easter-eggs.com - http://www.easter-eggs.com

Hi Derek,
Just tried a quick test, and now I see that in the first response from RT the images seem to get mislaid, but in all subsequent correspondence, any further images added are ok.

I guess I didn’t notice this here because we manage the creation of tickets on behalf of the customer, and then after that everything is ok.

If you come up with the answer we would be interested in implementing it here.

Another annoying features was the placement of “!” characters in the emails, which we also solved with another update that we submitted, see

Problems with ! in html format emails dated June 5th.

Regards

KevinFrom: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Derek keith
Sent: 16 July 2014 15:22
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] HTML email with inline images.

Thanks Kevin

That appears to have fixed Problem1.
Now just need to get inline pictures to show on the email.
derek

Can anyone help me get this working on RT 4.4.1 ?

The SendEmail.pm patch applies, but I am still getting emails converted to multipart/mixed with the images not inlined in the emails sent out. It looks like a mod to Transaction.pm like Kevin’s may still be required but the RT 4.4 code looks different to what has been referred to here.