How to set the sender e-mail address

Hi,

I configured a watcher in one of the trouble ticket queue and
set the scrips to send e-mail when there is a new ticket
created.

I noticed that the sender e-mail address is set as
nobody@localdomain.com (cause the apache is run as nobody).
Is there anyway so I can set the sender e-mail address as
support@mycompany.com.

TIA.

Daniel Windura wrote:

I configured a watcher in one of the trouble ticket queue and set the
scrips to send e-mail when there is a new ticket created.

Can you be more specific – what kind of watcher, and exactly what
scrip?

I noticed that the sender e-mail address is set as
nobody@localdomain.com

By “sender” do you mean the Sender: header or the From: header?

If you’re doing something like:

OnCreate NotifyCcs with template Transaction

I’d expect the From: header to have the requestor’s name and that
queue’s e-mail address – your webservers e-mail address shouldn’t be
used anywhere, since responding to that isn’t going to inject the
responses into ‘RT’.

Smylers
GBdirect
http://www.gbdirect.co.uk/

Smylers wrote:

I’d expect the From: header to have the requestor’s name and that
queue’s e-mail address – your webservers e-mail address shouldn’t be
used anywhere, since responding to that isn’t going to inject the
responses into ‘RT’.

Actually the webserver address appears as the “envelope” sender.
Theoretically this is where bounces will go to; this is a Good
Thing, as having bounces heading back into RT is a nifty way to
give yourself a happy fun mailbombing loop. :slight_smile:

But other than that, the From: header should indeed have the
address of the queue in it. We’d need to know more about the
problem setup to diagnose further (which MTA is in use, and
what the various config.pm mail options say…)

I noticed that the sender e-mail address is set as
nobody@localdomain.com (cause the apache is run as nobody).
Is there anyway so I can set the sender e-mail address as
support@mycompany.com.

Your MTA (probably sendmail) currently does not ‘trust’ the ‘nobody’ user
(with good reason!). If you add ‘nobody’ to the Trusted Users or
equivilant for your MTA, then your MTA will believe the ‘nobody’ user when
it defines an arbitary sending address, such as your RT queue system.

( Personally I like running the RT WebUI as a seperate user, and
’trusting’ that user, not the generic web ‘nobody’ user )

Search for ‘trusted’ in RT/FM (http://www.fsck.com/rtfm/) for more
specific hints for sendmail and exim.

Regards,

                         Bruce Campbell                            RIPE
               Systems/Network Engineer                             NCC
             www.ripe.net - PGP562C8B1B                      Operations

Hi,

Can you be more specific – what kind of watcher, and exactly what
scrip?

In the queue I put my e-mail address in the Administrative Cc field.
The scrip that I set is as follow:

OnCreate NotifyAllWatchers with template Transaction

By “sender” do you mean the Sender: header or the From: header?

It’s the From: header.

When I tried to create a new ticket on that queue, I received the email
from nobody@localdomain.com. localdomain.com is my domain name. I
suspect the nobody come from the user that run httpd

nobody 7860 7859 0 Apr12 ? 00:00:39
/usr/local/apache/bin/httpd

Is there anyway to set the From: header into something else like
support@anotherdomain.com?

Thanks.

Regards,

Daniel

Daniel Windura wrote:

In the queue I put my e-mail address in the Administrative Cc field.
The scrip that I set is as follow:

OnCreate NotifyAllWatchers with template Transaction

When I tried to create a new ticket on that queue, I received the
email from nobody@localdomain.com. localdomain.com is my domain name.
I suspect the nobody come from the user that run httpd

Is there anyway to set the From: header into something else like
support@anotherdomain.com?

The NotifyAllWatchers ScripAction should send mail out with the From:
header set to be the e-mail address of that particular queue (so that
any responses to that e-mail go through ‘RT’).

Can you check that the address for that queue is correct? If so, then
look at the permissions problem that somebody else (sorry, I’ve
forgotten who) suggested – ‘RT’ might be trying to set its From:
header, but your MTA doesn’t trust the nobody user sufficiently to allow
it to fake its own identity.

Smylers
GBdirect
http://www.gbdirect.co.uk/