How to get searches on "RT at a Glance" homepage to show ALL results?

My saved searches on my “RT at a Glance”/homepage do not show all the results and they do not indicate that there are more results in that search. How can I change this so it shows all the search results and/or alerts me that there are more? I have already changed the individual search settings on those saved searches to show all rows/results and that works when you run that individual search manually, but does not run correctly on the “RT at a Glance” homepage. Thanks.

See https://docs.bestpractical.com/rt/4.4.4/RT_Config.html#Home-page for homepage config options

1 Like

The “at a glance” page shows 10 tickets per portlet, by default.

1 Like

And low and behold, Set ($DefaultSummaryRows,300); did not work.

Has anyone here had experience getting this sort of function to work? Curious to see if others have had the same problem or not.

When you set the above did you clear your mason cache and restart your webserver? Testing real quick I can see my results go from 10->15 tickets when I change that value from 10->15 on my RT

1 Like

knation, I rebooted the RT server, but I did not clear the mason cache, as I don’t know how to do that.

You need to find the directory that RT is configured to use as the cache for the Mason objects and then remove that before restarting the web server. That will depend on how you’ve got RT installed on your machine - I could tell you where ours is (/opt/rt4/var/mason_data/obj) but yours may well be different. You’ll have to hunt around for it I’m afraid.