How to force text/plain for email sent by RT

I would like to force outgoing emails sent by RT as text/plain because I wish to use inline PGP signature. Is there a way to force this behavior ?
thank you


Effectively you just want to ensure that only the plain text versions of the templates you use to generate emails are employed. There’s a Best Practical blog post from back in 2013 when they improved HTML support in RT that might help, including a mention of the script:

/opt/rt4/etc/upgrade/switch-templates-to text

that should switch all the standard, distributed templates over to plain text (I don’t think it will help if you’ve got locally generated templates for your own scrips).

thank you very much. It worked.
Anyway when I Reply to a ticket I explicitly have to select the “Sign” option for the message to be signed. Is there a way to Sign by default ?
In I configured option

Set( %GnuPG,
Enable => 1,
OutgoingMessagesFormat => ‘Inline’,

thank you

We don’t use signing ourselves, but I know this can be done on a queue by queue basis. If you log in as an administrative user for RT, go to Admin->Queues, select a queue and then you’ll see check boxes for “Sign by default”, “Encrypt by default” and “Sign all auto-generated mail.”. Check as appropriate and select the required GnuPG keys, then click Save.