How to display a logo in RT 3.8.2

Hi,

I followed these http://wiki.bestpractical.com/view/ChangeLogo 

directions, but there still isn’t any logo getting displayed. When I do
a view source I see the code for the logo but nothing is displayed on
the page. I also found this
http://www.gossamer-threads.com/lists/rt/users/78249?do=post_view_threaded
which looks like the same issue I’m having. Any and all help is greatly
appreciated.

Thanks,
~Jet

Also when I navigate directly to the image I get:

The image �http://servername/rt/NoAuth/images/logo.gif� cannot be
displayed, because it contains errors.

However if I open up Firefox on that machine and then open up that image
file it opens fine.

Any ideas?

Jet Wilda wrote:

Jet Wilda wrote:

Hi,

I followed these http://wiki.bestpractical.com/view/ChangeLogo 

directions, but there still isn’t any logo getting displayed. When I do
a view source I see the code for the logo but nothing is displayed on
the page. I also found this
http://www.gossamer-threads.com/lists/rt/users/78249?do=post_view_threaded
which looks like the same issue I’m having. Any and all help is greatly
appreciated.

The CSS for the web2 style prevents the logo image being displayed. As a
quick way of telling that the modifications you made so far are correct, try
setting your preferences to use one of the other styles. The logo should
appear.

To make the logo appear under the default web2 style, as well as changing the
background to match the colour scheme of our company logo I created a local
copy of layout.css with the following changes:

% diff -u /usr/local/share/rt38/html/NoAuth/css/web2/layout.css /usr/local/www/rt38/NoAuth/css/web2/layout.css
— /usr/local/share/rt38/html/NoAuth/css/web2/layout.css 2009-02-25 22:19:11.000000000 +0000
+++ /usr/local/www/rt38/NoAuth/css/web2/layout.css 2009-02-17 11:37:42.000000000 +0000
@@ -53,7 +53,7 @@
padding:0;
margin:0;

  • background: #547CCC url(<%RT->Config->Get(‘WebPath’)%>/NoAuth/css/web2/images/background-gradient.png) top left repeat-x ;
  • background: #a2a2a2 url(<%RT->Config->Get(‘WebPath’)%>/NoAuth/css/web2/images/background-gradient.png) top left repeat-x ;
    font-family: arial, helvetica, sans-serif;

}
@@ -163,10 +163,10 @@

div#logo a {

  • display: none;
    
  • position: absolute;
  • left: 0;
  • bottom: 0;
  • /* display: none; */
  • position: fixed;
  • left: 1%;
  • bottom: 1%;
    }
    div#logo a img {
    border: 0;

(Note the file names are from the FreeBSD layout for rt-3.8.x – on most systems
the original file would be in ${RTHOME}/html/NoAuth/css/web2/layout.css and the modified copy should go into ${RTHOME}/local/NoAuth/css/web2/layout.css)

This displays the logo in the bottom left of the browser window – it’s fixed relative
to the window rather than scrolling with the page content. I also cooked up a modified
background-gradient.png in gimp – just changing the colours – which I installed into
/usr/local/www/rt38/NoAuth/css/web2/images/source/background-gradient.png. In order
to get it to display I had to copy /usr/local/share/rt38/html/NoAuth/css/web2/images/dhandler to /usr/local/www/rt38/NoAuth/css/web2/images/dhandler

Et voilà.

Cheers,

Matthew

Dr Matthew Seaman The Bunker, Ash Radar Station
PGP: 0x60AE908C on servers Marshborough Rd
Tel: +44 1304 814890 Sandwich
Fax: +44 1304 814899 Kent, CT13 0PL, UK

signature.asc (259 Bytes)

Hi,

First I would like to say thank you all for the help.  We got our

logo to show up.
Here is what we did in case anyone else runs into this (replace $RT_HOME with where RT is installed):

  • created local logo (mylogo.gif) in $RT_HOME/local/html/NoAuth/images
  • edit local layout.css file in $RT_HOME/local/html/NoAuth/css/web2
    • remove display: none; from div#logo a
  • edit the RT_SiteConfig.pm in $RT_HOME/etc
Set($WebBaseURL, "http://server");

Set($WebPath, “/rt”);

Set($WebImagesURL , $WebPath . “/NoAuth/images/”);

Set($LogoURL, $WebImagesURL . ‘mylogo.gif’);

Set($LogoLinkURL, ‘http://server’);

Set($LogoImageURL, $WebImagesURL . “mylogo.gif”);

Set($LogoAltText, “MyInformation”);

Set($LogoWidth, ‘486’);

Set($LogoHeight, ‘155’);

At this point it didn't work and we received the following errors:
In FireFox:
The image “http://server/rt/NoAuth/images/mylogo.gif” cannot be displayed, because it contains errors.
or in IE:
'<&' without matching '&>' at $RT_HOME/local/html/NoAuth/images/mylogo.gif line 90
sometimes:
Error during compilation of /$RT_HOME/local/html/NoAuth/images/mylogo.gif:

Unrecognized character \x08 at
/$RT_HOME/local/html/NoAuth/images/mylogo.gif line 229.

Stack:

[/$RT_HOME/local/html/NoAuth/images/mylogo.gif:229]

[/usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Interp.pm:811]

[/usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Interp.pm:441]

[/usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm:246]

[/usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Request.pm:211]

[/usr/lib/perl5/site_perl/5.8.8/HTML/Mason/ApacheHandler.pm:97]

[/$RT_HOME/bin/…/lib/RT/Interface/Web/Request.pm:68]

[/usr/lib/perl5/vendor_perl/5.8.8/Class/Container.pm:275]

[/usr/lib/perl5/vendor_perl/5.8.8/Class/Container.pm:353]

[/usr/lib/perl5/site_perl/5.8.8/HTML/Mason/Interp.pm:348]

[/usr/lib/perl5/site_perl/5.8.8/HTML/Mason/ApacheHandler.pm:868]

[/usr/lib/perl5/site_perl/5.8.8/HTML/Mason/ApacheHandler.pm:822]

[/$RT_HOME/bin/webmux.pl:149]

[/$RT_HOME/local/html/NoAuth/images/mylogo.gif:229]

To get past that we had to add the below to our apache config:
<Directory $RT_HOME/share/html/NoAuth/images>
    SetHandler default-handler

</Directory>

Restart apache and clear the mason cache and still no image. Apparently adding that to the apache configuration causes the local images directory ($RT_HOME/local/html/NoAuth/images) to not work. Moving the image into the non local directory ($RT_HOME/share/html/NoAuth/images) causes the image to show up. However since our image was a different size we also had to modify the Logo file ($RT_HOME/share/html/Elements) by making a local copy ($RT_HOME/local/html/Elemets). Here is what we changed:
<a href="<%$RT::LogoLinkURL%>"><img
src="&lt;%$RT::LogoImageURL%&gt;"


alt="&lt;%$RT::LogoAltText%&gt;"


width="&lt;%$RT::LogoWidth%&gt;"


height="&lt;%$RT::LogoHeight%&gt;" /&gt;&lt;/a&gt;
After restarting apache and clearing the mason cache the image showed up. We did have to edit other CSS files because our logo was bigger.

~Jet

Matthew Seaman wrote:

Jet Wilda wrote:
Hi,
I followed these <a class="moz-txt-link-freetext" href="http://wiki.bestpractical.com/view/ChangeLogo">http://wiki.bestpractical.com/view/ChangeLogo</a>

directions, but there still isn’t any logo getting displayed. When I
do a view source I see the code for the logo but nothing is displayed
on the page. I also found this http://www.gossamer-threads.com/lists/rt/users/78249?do=post_view_threaded
which looks like the same issue I’m having. Any and all help is
greatly appreciated.

The CSS for the web2 style prevents the logo image being displayed. As
a

quick way of telling that the modifications you made so far are
correct, try

setting your preferences to use one of the other styles. The logo
should

appear.

To make the logo appear under the default web2 style, as well as
changing the

background to match the colour scheme of our company logo I created a
local

copy of layout.css with the following changes:

% diff -u /usr/local/share/rt38/html/NoAuth/css/web2/layout.css
/usr/local/www/rt38/NoAuth/css/web2/layout.css

— /usr/local/share/rt38/html/NoAuth/css/web2/layout.css
2009-02-25 22:19:11.000000000 +0000

+++ /usr/local/www/rt38/NoAuth/css/web2/layout.css 2009-02-17
11:37:42.000000000 +0000

@@ -53,7 +53,7 @@

padding:0; 


margin:0; 
  • background: #547CCC
    url(<%RT->Config->Get(‘WebPath’)%>/NoAuth/css/web2/images/background-gradient.png)
    top left repeat-x ;
  • background: #a2a2a2
    url(<%RT->Config->Get(‘WebPath’)%>/NoAuth/css/web2/images/background-gradient.png)
    top left repeat-x ;
font-family: arial, helvetica, sans-serif; 

}

@@ -163,10 +163,10 @@

div#logo a {

  • display: none; 
    
  • position: absolute;

  • left: 0;

  • bottom: 0;

  • /* display: none; */

  • position: fixed;

  • left: 1%;

  • bottom: 1%;

}

div#logo a img {

border: 0; 

(Note the file names are from the FreeBSD layout for rt-3.8.x – on
most systems

the original file would be in ${RTHOME}/html/NoAuth/css/web2/layout.css
and the modified copy should go into
${RTHOME}/local/NoAuth/css/web2/layout.css)

This displays the logo in the bottom left of the browser window – it’s
fixed relative

to the window rather than scrolling with the page content. I also
cooked up a modified

background-gradient.png in gimp – just changing the colours – which I
installed into

/usr/local/www/rt38/NoAuth/css/web2/images/source/background-gradient.png.
In order

to get it to display I had to copy
/usr/local/share/rt38/html/NoAuth/css/web2/images/dhandler to
/usr/local/www/rt38/NoAuth/css/web2/images/dhandler

Et voilà.

Cheers, 




Matthew