How do I set the RT hostname?

I’m in the process of setting up a new RT 4.4 instance. I used the web
installer, which generated the following RT-SiteConfig.pm:

Set( $CommentAddress, ‘dev@example.com’ );
Set( $CorrespondAddress, ‘dev@example.com’ );
Set( $DatabaseHost, ‘localhost’ );
Set( $DatabaseName, ‘rt4’ );
Set( $DatabasePassword, ‘xxxxxxxxxxxxx’ );
Set( $DatabasePort, ‘’ );
Set( $DatabaseType, ‘mysql’ );
Set( $DatabaseUser, ‘rt_user’ );
Set( $Organization, ‘rt2.example.com’ );
Set( $OwnerEmail, ‘dev@example.com’ );
Set( $SendmailPath, ‘/usr/sbin/sendmail’ );
Set( $WebDomain, ‘rt2.example.com’ );
Set( $WebPort, ‘80’ );
Set( $rtname, ‘rt2.example.com’ );
1;

{ I’ve substituted ‘rt2.example.com’ for the actual FQDN of the machine
that’s hosting the instance }

When I tried to set up a new asset, I got the following error message:

RT has detected a possible cross-site request forgery for this request,
because the Referrer header supplied by your browser (rt2.example.com:80)
is not allowed by RT’s configured hostname (127.0.0.1:80).

A bit of googling showed me how to set this in RT-SiteConfig.pm:

Set(@ReferrerWhitelist, qw(127.0.0.1:80));

… that did disable the message, but why is the ‘configured hostname’ set
to 127.0.0.1:80, and how do I set it to the actual domain name of the
machine?

Thanks,

–Barton

On my test system I get the behavior you describe when $WebDomain does not match the URL in my browser.

Are you sure you’ve restarted your web server since making the change?From: rt-users [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Barton Chittenden
Sent: Monday, November 21, 2016 8:19 AM
To: rt-users
Subject: [rt-users] How do I set the RT hostname?

I’m in the process of setting up a new RT 4.4 instance. I used the web installer, which generated the following RT-SiteConfig.pm:

Set( $CommentAddress, ‘dev@example.commailto:dev@example.com’ );
Set( $CorrespondAddress, ‘dev@example.commailto:dev@example.com’ );
Set( $DatabaseHost, ‘localhost’ );
Set( $DatabaseName, ‘rt4’ );
Set( $DatabasePassword, ‘xxxxxxxxxxxxx’ );
Set( $DatabasePort, ‘’ );
Set( $DatabaseType, ‘mysql’ );
Set( $DatabaseUser, ‘rt_user’ );
Set( $Organization, ‘rt2.example.comhttp://rt2.example.com’ );
Set( $OwnerEmail, ‘dev@example.commailto:dev@example.com’ );
Set( $SendmailPath, ‘/usr/sbin/sendmail’ );
Set( $WebDomain, ‘rt2.example.comhttp://rt2.example.com’ );
Set( $WebPort, ‘80’ );
Set( $rtname, ‘rt2.example.comhttp://rt2.example.com’ );
1;

{ I’ve substituted ‘rt2.example.comhttp://rt2.example.com’ for the actual FQDN of the machine that’s hosting the instance }

When I tried to set up a new asset, I got the following error message:

RT has detected a possible cross-site request forgery for this request, because the Referrer header supplied by your browser (rt2.example.com:80http://rt2.example.com:80) is not allowed by RT’s configured hostname (127.0.0.1:80http://127.0.0.1:80).

A bit of googling showed me how to set this in RT-SiteConfig.pm:

Set(@ReferrerWhitelist, qw(127.0.0.1:80));

… that did disable the message, but why is the ‘configured hostname’ set to 127.0.0.1:80http://127.0.0.1:80, and how do I set it to the actual domain name of the machine?

Thanks,

–Barton

One more thing to note…

Set( $CommentAddress, ‘dev@example.com mailto:dev@example.com’ );

Set( $CorrespondAddress, ‘dev@example.com mailto:dev@example.com’ );

If these two are indeed the same, change the CommentAddress to something
you won’t use as much, like dev-comment@example.com. If these are the
same, RT may not know whether it should add a comment, or add
correspondence to the ticket.

Best regards,
SteveOn 11/21/2016 09:20 AM, Peter Zillmann wrote:

On my test system I get the behavior you describe when $WebDomain does
not match the URL in my browser.

Are you sure you’ve restarted your web server since making the change?

*From:*rt-users [mailto:rt-users-bounces@lists.bestpractical.com] *On
Behalf Of *Barton Chittenden
Sent: Monday, November 21, 2016 8:19 AM
To: rt-users
Subject: [rt-users] How do I set the RT hostname?

I’m in the process of setting up a new RT 4.4 instance. I used the web
installer, which generated the following RT-SiteConfig.pm:

Set( $CommentAddress, ‘dev@example.com mailto:dev@example.com’ );

Set( $CorrespondAddress, ‘dev@example.com mailto:dev@example.com’ );

Set( $DatabaseHost, ‘localhost’ );

Set( $DatabaseName, ‘rt4’ );

Set( $DatabasePassword, ‘xxxxxxxxxxxxx’ );

Set( $DatabasePort, ‘’ );

Set( $DatabaseType, ‘mysql’ );

Set( $DatabaseUser, ‘rt_user’ );

Set( $Organization, ‘rt2.example.com http://rt2.example.com’ );

Set( $OwnerEmail, ‘dev@example.com mailto:dev@example.com’ );

Set( $SendmailPath, ‘/usr/sbin/sendmail’ );

Set( $WebDomain, ‘rt2.example.com http://rt2.example.com’ );

Set( $WebPort, ‘80’ );

Set( $rtname, ‘rt2.example.com http://rt2.example.com’ );

1;

{ I’ve substituted ‘rt2.example.com http://rt2.example.com’ for the
actual FQDN of the machine that’s hosting the instance }

When I tried to set up a new asset, I got the following error message:

RT has detected a possible cross-site request forgery for this
request, because the Referrer header supplied by your browser
(rt2.example.com:80 http://rt2.example.com:80) is not allowed by
RT’s configured hostname (127.0.0.1:80 http://127.0.0.1:80).

A bit of googling showed me how to set this in RT-SiteConfig.pm:

Set(@ReferrerWhitelist, qw(127.0.0.1:80));

… that did disable the message, but why is the 'configured hostname’
set to 127.0.0.1:80 http://127.0.0.1:80, and how do I set it to the
actual domain name of the machine?

Thanks,

–Barton


RT 4.4 and RTIR training sessions, and a new workshop day! https://bestpractical.com/training

  • Los Angeles - January 9-11 2017