How can i set Default ACLs?

Hi all,

as a fresh new user/admin of RT i am struggling with unsufficient amount of
information.

I was able to install and (probably correct) sett up the RT 2.0.11 system.
I have created user Tester, queue “support” and two emails for this queue,
support@… & support-comment@…

Now, when i send email to the support@… the system has been already
answering :
“No permission to create tickets in the queue ‘support’.Create failed: 0 / 0
/ No permission to create tickets in the queue ‘support’.”

In the archive, i have found similar question with answer “You need to set
the Default ACLs per the Installation and Configuration guide”.

So: HOW CAN I DO THAT ??

		thx, Z.P.

|+ “No permission to create tickets in the queue ‘support’.Create failed: 0 / 0
|+ / No permission to create tickets in the queue ‘support’.”
|+
|+ In the archive, i have found similar question with answer “You need to set
|+ the Default ACLs per the Installation and Configuration guide”.
|+
|+ So: HOW CAN I DO THAT ??

You have to grant user rights.

|+ “No permission to create tickets in the queue ‘support’.Create failed: 0 / 0
|+ / No permission to create tickets in the queue ‘support’.”
|+
|+ In the archive, i have found similar question with answer “You need to set
|+ the Default ACLs per the Installation and Configuration guide”.
|+
|+ So: HOW CAN I DO THAT ??

You have to grant user rights.

Hi,

As an administrative user, select the Queue in the
configuration section, and then the queue in question.

Select “group rights”.

There’ll be an “Everyone” section - you’ll need to grant
"Everyone" the “Create Ticket” (and possibly “Reply-To Ticket”)
right.

Then save, and try it.

HTH,

Adrian

Adrian Chadd “The first rule of optimisation:
adrian@creative.net.au Don’t do it, and at least don’t
do it yet.” – Stefan Axelsson

-----Original Message-----
From: Darrin Walton [mailto:darrinw@nixc.net]
Sent: Friday, January 25, 2002 7:33 AM
To: Zdenek Pizl
Cc: rt-users@lists.fsck.com
Subject: Re: [rt-users] how can i set Default ACLs ??

|+ “No permission to create tickets in the queue
’support’.Create failed: 0 / 0
|+ / No permission to create tickets in the queue ‘support’.”
|+
|+ In the archive, i have found similar question with
answer “You need to set
|+ the Default ACLs per the Installation and Configuration guide”.
|+
|+ So: HOW CAN I DO THAT ??

You have to grant user rights.

The Installation Guide section titled "Users and Queues and Scrips, Oh My"
lists the basic ACLs needed to get started.

Nice timing… I was just trying to set this up and this thread was helpfull… However I think I have set something wrong, here’s the error I get when sending mail to support@rt.foo.com:

----- The following addresses had permanent fatal errors -----
"|/usr/local/rt2/bin/rt-mailgate --queue support --action correspond"
(reason: service unavailable)
(expanded from: support@rt.foo.com)

----- Transcript of session follows -----
smrsh: rt-mailgate not available for sendmail programs
554 5.0.0 Service unavailable

[ Part 2: "Delivery Status" ]

Reporting-MTA: dns; rt.foo.com
Arrival-Date: Fri, 25 Jan 2002 18:14:41 -0800

Final-Recipient: RFC822; support@rt.foo.com
X-Actual-Recipient: X-Unix; |/usr/local/rt2/bin/rt-mailgate --queue support --action correspond
Action: failed
Status: 5.5.0
Diagnostic-Code: X-Unix; 69

Here is my /etc/aliases file:

RT2

support: "|/usr/local/rt2/bin/rt-mailgate --queue support --action correspond"
support-comment: “|/usr/local/rt2/bin/rt-mailgate --queue support --action comment”

My RT install is living on an i686 RH7.2 system with no extras, it’s dedicated to RT with nothing other than the dependencies and OpenSSH_3.0.2p1 added to the system. The support queue is called “Support Requests” and in the Queue configuration page I have the following set:
Correspondence Address: support@rt.foo.com
Comment Address: support-comment@rt.foo.com

Anyone have experience with this error?

Thanks!On January 25, 2002 05:44 am, you wrote:

On Fri, Jan 25, 2002, Darrin Walton wrote:

|+ “No permission to create tickets in the queue ‘support’.Create
| failed: 0 / 0 + / No permission to create tickets in the queue
| ‘support’.”
|+
|+ In the archive, i have found similar question with answer “You need
| to set + the Default ACLs per the Installation and Configuration
| guide”. +
|+ So: HOW CAN I DO THAT ??

You have to grant user rights.

Hi,

As an administrative user, select the Queue in the
configuration section, and then the queue in question.

Select “group rights”.

There’ll be an “Everyone” section - you’ll need to grant
"Everyone" the “Create Ticket” (and possibly “Reply-To Ticket”)
right.

Then save, and try it.

HTH,

Adrian

Do this: ln -s /usr/local/rt2/bin/rt-mailgate /etc/smrsh/rt-mailgate

Then try again

Greg Smythe
SysAdmin
Intellstat Communications
WA State ResidentFrom: RT2 Troubles [mailto:rt2trouble@morben.ca]
Sent: Friday, January 25, 2002 10:14 AM
To: rt-users@lists.fsck.com
Subject: Re: [rt-users] how can i set Default ACLs ??

Nice timing… I was just trying to set this up and this thread was
helpfull… However I think I have set something wrong, here’s the error I
get when sending mail to support@rt.foo.com:

----- The following addresses had permanent fatal errors -----
"|/usr/local/rt2/bin/rt-mailgate --queue support --action correspond"
(reason: service unavailable)
(expanded from: support@rt.foo.com)

----- Transcript of session follows -----
smrsh: rt-mailgate not available for sendmail programs
554 5.0.0 Service unavailable

[ Part 2: "Delivery Status" ]

Reporting-MTA: dns; rt.foo.com
Arrival-Date: Fri, 25 Jan 2002 18:14:41 -0800

Final-Recipient: RFC822; support@rt.foo.com
X-Actual-Recipient: X-Unix; |/usr/local/rt2/bin/rt-mailgate --queue support
–action correspond
Action: failed
Status: 5.5.0
Diagnostic-Code: X-Unix; 69

Here is my /etc/aliases file:

RT2

support: "|/usr/local/rt2/bin/rt-mailgate --queue support --action
correspond"
support-comment: “|/usr/local/rt2/bin/rt-mailgate --queue support --action
comment”

My RT install is living on an i686 RH7.2 system with no extras, it’s
dedicated to RT with nothing other than the dependencies and OpenSSH_3.0.2p1
added to the system. The support queue is called “Support Requests” and in
the Queue configuration page I have the following set:
Correspondence Address: support@rt.foo.com
Comment Address: support-comment@rt.foo.com

Anyone have experience with this error?

Thanks!

Wow… Big thanks to Greg Smythe … that man is a problem solver and a half.
After fixing two issues in a row via some private exchanges I decided to stop
bugging Greg and I’m posting this last (I hope) problem to the list.

We can now accept customer mail (thanks Greg) and RT2 is putting it into the
right queues (thanks again Greg), but when we reply to the customer submitted
ticket, there’s no mail sent and no error in the rt.log files or in
/var/log/maillog… It’s almost like it’s not even trying to send the reply
out. Any suggestions of other log files to check or which settings I should
check that effect mail replies?

Thanks in advance, this list is great!

Ohh! Ohh! I know the answer to this! I bet you don’t have a “OnCorrespond
NotifyAllWatchers with template Correspondence” scrip setup for the queue :slight_smile:

<I’m bored so I thought I’d answer anyways>

Greg Smythe
SysAdmin
Intellstat Communications
WA State Resident-----Original Message-----
From: RT2 Troubles [mailto:rt2trouble@morben.ca]
Sent: Friday, January 25, 2002 2:43 PM
To: rt-users@lists.fsck.com
Subject: Re: [rt-users] how can i set Default ACLs ??

Wow… Big thanks to Greg Smythe … that man is a problem solver and a half.
After fixing two issues in a row via some private exchanges I decided to
stop
bugging Greg and I’m posting this last (I hope) problem to the list.

We can now accept customer mail (thanks Greg) and RT2 is putting it into the

right queues (thanks again Greg), but when we reply to the customer
submitted
ticket, there’s no mail sent and no error in the rt.log files or in
/var/log/maillog… It’s almost like it’s not even trying to send the reply
out. Any suggestions of other log files to check or which settings I should
check that effect mail replies?

Thanks in advance, this list is great!

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Uuuh no… Hahaha… NotifyMyGrandmaThatThisVariableIsTooLong ? Hahaha… I
didn’t touch the scrips yet because it said in the instructions that the
primary reason to touch scrips was to have an auto-respond to email -> queue
requests. I guess I better go read em! Thanks again Greg! ;)On January 25, 2002 03:03 pm, you wrote:

Ohh! Ohh! I know the answer to this! I bet you don’t have a “OnCorrespond
NotifyAllWatchers with template Correspondence” scrip setup for the queue
:slight_smile:

<I’m bored so I thought I’d answer anyways>

-=-=-=-=-=-=-=-=-=-=-=-=-=-
Greg Smythe
SysAdmin
Intellstat Communications
WA State Resident

-----Original Message-----
From: RT2 Troubles [mailto:rt2trouble@morben.ca]
Sent: Friday, January 25, 2002 2:43 PM
To: rt-users@lists.fsck.com
Subject: Re: [rt-users] how can i set Default ACLs ??

Wow… Big thanks to Greg Smythe … that man is a problem solver and a half.
After fixing two issues in a row via some private exchanges I decided to
stop
bugging Greg and I’m posting this last (I hope) problem to the list.

We can now accept customer mail (thanks Greg) and RT2 is putting it into
the

right queues (thanks again Greg), but when we reply to the customer
submitted
ticket, there’s no mail sent and no error in the rt.log files or in
/var/log/maillog… It’s almost like it’s not even trying to send the reply
out. Any suggestions of other log files to check or which settings I should
check that effect mail replies?

Thanks in advance, this list is great!


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Oh my… That didn’t require any reading… it was so simple… The more I learn
RT the more I like it… It’s almost as good as Linux! :slight_smile:

Thanks Greg! Thanks everyone! Even if that was the very last bug, I’ll still
watch this list and try to share what I have learned.

happy danceOn January 25, 2002 03:03 pm, you wrote:

Ohh! Ohh! I know the answer to this! I bet you don’t have a “OnCorrespond
NotifyAllWatchers with template Correspondence” scrip setup for the queue
:slight_smile:

<I’m bored so I thought I’d answer anyways>

-=-=-=-=-=-=-=-=-=-=-=-=-=-
Greg Smythe
SysAdmin
Intellstat Communications
WA State Resident

-----Original Message-----
From: RT2 Troubles [mailto:rt2trouble@morben.ca]
Sent: Friday, January 25, 2002 2:43 PM
To: rt-users@lists.fsck.com
Subject: Re: [rt-users] how can i set Default ACLs ??

Wow… Big thanks to Greg Smythe … that man is a problem solver and a half.
After fixing two issues in a row via some private exchanges I decided to
stop
bugging Greg and I’m posting this last (I hope) problem to the list.

We can now accept customer mail (thanks Greg) and RT2 is putting it into
the

right queues (thanks again Greg), but when we reply to the customer
submitted
ticket, there’s no mail sent and no error in the rt.log files or in
/var/log/maillog… It’s almost like it’s not even trying to send the reply
out. Any suggestions of other log files to check or which settings I should
check that effect mail replies?

Thanks in advance, this list is great!


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users