How can I get rid of using -no-verify-ssl

What kind of security risk does using -no-verify-ssl in the aliases pose?

I have tried to replace it with --ca-file /etc/apache2/ssl/wildcardcet.crt but that doesn’t work. I get a HTTP request failed: 500 Can’t connect to (certificate verify failed)

I am using a wildcard cert and have edited mailgater per this thread:Rt-mailgate ignoring --no-verify-ssl?

Thank you

=item C<–no-verify-ssl>

This flag tells the mail gateway to trust all SSL certificates,

regardless of if their hostname matches the certificate, and regardless

of CA. This is required if you have a self-signed certificate, or some

other certificate which is not traceable back to an certificate your

system ultimitely trusts.

You will need that config if your cert is self signed, I don’t think the risk is high since you know the URL the mail is being piped to

Thank you, knation, for all of your help.