Help with RT 3.4.4 authentication to windows 2003

hi
I’m struggling to get RT working with active directory
on windows 2003. RT 3.4.4, fedora core 4. apache
2.0.54.

I’ve tried the RTSMB files (I used these fine on
3.4.2, but get an error of
RT: LDAPAuth: Cannot bind to LDAP: 1
LDAP_OPERATIONS_ERROR
(/usr/local/rt3/local/lib/RT/User_Local.pm:130)

So I tried something else but couldn’t find the
original User_Local.pm mentioned in the wiki so using
http://www.justatheory.com/computers/programming/perl/rt/ldap_auth.html

I seem to find the LDAP server (If i put in the wrong
one I get an error).
I seem to bind (again a wrong one gives an error 49).
But I then can’t login -

Jan 5 15:31:03 server RT: Using External
Authentication
(/usr/local/rt3/local/lib/RT/User_Local.pm:52)
Jan 5 15:31:03 server RT: FAILED LOGIN for username
from ip (/usr/local/rt3/local/html/autohandler:144)

My RT_SiteConfig.pm has parameters as -

$LDAPExternalAuth = 1;
$LdapServer=“server.domain”;
$LdapUser=“cn=Administrator,cn=Users,dc=server,dc=domain”;
$LdapPass=“password”;
$LdapBase=“dc=server,dc=domain”;
$LdapUidAttr=“sAMAccountName”;
$LdapFilter="(objectclass=*)";
$LdapTLS = 1;
$LdapSSLVersion = 3;

I’ve also tried without TLS, no difference. Perl
modules are there.

I’m wondering if its to do with finding the user; I’m
binding as a superuser to rule that out for now (works
ok for bugzilla) but its in cn=Users, where my users
incl. myself are in staff ous eg. ou=Developers,
ou=Sales etc.
Any help appreciated, thanks or suggestions for
working on 3.4.4.
Ely

Yahoo! Messenger - NEW crystal clear PC to PC calling worldwide with voicemail http://uk.messenger.yahoo.com