Help Setting Up Fetchmail

I’m running RT on a Windows box. I downloaded the installer and followed the instructions from I am running 3.0.12.

Everything is going well, except when Fetchmail runs to get mail from the mail server I get the following error:

C:\Program Files\OurInternet\Common\fetchmail\bin>type …\rt-mailgate.conf | fetchmail.exe -N -d 300 -f -

fetchmail: removing stale lockfile

fetchmail: starting fetchmail 6.2.5 daemon

3 messages for rt at mail.server (12704 octets).

reading message rt@mydomain:1 of 3 (4232 octets) .fetchmail: SIGPIPE thrown

from an MDA or a stream socket error

fetchmail: socket error while delivering to SMTP host mail.server

fetchmail: Query status=2 (SOCKET)

fetchmail: sleeping at Tue Oct 24 17:18:12 2006

I’ve changed the name of the mail server and domain for privacy purposes. I’ve found many posts on the 'Net about this error message, but I haven’t found anything that has helped me. I did a basic install of CYGWIN, that didn’t help. I downloaded the newest CYGWIN1.dll and replaced the one in my C:\Program Files\OurInternet\Common\fetchmail\bin. That didn’t help. I’ve since restored that file to the original version.

I’ve also tried to access the mail server via POP3 and IMAP, I get the same error each time. I think it is because of a problem with the MTA that fetchmail is trying to hand the mail off too. The trouble is I don’t know what to do to fix it. Any help would be appreciated. Thanks.