Help - Rt not working anymore


#1

Could anyone explain why I am getting these errors? The web part of Rt has
been working fine until today when I was doing some upgrades to try RT-1.3 I
have checked everything I can think of and made every effort to not
overwrite anything. After I did the install of RT-1.3 my old rt was still
working properly as I used different user id’s and different file locations
as well as a rttest database instead of the standard rt… Help!?
I can execute the file /usr/local/rt/bin/cgi/webrt.cgi and it does not
return any errors and I have not changed the configuration of my httpsd as I
was working on the httpd instead…

(13)Permission denied: mod_mime_magic: can’t read
`/usr/local/rt/bin/cgi/webrt.cgi’
webrt.cgi: Failed to launch RT program.
webrt.cgi: Permission denied
[Thu May 18 14:14:12 2000] [error] [client ip.removed] Premature end of
script headers: /usr/local/rt/bin/cgi/webrt.cgi

Kent Longballa


#2

from your rt 1.0 source tree, run

make upgrade-noclobberOn Thu, May 18, 2000 at 03:18:16PM -0500, Kent Longballa wrote:

Could anyone explain why I am getting these errors? The web part of Rt has
been working fine until today when I was doing some upgrades to try RT-1.3 I
have checked everything I can think of and made every effort to not
overwrite anything. After I did the install of RT-1.3 my old rt was still
working properly as I used different user id’s and different file locations
as well as a rttest database instead of the standard rt… Help!?
I can execute the file /usr/local/rt/bin/cgi/webrt.cgi and it does not
return any errors and I have not changed the configuration of my httpsd as I
was working on the httpd instead…

(13)Permission denied: mod_mime_magic: can’t read
`/usr/local/rt/bin/cgi/webrt.cgi’
webrt.cgi: Failed to launch RT program.
webrt.cgi: Permission denied
[Thu May 18 14:14:12 2000] [error] [client ip.removed] Premature end of
script headers: /usr/local/rt/bin/cgi/webrt.cgi

Kent Longballa


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent — root@eruditorum.orgjesse@fsck.com
pgp keyprint: 50 41 9C 03 D0 BC BC C8 2C B9 77 26 6F E1 EB 91
"Bother," said Pooh, “Eeyore, ready two photon torpedoes and lock
phasers on the Heffalump, Piglet, meet me in transporter room three”


#3

Ran the make upgrade-noclobber and got no error messages but still have the
same problem…
Trying to run rt or webrt.cgi as user rt gives the following…
webrt.cgi: Failed to launch RT program.
webrt.cgi: Permission denied

Running the same program as root works fine.

JESSE
from your rt 1.0 source tree, run
make upgrade-noclobber

KENT

Could anyone explain why I am getting these errors? The web part of Rt has
been working fine until today when I was doing some upgrades to try RT-1.3
I
have checked everything I can think of and made every effort to not
overwrite anything. After I did the install of RT-1.3 my old rt was still
working properly as I used different user id’s and different file
locations
as well as a rttest database instead of the standard rt… Help!?
I can execute the file /usr/local/rt/bin/cgi/webrt.cgi and it does not
return any errors and I have not changed the configuration of my httpsd as
I
was working on the httpd instead…

(13)Permission denied: mod_mime_magic: can’t read
`/usr/local/rt/bin/cgi/webrt.cgi’
webrt.cgi: Failed to launch RT program.
webrt.cgi: Permission denied
[Thu May 18 14:14:12 2000] [error] [client ip.removed] Premature end of
script headers: /usr/local/rt/bin/cgi/webrt.cgi

Kent Longballa


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent — root@eruditorum.orgjesse@fsck.com
pgp keyprint: 50 41 9C 03 D0 BC BC C8 2C B9 77 26 6F E1 EB 91
"Bother," said Pooh, “Eeyore, ready two photon torpedoes and lock
phasers on the Heffalump, Piglet, meet me in transporter room three”

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users