GMail not sending out from RT

We are receiving emails from Gmail but the auto message does not get sent or or even the reply to the ticket does not get sent out All other emails work but Gmail any clues on why this is happening It just started about a week ago


As in Gmail is blocking the incoming email? Did you check spam folder? How are you sending email?

  1. Check RT.log if the message has been sent
  2. Check mail.log if the message has been delivered to GMail

If both are ‘yes’ the problem is at GMail. Check spam and other configuration there or raise a ticket.
If one is ‘no’ read error message.

In case you have no access to mail.log take care to receive the non delivery reports for emails. In many configurations they are dismissed by RT.

Also look at the ticket history itself. It will usually show a copy of the email if RT thinks it has sent one. If there’s no outgoing email in the history, either the scrip that generates it has an error or it didn’t meet its conditions to run, or there were no potential recipients. That last one sometimes catches people out during testing if they’ve configured RT not to send emails to themselves ( $NotifyActor setting in your local

Note that if your has $RecordOutgoingEmail set to 0 you won’t see any of the outgoing emails in the ticket history - you probably want to set this to 1 (the default if it isn’t mentioned in the config) at least temporarily whilst you debug this issue.

Hi GreenJimII
It looks like gmail thinks our return emails are spam and are blocking them Any ideas on how we can fix this problem
Our system has detected that this message
<<< 550-5.7.1 likely unsolicited mail. To reduce the amount of spam sent to Gmail,
<<< 550-5.7.1 this message has been blocked


I don’t know I’m afraid - that’s an issue outside of RT at the Gmail end. You’ll probably need to see if Google offer any options for white listing the email from you.

Are you sending email from the RT machine or your own email server or routing through a service?

Hi GreenJimII
Thanks for your help One question we have noticed that is our respose email Can we change this in RT www-data@itsupport


Do you mean you want to change the reply-to email address? That can be done globally and on a per queue basis. The global setting is in your local in the $CorrespondAddress (for Requestors replying to tickets) and $CommentAddress (for staff emailing in tickets). Those will be the defaults for any queues that don’t have their own per queue override values.

The per queue config can be adjusted using the Admin web user interface. Got to Admin->Queues->Select, pick the queue you want and then in the Basics tab you should see Reply Address (and Comment Address if you want to change where comments are sent to).

Bare in mind though that you may also need to tweak the aliases that you’re using to feed incoming emails to rt-mailgate and may also need to update your local if you have an $RTAddressRegexp set in there, otherwise RT will complain that the addresses you’re trying to set don’t match what it is expecting.