Global symbol "$m" requires explicit package name at

Hello, on tue 23 apr 2002 Frederic Gobin
asked about this same issue. His letter had a subject of
"[rt-devel] Can’t start Apache after installing RT 2.0.13"

in any event when I start apache I see out put simular to:

Variable "$m" is not imported at /usr/local/rt2/bin/webmux.pl line 94.
[Mon Apr 22 15:37:27 2002] [error] Global symbol "$m" requires 

explicit package name at /usr/local/rt2/bin/webmux.pl line 94.
Compilation failed in require at (eval 1) line 1.

Syntax error on line 587 of /usr/local/apache/conf/httpd.conf:
Global symbol "$m" requires explicit package name at 

/usr/local/rt2/bin/webmux.pl line 94.
Compilation failed in require at (eval 1) line 1.

/usr/local/apache/bin/apachectl start : httpd could not be started

what have I not done? All checks / modules seemed to have installed correctly,
I’ve recompiled apache with mod_perl, installed all the mods required…

thnaks for any advice,
greg

Hi,

I can report exactly, 100% the same on FreeBSD 4.6-STABLE, Apache 1.3.26.

testdeps -warn mysql reports all the required modules are installed. However,
apache initially for some reason still missed Apache::DBI. This, I installed
manually via CPAN, and after that that error was gone.

However, the moment I enable mod_perl to load RT’s perl thingies, apache bails
out with the below error message.

Apache config:

PerlModule Apache::DBI

PerlFreshRestart On

PerlRequire /usr/local/rt/bin/webmux.pl

<Location /tickets>

SetHandler perl-script

PerlHandler RT::Mason

meOn Thu, Jul 11, 2002 at 06:13:33PM +0000, greg@fqdn.com wrote:

Hello, on tue 23 apr 2002 Frederic Gobin
asked about this same issue. His letter had a subject of
"[rt-devel] Can’t start Apache after installing RT 2.0.13"

in any event when I start apache I see out put simular to:

Variable "$m" is not imported at /usr/local/rt2/bin/webmux.pl line 94.
[Mon Apr 22 15:37:27 2002] [error] Global symbol "$m" requires 

explicit package name at /usr/local/rt2/bin/webmux.pl line 94.
Compilation failed in require at (eval 1) line 1.

Syntax error on line 587 of /usr/local/apache/conf/httpd.conf:
Global symbol "$m" requires explicit package name at 

/usr/local/rt2/bin/webmux.pl line 94.
Compilation failed in require at (eval 1) line 1.

/usr/local/apache/bin/apachectl start : httpd could not be started

what have I not done? All checks / modules seemed to have installed correctly,
I’ve recompiled apache with mod_perl, installed all the mods required…

thnaks for any advice,
greg


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Lo again,

I’m still on this whole error thing. I’m upgrading my RT to the latest ver
now, RT-2.0.13…

Can anyone perhaps tell me if the below warning is crucial, and what may be
causing it, or how I can fix it?

<SNIPED testdeps -warn mysql>
Checking for Net::SMTP…found
Checking for Params::Validate 0.02 …found
Scalar::Util not detected - container() method not available
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Checking for HTML::Mason 1.02 …found
Checking for CGI::Cookie 1.20 …found

Thanks!

meOn Thu, Jul 11, 2002 at 08:45:23PM +0200, Chris Knipe wrote:

Hi,

I can report exactly, 100% the same on FreeBSD 4.6-STABLE, Apache 1.3.26.

testdeps -warn mysql reports all the required modules are installed. However,
apache initially for some reason still missed Apache::DBI. This, I installed
manually via CPAN, and after that that error was gone.

However, the moment I enable mod_perl to load RT’s perl thingies, apache bails
out with the below error message.

Apache config:

PerlModule Apache::DBI

PerlFreshRestart On

PerlRequire /usr/local/rt/bin/webmux.pl

<Location /tickets>

SetHandler perl-script

PerlHandler RT::Mason


me

On Thu, Jul 11, 2002 at 06:13:33PM +0000, greg@fqdn.com wrote:

Hello, on tue 23 apr 2002 Frederic Gobin
asked about this same issue. His letter had a subject of
"[rt-devel] Can’t start Apache after installing RT 2.0.13"

in any event when I start apache I see out put simular to:

Variable "$m" is not imported at /usr/local/rt2/bin/webmux.pl line 94.
[Mon Apr 22 15:37:27 2002] [error] Global symbol "$m" requires 

explicit package name at /usr/local/rt2/bin/webmux.pl line 94.
Compilation failed in require at (eval 1) line 1.

Syntax error on line 587 of /usr/local/apache/conf/httpd.conf:
Global symbol "$m" requires explicit package name at 

/usr/local/rt2/bin/webmux.pl line 94.
Compilation failed in require at (eval 1) line 1.

/usr/local/apache/bin/apachectl start : httpd could not be started

what have I not done? All checks / modules seemed to have installed correctly,
I’ve recompiled apache with mod_perl, installed all the mods required…

thnaks for any advice,
greg


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

—end quoted text—

Chris Knipe wrote:

I can report exactly, 100% the same on FreeBSD 4.6-STABLE, Apache 1.3.26.

Variable "$m" is not imported at /usr/local/rt2/bin/webmux.pl line 94.
[Mon Apr 22 15:37:27 2002] [error] Global symbol "$m" requires 

explicit package name at /usr/local/rt2/bin/webmux.pl line 94.

The helpful mailing list appends this:

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

And indeed, if you go there, you’ll see:

http://fsck.com/rtfm/article.html?id=5#184

I’ve fixed the problem by downgrading

HTML-Mason-1.11 -> HTML-Mason-1.05

</canauOn Thu, Jul 11, 2002 at 08:45:23PM +0200, Chris Knipe wrote:

Hi,

I can report exactly, 100% the same on FreeBSD 4.6-STABLE, Apache 1.3.26.

testdeps -warn mysql reports all the required modules are installed. However,
apache initially for some reason still missed Apache::DBI. This, I installed
manually via CPAN, and after that that error was gone.

However, the moment I enable mod_perl to load RT’s perl thingies, apache bails
out with the below error message.

Apache config:

PerlModule Apache::DBI

PerlFreshRestart On

PerlRequire /usr/local/rt/bin/webmux.pl

<Location /tickets>

SetHandler perl-script

PerlHandler RT::Mason


me

On Thu, Jul 11, 2002 at 06:13:33PM +0000, greg@fqdn.com wrote:

Hello, on tue 23 apr 2002 Frederic Gobin
asked about this same issue. His letter had a subject of
"[rt-devel] Can’t start Apache after installing RT 2.0.13"

in any event when I start apache I see out put simular to:

Variable "$m" is not imported at /usr/local/rt2/bin/webmux.pl line 94.
[Mon Apr 22 15:37:27 2002] [error] Global symbol "$m" requires 

explicit package name at /usr/local/rt2/bin/webmux.pl line 94.
Compilation failed in require at (eval 1) line 1.

Syntax error on line 587 of /usr/local/apache/conf/httpd.conf:
Global symbol "$m" requires explicit package name at 

/usr/local/rt2/bin/webmux.pl line 94.
Compilation failed in require at (eval 1) line 1.

/usr/local/apache/bin/apachectl start : httpd could not be started

what have I not done? All checks / modules seemed to have installed correctly,
I’ve recompiled apache with mod_perl, installed all the mods required…

thnaks for any advice,
greg


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

It was 1.11, I rolled it back now I get a slightly different error.
I’ll continue to adjust versions and we’ll see what happens.

Today is my ‘computer time’ day. 8)

take care and thanks,
greg

fyi the error now is simular to:

[root@vortex root]# /usr/local/apache/bin/apachectl start
Variable “$m” is not imported at /usr/local/rt/bin/webmux.pl line 94.
[Sat Jul 13 10:56:43 2002] [error] Global symbol “$m” requires explicit package name at /usr/local/rt
/bin/webmux.pl line 94.
Compilation failed in require at (eval 6) line 1.

Syntax error on line 344 of /usr/local/apache/conf/httpd.conf:
Global symbol “$m” requires explicit package name at /usr/local/rt/bin/webmux.pl line 94.
Compilation failed in require at (eval 6) line 1.

/usr/local/apache/bin/apachectl start: httpd could not be started
[root@vortex root]#

thanks again, have a great BBQn’ weekend!

greg