Global RT at a Glance not taking effect

Hi all,

I’ve got an issue with RT at a glance global configuration not working. I
want only “Dashboards” to be visible on the homepage after a user logs in.

I’ve set the following in tools > configuration > Global > RT at a Glance
RT at a glance body: Dasboards
RT at a glance: Summary: blank

When logging in as root this applies fine.
When logging in as any other users ( we use RT External Auth) it does not
apply.

I also tried setting:

Set ( $HomepageComponents, [qw(Dashboards)]); in RT_SiteConfig.pm
But that didn’t work either.

Users can access Dashboards fine, so it doesn’t appear to be a permissions
issue, i just want them only to be able to see their dashboards rather than
have to navigate to them.

Could anyone assist please? RT Version is 4.0.1, External Auth is version
0.12

Many thanks.

Hi all,
I’ve got an issue with RT at a glance global configuration not working. I want only
"Dashboards" to be visible on the homepage after a user logs in.
I’ve set the following in tools > configuration > Global > RT at a Glance
RT at a glance body: Dasboards
RT at a glance: Summary: blank
When logging in as root this applies fine.
When logging in as any other users ( we use RT External Auth) it does not apply.

Do these users have their own homepage settings from previous
use/customization? You will need to reset that, or just clear their
homepage preferences in the Attributes table in the database.

I also tried setting:
Set ( $HomepageComponents, [qw(Dashboards)]); in RT_SiteConfig.pm
But that didn’t work either.

HomepageComponents doesn’t forcibly turn off components in 4.0.
It will in 4.2

Users can access Dashboards fine, so it doesn’t appear to be a permissions issue, i just want
them only to be able to see their dashboards rather than have to navigate to them.
Could anyone assist please? RT Version is 4.0.1, External Auth is version 0.12

With 4.0.1, you could be running into some bug (4.0.17 is current) but
start by resetting homepage settings for one of your external auth
users and seeing if that fixes it.

Homepages are also cached in the session, so you need to log in and
out.

-kevin

Hi all,
I’ve got an issue with RT at a glance global configuration not
working. I want only
"Dashboards" to be visible on the homepage after a user logs in.
I’ve set the following in tools > configuration > Global > RT at a
Glance
RT at a glance body: Dasboards
RT at a glance: Summary: blank
When logging in as root this applies fine.
When logging in as any other users ( we use RT External Auth) it does
not apply.

Do these users have their own homepage settings from previous
use/customization? You will need to reset that, or just clear their
homepage preferences in the Attributes table in the database.

No, they’ve never been able to set them "no permissions to set preferences"
was the error they got. How would I go about clearing the homepage
preferences anyway?

I also tried setting:
Set ( $HomepageComponents, [qw(Dashboards)]); in RT_SiteConfig.pm
But that didn’t work either.

HomepageComponents doesn’t forcibly turn off components in 4.0.
It will in 4.2

Users can access Dashboards fine, so it doesn’t appear to be a
permissions issue, i just want
them only to be able to see their dashboards rather than have to
navigate to them.
Could anyone assist please? RT Version is 4.0.1, External Auth is
version 0.12

With 4.0.1, you could be running into some bug (4.0.17 is current) but
start by resetting homepage settings for one of your external auth
users and seeing if that fixes it.

Homepages are also cached in the session, so you need to log in and
out.

I’ve tried that, but will clear the mason cache/ reboot the server to see
if it has any effect.

-kevin

Will report back tomorrow morning. Thanks so far.

 > Hi all,
 > I've got an issue with RT at a glance global configuration not working. I want only
 > "Dashboards" to be visible on the homepage after a user logs in.
 > I've set the following in tools > configuration > Global > RT at a Glance
 > RT at a glance body: Dasboards
 > RT at a glance: Summary: blank
 > When logging in as root this applies fine.
 > When logging in as any other users ( we use RT External Auth) it does not apply.

 Do these users have their own homepage settings from previous
 use/customization? You will need to reset that, or just clear their
 homepage preferences in the Attributes table in the database.

No, they’ve never been able to set them “no permissions to set preferences” was the error they
got. How would I go about clearing the homepage preferences anyway?

As the relevant user - Settings -> RT at a Glance, although if they
don’t have ModifySelf they may not be able to get there and you may
need to go look in the Attributes table for rows with a name of
Pref-HomepageSettings and then use /opt/rt4/sbin/rt-attributes-viewer
with the id of the row to see what user has an override.

-kevin