Getting nowhere with User_Local.pm and with no logs to go on

Running the unstable debian RT package on apache 1.3.34 modperl 1.29. Only
changes I have made are to RT_SiteConfig.pm , and installing User_Local.pm
as I aspire to having active directory ldap derived user creation.

The problems:

  1. Getting absolutely nothing logged in /var/log/request-tracker3.4

Dropping @LogToSyslogConf = ( socket => ‘inet’ ) unless (@LogToSyslogConf);
into RT_SiteConfig.pm did not make any difference

  1. LDAP auth does not appear to be attempted -

[Wed Feb 22 16:16:35 2006] [error]: FAILED LOGIN for eeee from
192.168.234.123 (/usr/share/request-tracker3.4/html/autohandler:191)

Which appears to be a failed local logon attempt, not an ldap attempt.
I am not seeing anything on my AD server that would indicate any requests
hitting it.

Any ideas? Do I need to include the User_Local.pm somehow? I have it
installed in both

/usr/local/share/request-tracker3.4/lib/RT
/usr/share/request-tracker3.4/lib/RT

Toggling the debug flag in it did not increase any logging output anywhere
in /var/log

RT_SiteConfig.pm

These are the bits you absolutely must edit.

To find out how, please read

/usr/share/doc/request-tracker3.4/INSTALL.Debian

THE BASICS:

Set($rtname, ‘rt.f.q.d.n’);
Set($Organization, ’ domain.com’);
Set($CorrespondAddress , ‘rt@domain.com’);
Set($CommentAddress , ‘rt-comment@domain.com’);
Set($Timezone , ‘America/New_York’); # obviously choose what suits you

THE DATABASE:

Set($DatabaseType, ‘mysql’); # e.g. Pg or mysql

These are the settings we used above when creating the RT database,

you MUST set these to what you chose in the section above.

Set($DatabaseUser , ‘rt’);
Set($DatabasePassword , ‘rtpassword’);
Set($DatabaseName , ‘rtdbname’);

try to get logging working

@LogToSyslogConf = ( socket => ‘inet’ ) unless (@LogToSyslogConf);

THE WEBSERVER:

Set($WebPath , “/rt”);
Set($WebBaseURL , “http://rt.domain.com”);

Ldap Attempts

Set($LDAPExternalAuth, 1);
Set($LdapServer, “ad.dc.goes.here”);
Set($LdapUser, “rt”);
Set($LdapPass, “password”);
Set($LdapBase, “dc=domain,dc=com”);
Set($LdapUidAttr, “uid”);
Set($LdapFilter, “(objectclass=*)”);
Set($LDapTLS, 0);
1;

You stopped and started the web server right? Did you try stopping,
emptying the mason cache, then starting apache again?

Matt Ostiguy wrote:

Running the unstable debian RT package on apache 1.3.34 modperl 1.29.
Only changes I have made are to RT_SiteConfig.pm , and installing
User_Local.pm as I aspire to having active directory ldap derived user
creation.

The problems:

  1. Getting absolutely nothing logged in /var/log/request-tracker3.4

Dropping @LogToSyslogConf = ( socket => ‘inet’ ) unless
(@LogToSyslogConf); into RT_SiteConfig.pm did not make any difference

  1. LDAP auth does not appear to be attempted -

[Wed Feb 22 16:16:35 2006] [error]: FAILED LOGIN for eeee from
192.168.234.123 http://192.168.234.123/
(/usr/share/request-tracker3.4/html/autohandler:191)

Which appears to be a failed local logon attempt, not an ldap attempt.
I am not seeing anything on my AD server that would indicate any
requests hitting it.

Any ideas? Do I need to include the User_Local.pm somehow? I have it
installed in both

/usr/local/share/request-tracker3.4/lib/RT
/usr/share/request-tracker3.4/lib/RT

Toggling the debug flag in it did not increase any logging output
anywhere in /var/log

RT_SiteConfig.pm

These are the bits you absolutely must edit.

To find out how, please read

/usr/share/doc/request-tracker3.4/INSTALL.Debian

THE BASICS:

Set($rtname, ‘rt.f.q.d.n’);
Set($Organization, ’ domain.com http://domain.com/’);
Set($CorrespondAddress , ‘rt@domain.com mailto:rt@domain.com’);
Set($CommentAddress , ’ rt-comment@domain.com
mailto:rt-comment@domain.com’);
Set($Timezone , ‘America/New_York’); # obviously choose what suits you

THE DATABASE:

Set($DatabaseType, ‘mysql’); # e.g. Pg or mysql

These are the settings we used above when creating the RT database,

you MUST set these to what you chose in the section above.

Set($DatabaseUser , ‘rt’);
Set($DatabasePassword , ‘rtpassword’);
Set($DatabaseName , ‘rtdbname’);

try to get logging working

@LogToSyslogConf = ( socket => ‘inet’ ) unless (@LogToSyslogConf);

THE WEBSERVER:

Set($WebPath , “/rt”);
Set($WebBaseURL , “http://rt.domain.com http://rt.domain.com/”);

Ldap Attempts

Set($LDAPExternalAuth, 1);
Set($LdapServer, “ad.dc.goes.here”);
Set($LdapUser, “rt”);
Set($LdapPass, “password”);
Set($LdapBase, “dc=domain,dc=com”);
Set($LdapUidAttr, “uid”);
Set($LdapFilter, “(objectclass=*)”);
Set($LDapTLS, 0);
1;


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Download a free sample chapter of RT Essentials from O’Reilly Media at http://rtbook.bestpractical.com

WE’RE COMING TO YOUR TOWN SOON - RT Training in Amsterdam, Boston and
San Francisco - Find out more at http://bestpractical.com/services/training.html

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati

Matt Ostiguy wrote:

Running the unstable debian RT package on apache 1.3.34 modperl 1.29.
Only changes I have made are to RT_SiteConfig.pm , and installing
User_Local.pm as I aspire to having active directory ldap derived user
creation.

The problems:

  1. Getting absolutely nothing logged in /var/log/request-tracker3.4

Dropping @LogToSyslogConf = ( socket => ‘inet’ ) unless
(@LogToSyslogConf); into RT_SiteConfig.pm did not make any difference

  1. LDAP auth does not appear to be attempted -

[Wed Feb 22 16:16:35 2006] [error]: FAILED LOGIN for eeee from
192.168.234.123 http://192.168.234.123/
(/usr/share/request-tracker3.4/html/autohandler:191)

Which appears to be a failed local logon attempt, not an ldap attempt.
I am not seeing anything on my AD server that would indicate any
requests hitting it.

Any ideas? Do I need to include the User_Local.pm somehow? I have it
installed in both

/usr/local/share/request-tracker3.4/lib/RT
/usr/share/request-tracker3.4/lib/RT

Toggling the debug flag in it did not increase any logging output
anywhere in /var/log

RT_SiteConfig.pm

These are the bits you absolutely must edit.

To find out how, please read

/usr/share/doc/request-tracker3.4/INSTALL.Debian

THE BASICS:

Set($rtname, ‘rt.f.q.d.n’);
Set($Organization, ’ domain.com http://domain.com/’);
Set($CorrespondAddress , ‘rt@domain.com mailto:rt@domain.com’);
Set($CommentAddress , ’ rt-comment@domain.com
mailto:rt-comment@domain.com’);
Set($Timezone , ‘America/New_York’); # obviously choose what suits you

THE DATABASE:

Set($DatabaseType, ‘mysql’); # e.g. Pg or mysql

These are the settings we used above when creating the RT database,

you MUST set these to what you chose in the section above.

Set($DatabaseUser , ‘rt’);
Set($DatabasePassword , ‘rtpassword’);
Set($DatabaseName , ‘rtdbname’);

try to get logging working

@LogToSyslogConf = ( socket => ‘inet’ ) unless (@LogToSyslogConf);

THE WEBSERVER:

Set($WebPath , “/rt”);
Set($WebBaseURL , “http://rt.domain.com http://rt.domain.com/”);

Ldap Attempts

Set($LDAPExternalAuth, 1);
Set($LdapServer, “ad.dc.goes.here”);
Set($LdapUser, “rt”);
Set($LdapPass, “password”);
Set($LdapBase, “dc=domain,dc=com”);
Set($LdapUidAttr, “uid”);
Set($LdapFilter, “(objectclass=*)”);
Set($LDapTLS, 0);
1;

check /usr/local/request-tracker3/var/log/rt.log

You stopped and started the web server right? Did you try stopping,
emptying the mason cache, then starting apache again?

I have restarted apache numerous times - does that take care of the mason
cache?

/var/cache/mason/obj
/var/cache/mason/cache

are empty - would that be the place for a debian rt install?

Thanks

Matt

Matt Ostiguy wrote:

You stopped and started the web server right?  Did you try stopping,
emptying the mason cache, then starting apache again?

I have restarted apache numerous times - does that take care of the
mason cache?

/var/cache/mason/obj
/var/cache/mason/cache

are empty - would that be the place for a debian rt install?

I don’t know about debian. I’m a CentOS guy myself. For me, the mason
cache is at /usr/local/rt3/var/mason_data/
Hopefully one of the other debian guys can point you in the right
direction here, but it sounds like your changes are cached.

Thanks

Matt



http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Download a free sample chapter of RT Essentials from O’Reilly Media at http://rtbook.bestpractical.com

WE’RE COMING TO YOUR TOWN SOON - RT Training in Amsterdam, Boston and
San Francisco - Find out more at http://bestpractical.com/services/training.html

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati