Garbled text in history field in ticket

Frequently, when I copy/paste text into the message field when creating a ticket or adding to an existing ticket, the text appears ok when I paste it, but is garbled when I view the ticket after saving the updates. It also adds line breaks, extra spaces, and cuts off part of the message. There does not appear to be consistency in terms of when this happens (it’s not specific to a particular browser or OS). It seems that it may be adding html code to the text? I’m not sure what’s happening. I’ve also tried pasting the text into notepad to remove all formatting before pasting it into the ticket but that doesn’t always help.

One thing I can say is that this only occurs if using the “reply” or “comment” option. It is always ok when adding text via “resolve”.

I have a screen shot at http://people.haverford.edu/jscales/rtexample.jpg that exemplifies some of what I’m experiencing. In this example, the first two attempts to copy and paste the email from a user resulted in cut off text. The third time it displays fine and that was when I pasted it into the ticket via “resolve”. The final comment in the ticket was typed in directly as a comment. I typed only “Sarah and Vasantha are working on this” and RT added the extra text (which is displayed partly as boxes on my browser but shows as RT text in this screenshot.)

This is happening a lot (about 25% of tickets have at least something wrong with the text) and it is not something that we can work around because it often results in lost comments/text. We just launched RT for our help desk and this is very problematic. I’m desperate to fix this before the school year starts again at the end of this month. Can anyone help? Any ideas? Has this been seen before?

I’m using RT 3.8.2

Jennifer Scales
Help Desk/Public Lab Coordinator
College Information Resources
Haverford College
jscales@haverford.edu
(610) 896-1373

Haverford College Computing staff will never ask for your password in an email message. Please keep your passwords private to protect yourself and the security of our network. See https://www.haverford.edu/acc/protect/ for more information.

Frequently, when I copy/paste text into the message field when creating a ticket or adding to
an existing ticket, the text appears ok when I paste it, but is garbled when I view the ticket
after saving the updates. It also adds line breaks, extra spaces, and cuts off part of the
message. There does not appear to be consistency in terms of when this happens (it’s not
specific to a particular browser or OS). It seems that it may be adding html code to the
text? I’m not sure what’s happening. I’ve also tried pasting the text into notepad to remove
all formatting before pasting it into the ticket but that doesn’t always help.

One thing I can say is that this only occurs if using the “reply” or “comment” option. It is
always ok when adding text via “resolve”.

There is no difference between the text boxes on Reply, Comment or Resolve.

There were a number of IE bugs fixed between 3.8.2 and the current
3.8.4 release and your bug sounds like something that was fixed for IE
in that timeframe

If you’re able to replicate it in 3.8.4 you should file a bug with
reproduction steps.

-kevin

Could this be the bug that presents when you use both the wysiwyg
editor and a signature?

-mikeOn 2009-08-05, at 11:28 AM, Jennifer Scales jscales@haverford.edu wrote:

Frequently, when I copy/paste text into the message field when
creating a ticket or adding to an existing ticket, the text appears
ok when I paste it, but is garbled when I view the ticket after
saving the updates. It also adds line breaks, extra spaces, and
cuts off part of the message. There does not appear to be
consistency in terms of when this happens (it’s not specific to a pa
rticular browser or OS). It seems that it may be adding html code t
o the text? I’m not sure what’s happening. I’ve also tried
pasting the text into notepad to remove all formatting before pastin
g it into the ticket but that doesn’t always help.

One thing I can say is that this only occurs if using the “reply”
or “comment” option. It is always ok when adding text via
“resolve”.

I have a screen shot at http://people.haverford.edu/jscales/rtexample.jpg
that exemplifies some of what I’m experiencing. In this example,
the first two attempts to copy and paste the email from a user resul
ted in cut off text. The third time it displays fine and that was w
hen I pasted it into the ticket via “resolve”. The final comment
in the ticket was typed in directly as a comment. I typed only “Sar
ah and Vasantha are working on this” and RT added the extra text (wh
ich is displayed partly as boxes on my browser but shows as RT text
in this screenshot.)

This is happening a lot (about 25% of tickets have at least
something wrong with the text) and it is not something that we can
work around because it often results in lost comments/text. We just
launched RT for our help desk and this is very problematic. I’m des
perate to fix this before the school year starts again at the end of
this month. Can anyone help? Any ideas? Has this been seen before?

I’m using RT 3.8.2

Jennifer Scales

Help Desk/Public Lab Coordinator

College Information Resources

Haverford College

jscales@haverford.edu

(610) 896-1373

Haverford College Computing staff will never ask for your password
in an email message. Please keep your passwords private to protect
yourself and the security of our network. See https://www.haverford.edu/acc/protect/
for more information.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

That appears to have done the trick. I updated to 3.8.4 and the problem appears to be resolved. Thanks!

Jennifer Scales
Help Desk/Public Lab Coordinator
College Information Resources
Haverford College
jscales@haverford.edu
(610) 896-1373

Haverford College Computing staff will never ask for your password in an email message. Please keep your passwords private to protect yourself and the security of our network. See https://www.haverford.edu/acc/protect/ for more information.From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Kevin Falcone
Sent: Wednesday, August 05, 2009 12:40 PM
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Garbled text in history field in ticket

Frequently, when I copy/paste text into the message field when creating a ticket or adding to
an existing ticket, the text appears ok when I paste it, but is garbled when I view the ticket
after saving the updates. It also adds line breaks, extra spaces, and cuts off part of the
message. There does not appear to be consistency in terms of when this happens (it’s not
specific to a particular browser or OS). It seems that it may be adding html code to the
text? I’m not sure what’s happening. I’ve also tried pasting the text into notepad to remove
all formatting before pasting it into the ticket but that doesn’t always help.

One thing I can say is that this only occurs if using the “reply” or “comment” option. It is
always ok when adding text via “resolve”.

There is no difference between the text boxes on Reply, Comment or Resolve.

There were a number of IE bugs fixed between 3.8.2 and the current
3.8.4 release and your bug sounds like something that was fixed for IE
in that timeframe

If you’re able to replicate it in 3.8.4 you should file a bug with
reproduction steps.

-kevin

I have a screen shot at [1]http://people.haverford.edu/jscales/rtexample.jpg that exemplifies
some of what I’m experiencing. In this example, the first two attempts to copy and paste the
email from a user resulted in cut off text. The third time it displays fine and that was when
I pasted it into the ticket via “resolve”. The final comment in the ticket was typed in
directly as a comment. I typed only “Sarah and Vasantha are working on this” and RT added the
extra text (which is displayed partly as boxes on my browser but shows as RT text in this
screenshot.)

This is happening a lot (about 25% of tickets have at least something wrong with the text) and
it is not something that we can work around because it often results in lost comments/text.
We just launched RT for our help desk and this is very problematic. I’m desperate to fix this
before the school year starts again at the end of this month. Can anyone help? Any ideas?
Has this been seen before?
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com