FW: Tracking a bug with WYSIWYG editor and IE7

I am forwarding this to the dev list, hoping that it may receive a bit more attention there.

Any pointers as to what this could be?

Michael has this bug with his vanila 3.8.2 install when he has disabled his only extension, RTFM to see if it makes any difference. It looks like it might be login specific, because hes not experiencing the problem with every user on his system.

I get it only when RTx-EmailCompletion is enabled, but I am experiencing the problem with every user.

Another user received it and doesn’t have RTx-EmailCompletion installed.From: Michael Finn [mailto:mfinn@nbutexas.com]
Sent: 27 February 2009 19:44
To: Alex Young; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Tracking a bug with WYSIWYG editor and IE7

Further testing:
Logged into a different PC (Remote Desktop); logged into RT w/ IE7 --> same problem (55 chars, extra garbage).
Logged into RT as root w/ IE7 --> did NOT have the problem.
Fellow IT user (with same permissions as mine) is also not having this problem.
It looks like I’m the lucky one. :frowning:

What could it be about my login in RT that’s causing this issue???

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-
bounces@lists.bestpractical.com] On Behalf Of Michael Finn
Sent: Friday, February 27, 2009 9:28 AM
To: Alex Young; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Tracking a bug with WYSIWYG editor and IE7

I just tried it with RTFM disabled, and got the same results:

Subject: 3rd test of RT in IE7
MIME-Version: 1.0
Content-Type: text/html; charset="UTF-8"
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Disposition: inline
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 55

I
’ve disabled
RTFM to test the IE7 pr
oblem

-----Original Message-----
From: Alex Young [mailto:alexyoung@scoutsolutions.co.uk]
Sent: Friday, February 27, 2009 5:04 AM
To: Michael Finn; rt-users@lists.bestpractical.com
Subject: RE: Tracking a bug with WYSIWYG editor and IE7

I am using pretty much the same as you, except I’m running IE7 on
Vista.

Michael, do oyu still have this bug if you disable RTFM?

I can reproduce the error consistantly whenever I hit reply/comment
to
a specific transaction. Depending on which transaction I
reply/comment
on changes the site that the data is truncated. Doesnt matter how
much
more I type into the reply/comment, each transaction also truncated
at
the same bytes regardless.

The Javascript errors I had in IE had nothing to do with this bug. I
fixed it my removing the references to scriptalicous.js and
prototype.js in the modified header from the RTx-EmailCompletion
header.

-----Original Message-----
From: Michael Finn [mailto:mfinn@nbutexas.com]
Sent: 25 February 2009 20:59
To: Alex Young; rt-users@lists.bestpractical.com
Subject: Tracking a bug with WYSIWYG editor and IE7

The only extension I have is RTFM. More specs:
RT-3.8.2
RTFM-2.4.1
MySQL 5.0.67 (external server)
IE 7.0.5730.11 on WinXP SP3
IE7 Add-ons don’t apply, because I experienced the same issue in IE7
"safe mode" (‘iexplore -extoff’).

I’m baffled.

-----Original Message-----
From: Alex Young [mailto:alexyoung@scoutsolutions.co.uk]
Sent: Wednesday, February 25, 2009 12:38 PM
To: Michael Finn; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Trying to track a bug with WYSIWYG
editor,IE7

and RTx-EmailCompletion

Hmmm… odd that I dont get the error when I remove RTx-
EmailCompletion, but you’re not using it. What other extensions are
you
using? Do you still get this problem if they are disabled?

Mine is getting truncated at 319 characters on every one. I never
noticed it before.

Looks like my JavaScript error is unrelated. Its a RTx-
EmailCompletion
specific error that, so nothing to do with the truncation.

================================================
MIME-Version: 1.0
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Disposition: inline
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
RT-Send-CC:
Content-Length: 319

Does it do it when inserting content fro m the previous page?

On Wed Feb 25 14:58:45 2009, ayoung wrote:
> T his is a lon g winded reply to see if IE will br eak with the WYSIWYG
& gt; editor yet
> again.
>
> I cant understand why it breaks.
&g t ; ================================================

-----Original Message-----
From: Michael Finn [mailto:mfinn@nbutexas.com]
Sent: 25 February 2009 18:26
To: Alex Young; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] Trying to track a bug with WYSIWYG
editor,IE7

and RTx-EmailCompletion

Alex,

I’ve observed the same kind of behavior when I use the "New ticket
in"
button at the top, but not when I enter a comment or reply.
Additionally, my text is truncated at 55 characters. I’m having
this

issue in IE7, but not Firefox 3. I don’t get JavaScript errors in
either browser.

I do not use RTx-EmailCompletion, however. Here’s an example of
what

I’m seeing (with headers):

MIME-Version: 1.0
Content-Type: text/html; charset="UTF-8"
X-Mailer: MIME-tools 5.427 (Entity 5.427)
Content-Disposition: inline
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: utf-8
Content-Length: 55

K
. Tibbels PC&
nbsp;won’t boot.  &quot
;Strik

Mike

From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-
bounces@lists.bestpractical.com] On Behalf Of Alex Young
Sent: Wednesday, February 25, 2009 10:45 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Trying to track a bug with WYSIWYG editor,IE7
and

RTx-EmailCompletion

Hi,
I’m trying to track down a bug I am experiencing with RT,
its
WYSIWYG editor, IE7 and RTx-EmailCompletion.

On my install when RT inserts content automatically into the body
of

the WYSIWYG editor.

I only get this error when using Internet Explorer 7 (Haven’t tried
other IE versions). Firefox doesn’t suffer.

If I insert and RTFM article, my user signature (set under users
preferences), or hit reply/comment on a ticket transaction it posts
the
info correct into the WYSIWYG editor window. When submitting that
page
the transaction content randomly inserts spaces, line breaks, and
chops
off the end of the content.

If I disable RTx-EmailCompletion it works fine.

I also have a JavaScript error in IE7 when RTx-EmailCompletion is
enabled;
Line: 2
Char: 1
Error: Syntax error
Code: 0

This error shows on every page. Looks like it’s a problem with RTx-
EmailCompletion. It doesn’t give a JS error in Firefox.

Has anyone else had this problem or been able to fix it?


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com