FW: mod_fastcgi problems

Hi,

Regarding the below email does anyone know why I am unable to start apache?
It seems like the fastcgi module is not installed but RT seems to report
that it is. Does anyone know how I can check this on Gentoo?

For your information please see my Apache options below:

APACHE2_OPTS="-D FASTCGI -D DEFAULT_VHOST -D INFO -D LANGUAGE -D SSL -D
SSL_DEFAULT_VHOST -D SUEXEC"

===== /etc/apache2/vhosts.d/rt_apache2_fcgi.conf =====

Tell FastCGI to put its temporary files somewhere sane.

FastCgiIpcDir /tmp

Tell FastCGI that it should use apache’s “suexec” binary to call any

FastCGI script.

This is a GLOBAL setting

FastCgiWrapper /usr/sbin/suexec2

Apache 1.3 discards the user and group parameters on the FastCgiServer

line.

Apache 2.0 requires them.

FastCgiServer RT_DIR/bin/mason_handler.fcgi -idle-timeout 120 -user rt
-group rt -processes 4

    ServerName helpdesk.pikedom.com

    DocumentRoot HTDOCS

    ServerAdmin administrator@pikedom.com



    AddDefaultCharset UTF-8



    <IfDefine USERDIR>

            UserDir disabled

    </IfDefine>



    # Set the rt user and group as the executing user for this virtual

host

    SuexecUserGroup rt rt

    AddHandler fastcgi-script fcgi

    ScriptAlias / RT_DIR/bin/mason_handler.fcgi/



    <Directory "HTDOCS">

            Options Indexes FollowSymLinks

            AllowOverride None

            Order allow,deny

            Allow from all

    </Directory>

vim: ts=4 filetype=apache

Can anyone see what I am doing wrong? Sorry if it’s obvious, I’m a bit of a
newbie so please try and be patient with me.

Many thanks,

AndyFrom: Andrew Pike [mailto:andy_pikey@hotmail.com]
Sent: 20 August 2009 20:38
To: 'rt-users@lists.bestpractical.com’
Subject: mod_fastcgi problems

Hi,

I hope you can help. I am running Gentoo and installed RT v3.6.7 via
emerge. I have followed your instructions at
http://wiki.bestpractical.com/view/GentooInstallGuide and all seems to go
well until I:

cp /var/www/myrt/rt-3.6.1/etc/rt_apache2_fcgi.conf /etc/apache2/vhosts.d/

And then when I restart apache I receive the following error:

  • apache2 has detected a syntax error in your configuration files:

Syntax error on line 3 of /etc/apache2/vhosts.d/rt_apache2_fcgi.conf:

Invalid command ‘FastCgiIpcDir’, perhaps misspelled or defined by a module
not included in the server configuration

If I run ‘perl sbin/rt-test-dependencies --with-fastcgi’ I get the following
output:

perl:

    >=5.8.3(5.008008)...found

users:

    rt group (rt)...found

    bin owner (rt)...found

    libs owner (rt)...found

    libs group (rt)...found

    web owner (apache)...found

    web group (apache)...found

CLI dependencies:

CORE dependencies:

FASTCGI dependencies:

MAILGATE dependencies:

MASON dependencies:

Everything was found.

Many thanks for your help. Please advise if you would like to see the
contents of any other config file.

Cheers,

Andy

Hi,

Regarding the below email does anyone know why I am unable to start apache?
It seems like the fastcgi module is not installed but RT seems to report
that it is. Does anyone know how I can check this on Gentoo?

RT does not check if the module fastcgi is installed, it only checks if
the needed perl support for fastcgi is installed.

For Gentoo, I cannot really help, but try to find a file named
*fastcgi.so in /usr.

Hi Emmanuel,

Thanks for your help! I feel a bit of a fool but I didn’t install it!! I
didn’t search Gentoo’s package manager properly with the correct full name
(emerge -v mod_fastcgi).

However, now when I start apache I get a different message, please see
below. Can I just disable this line referring to ‘suexec2’? I enabled it
in my APACHE2_OPTS yesterday out of sheer desperation!

==== ERROR ====

  • apache2 has detected a syntax error in your configuration files:
    Syntax error on line 7 of /etc/apache2/vhosts.d/rt_apache2_fcgi.conf:
    FastCgiWrapper: “/usr/sbin/suexec2” execute access for server (uid 81, gid
  1. failed: stat(/usr/sbin/suexec2) failed: No such file or directory
    ===============

Well I personnaly never use suexec, but if you wan’t to use it, as
fastcgi, check that it is installed and check the path (maybe not
/usr/sbin/suexec2).

Else, just follow fastcgi instructions in RT README file :wink: