FW: 403 Forbidden

Hi all,

Newbie here and would really appreciate some help here. I’ve recently just
installed RT (v3.6.7) on Gentoo using the provided ebuilds. The install
seems to have gone okay except I could not log onto the web interface.
After buying RT essentials I convinced myself the my configuration was ok
but I still got the below error. I noticed that my RT_SiteConfig.pm file
was owned by root so changed this to rt:rt. However when I checked my log
file (/var/logs/apache/error_log) I was the following entry:

Can’t locate //var/www/helpdesk.pikedom.com/rt-3.6.7/etc/RT_SiteConfig.pm in
@INC (@INC contains: //var/www/helpdesk.pikedom.com/rt-3.6.7/local/lib
//var/www/helpdesk.pikedom.com/rt-3.6.7/lib /etc/perl
/usr/lib/perl5/vendor_perl/5.8.8/i686-linux /usr/lib/perl5/vendor_perl/5.8.8
/usr/lib/perl5/vendor_perl /usr/lib/perl5/site_perl/5.8.8/i686-linux
/usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl
/usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8
/usr/local/lib/site_perl .) at
//var/www/helpdesk.pikedom.com/rt-3.6.7/lib/RT.pm line 152.

.

.

.

RT couldn’t load RT config file
//var/www/helpdesk.pikedom.com/rt-3.6.7/etc/RT_SiteConfig.pm as:

user: apache

group: apache

The file is owned by user rt and group rt.

This usually means that the user/group your webserver is running

as cannot read the file. Be careful not to make the permissions

on this file too liberal, because it contains database passwords.

You may need to put the webserver user in the appropriate group

(rt) or change permissions be able to run succesfully.

I then added apache to the rt group (usermod -G rt apache) but now I see the
following entries in my log:

Could not create
’/var/www/helpdesk.pikedom.com/rt-3.6.7/var/mason_data/obj/.__obj_create_mar
ker’: Permission denied

Stack:

[/usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Interp.pm:222]

[/usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Interp.pm:169]

[/usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/Interp.pm:155]

[/usr/lib/perl5/vendor_perl/5.8.8/Class/Container.pm:329]

[/usr/lib/perl5/vendor_perl/5.8.8/Class/Container.pm:53]

[/usr/lib/perl5/vendor_perl/5.8.8/HTML/Mason/CGIHandler.pm:48]

[/var/www/helpdesk.pikedom.com/rt-3.6.7/lib/RT/Interface/Web/Handler.pm:173]

[/var/www/helpdesk.pikedom.com/rt-3.6.7/lib/RT/Interface/Web/Handler.pm:168]

[/var/www/helpdesk.pikedom.com/rt-3.6.7/bin/webmux.pl:89]

Am I doing the right thing? Can anyone offer any advice?

Thanks in advance,

AndyFrom: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Andrew Pike
Sent: 22 August 2009 16:04
To: rt-users@lists.bestpractical.com
Subject: [rt-users] 403 Forbidden

Hi,

I am trying to log into the RT UI via a web browser for the first time but
am unable to get anything other than a ‘403 Forbidden’ page. Can anyone
point me in the right direction? It is anything to do with file permissions
or could it be something wrong in my setup / config?

Many thanks,

Andy

ATT00041.txt (321 Bytes)