Full text searching with RT 4.4.4 and MySQL 5.7


We’re using RT 4.4.4 with MySQL 5.7, and working on full text searching. It’s quite confusing as there are many web pages out there saying it doesn’t work and you have to use something like Sphinx, however my understanding is that it will work in MySQL 5.6 and above.

We’ve run /opt/rt4/sbin/rt-setup-fulltext-index and it apparently completed successfully, and after adding the %FullTextSearch bit to our configuration under /etc/request-tracker4/RT_SiteConfig.d full text searches appear to be working. The words “You can search for any word in full ticket history by typing fulltext: word” appear on the Search page. So far so good…

We then ran /opt/rt4/sbin/rt-fulltext-indexer which as per the documentation is needed to keep the indexes up to date, however it gives an error:
Full text search is disabled in your RT configuration. Run /opt/rt4/sbin/rt-setup-fulltext-index to configure and enable it.

This error is incorrect as full text searches are enabled in the RT configuration, as evidenced by it being available on RT’s Search page. So my questions are:

  1. Can someone confirm whether we really need to run rt-setup-fulltext-index?
  2. How can we fix this “Full text search is disabled in your RT configuration” error?

Thanks very much for any assistance.

To be sure its enabled and RT sees it as enabled, if you go to Admin->Tools->System Configuration and search “FullTextSearch” what is the config value set to?

I did that and it’s set to:

‘Engine’ => ‘InnoDB’,
‘Table’ => ‘AttachmentsIndex’,
‘Indexed’ => 1,
‘Column’ => ‘Content’,
‘Enable’ => 1

Any ideas what could be wrong with rt-setup-fulltext-index? Thank you.

Does the user running the indexer have the correct rights to read the RT_SiteConfig.d/ directory?

After adding a bit of debugging code I found that rt-fulltext-indexer was looking in /opt/rt4/etc. for the configuration, whereas the web interface uses /etc/request-tracker4. Problem solved.