Fsck.com RT instance Upgraded to 2.1.68

You have no idea how much pleasure it gives me to announce that
fsck.com’s RT instance has been upgraded to RT 2.1.68. We’ll be watching
closely over the next serveral days to make sure everything is in order,
but so far, so good.

Jesse

»|« http://www.bestpractical.com/rt – Trouble Ticketing. Free.
rt-announce mailing list
rt-announce@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-announce

Jesse Vincent wrote:

You have no idea how much pleasure it gives me to announce that
fsck.com’s RT instance has been upgraded to RT 2.1.68. We’ll be watching
closely over the next serveral days to make sure everything is in order,
but so far, so good.

One question: what is the url of the instance of RT?

One question: what is the url of the instance of RT?

if you go to fsck.com/rt2/ where the instance used to live,
you’ll be redirected to rt3.fsck.com, its new home.

-j

»|« http://www.bestpractical.com/rt – Trouble Ticketing. Free.

One question: what is the url of the instance of RT?

if you go to fsck.com/rt2/ where the instance used to live,
you’ll be redirected to rt3.fsck.com, its new home.

When I do that with a web browser identified by the following string:

“Mozilla/5.0 (Macintosh; U; PPC Mac OS X; de-de) AppleWebKit/51
(like Gecko) Safari/51”

I get some asian looking login screen. The web pages are not german at
all as well, being a mix of misrendered utf8 characters (not Your
fault) and english.

I guess the /de-de/ is not standards compliant.

Regards,
Harald

Harald Wagener * FCB/Wilkens * An der Alster 42 * 20099 Hamburg

At 10:39 AM 6/02/2003 +0100, Harald Wagener wrote:

if you go to fsck.com/rt2/ where the instance used to live,
you’ll be redirected to rt3.fsck.com, its new home.

When I do that with a web browser identified by the following string:

“Mozilla/5.0 (Macintosh; U; PPC Mac OS X; de-de) AppleWebKit/51
(like Gecko) Safari/51”

I get some asian looking login screen. The web pages are not german at all
as well, being a mix of misrendered utf8 characters (not Your fault) and
english.

I guess the /de-de/ is not standards compliant.

The de-de in the version string should be irrelevant since for language
purposes it should be using the HTTP-Accept-Language header your browser
sends. I think this is broken in RT, however. I noticed this problem in an
early release of the 2.1 but didn’t have time to investigate.

At any rate, my HTTP-Accept-Language header is:
HTTP_ACCEPT_LANGUAGE=en-au, en;q=0.66, nl;q=0.33

When I aim this at http://rt3.fsck.com/ I get a Dutch page, despite the
fact that English is listed as preferable. If I yank Dutch from the end of
the list, I get an English page (as expected). Hence I think there’s a
problem with the auto-language detection in RT3.

It’s commendable that RT is trying to do the right thing here. One of my
pet hates is web i18n that ignores what your browser says about your
language preferences.

Cheers,

  • Andrew

At 10:39 AM 6/02/2003 +0100, Harald Wagener wrote:

I guess the /de-de/ is not standards compliant.

The de-de in the version string should be irrelevant since for
language purposes it should be using the HTTP-Accept-Language header
your browser sends.

Ah, OK. How do I find out what HTTP-Accept-Language header my browser
sends?

Regards,
Harald

Harald Wagener * FCB/Wilkens * An der Alster 42 * 20099 Hamburg

At 12:26 PM 6/02/2003 +0100, Harald Wagener wrote:

Ah, OK. How do I find out what HTTP-Accept-Language header my browser sends?

Drop the following script in your cgi-bin area, and point your browser at it.

#!/bin/sh

printenv – simple CGI program which just prints its environment.

- Andrew Snare ajs@pigpond.com

echo “Content-type: text/plain\n”;
exec env | sort -t=

End

Make sure it’s executable.

  • Andrew

At 12:26 PM 6/02/2003 +0100, Harald Wagener wrote:

Ah, OK. How do I find out what HTTP-Accept-Language header my browser
sends?

Drop the following script in your cgi-bin area, and point your browser
at it.

[snip]

Make sure it’s executable.

  • Andrew

Amongst other info, I spotted this nice one:

|HTTP_ACCEPT_LANGUAGE=de-de, ja;q=0.20, en;q=0.60, en-us;q=0.40,
de;q=0.80

Why japanese still is in there is beyond me, but being on a Mac at the
time being, I am bound to the system preferences (where I selected
german,english,us-english in that order).

Safari is evil, but at least it recognizes some of the info. Chimera
just has no user configurable Language Acception stuff.

Regards,
Harald
Harald Wagener * FCB/Wilkens * An der Alster 42 * 20099 Hamburg

At 03:37 PM 6/02/2003 +0100, Harald Wagener wrote:

|HTTP_ACCEPT_LANGUAGE=de-de, ja;q=0.20, en;q=0.60, en-us;q=0.40, de;q=0.80

Why japanese still is in there is beyond me, but being on a Mac at the
time being, I am bound to the system preferences (where I selected
german,english,us-english in that order).

Your list is equivalent to:
de-de
de[-]*
en[-]*
en-us
ja[-]*

Ignoring the Japanese on the end, note that en-us will never be 'selected’
because ‘en’ occurs higher in the list. I doubt this is intended.

Safari is evil, but at least it recognizes some of the info. Chimera just
has no user configurable Language Acception stuff.

Getting waaaay off-topic here, but if Chimera uses the same preferences
code as Mozilla, you can change the languages line in your prefs.js to
something like:

     user_pref("intl.accept_languages", "en-au, en, nl");

Chimera is arguably broken if it’s sending an Accept-Languages header but
doesn’t give you a way to alter the settings (according to the RFC).

This Accept-Language stuff is defined in RFC2616, Section 14.4.

Cheers,

  • Andrew