First-time RT install questions

First, let’s start with perl.

My CentOS-3 (RHEL-3) system had perl 5.8.0 installed, and RT says it needs
5.8.3 minimum. Following the ‘ComplilingPerl’ page, in the RT Wiki, I have
built perl 5.8.7 and it is installed in /usr/local/perl-5.8.7.

The page assumes that I already have a working RT installed, and uses it to
help get the perl up to date with all required perl modules. I don’t have RT
installed yet though. Is there some way that I can install all these
dependencies before installing RT? I know I can do this during the RT
install, but I’d prefer to get it done ahead of time, if I can.

Also, the page stops at the point of telling me I need to do something so
that RT will use the new perl and not the vendor supplied one, but stops
short of telling me what it is I need to do. What do I need to do?

-ste

You should actually be able to start installing RT. Follow the manual
instructions in the Wiki, and make sure to configure RT to use your
custom perl installation. Then when you get to the step of using the
dependency checker/resolver it will handle installing the CPAN
dependencies for you.

Joby Walker
ITI SSG, University of Washington

Shaun T. Erickson wrote:

Hi All,

I’m trying to use this wonderful contrib:

http://wiki.bestpractical.com/index.cgi?SpreadsheetDisplayedFields

It works, but for some reason some of the fields are being imported into
Excel with HTML formatting tags around them… Anybody run into this problem
before?

Thanks! :slight_smile:

  • David

At Tuesday 10/18/2005 05:02 PM, David Young wrote:

Hi All,

I’m trying to use this wonderful contrib:

http://wiki.bestpractical.com/index.cgi?SpreadsheetDisplayedFields

It works, but for some reason some of the fields are being imported into
Excel with HTML formatting tags around them… Anybody run into this problem
before?

Hello David,

There shouldn’t (of course!) be any HTML in the downloaded data - can you
show us what the data looks like - what fields have HTML and what the tags are?

Also, what version of RT are you on?

Thanks,
Steve

Stephen Turner wrote:

At Tuesday 10/18/2005 05:02 PM, David Young wrote:

Hi All,

I’m trying to use this wonderful contrib:

http://wiki.bestpractical.com/index.cgi?SpreadsheetDisplayedFields

It works, but for some reason some of the fields are being imported into
Excel with HTML formatting tags around them… Anybody run into this
problem
before?

I would hazard a guess and say that Excel is adding them automatically
around email addresses. I can’t see anywhere else it would do that
though. With 3.4.4 I see no HTML tags in the raw file. OpenOffice Calc
does not add any tags. I can’t test Excel…

Tom

You should actually be able to start installing RT. Follow the manual
instructions in the Wiki, and make sure to configure RT to use your
custom perl installation. Then when you get to the step of using the
dependency checker/resolver it will handle installing the CPAN
dependencies for you.

Ok. I set and exported the PERL variable to the location of the newer perl,
then built and installed RT.

Now I’m trying to build the fastcgi module for apache, and it’s failing
because I’m getting lots of undefined references to

apr_something

where ‘something’ is a lot of different things.

What do I need to add to my system to get these functions?
-ste

Now I’m trying to build the fastcgi module for apache, and it’s failing
because I’m getting lots of undefined references to

apr_something

I see that I was trying to build it incorrectly, and have corrected my
mistake. It builds and installs just fine now. Sorry.

-ste

Ok, now that I have mod_fastcgi installed, I’m trying to configure apache 2
to be able to access RT. I’m finding it very confusing, because the wiki
shows to do it different ways on different pages.

When I try to access the URL https://spot.blackdogsoft.net/rt I get a 403
error page saying I don’t have permission to access /rt, and the ssl error
log says “FastCGI: invalid (dynamic) server “/usr/local/rt3/share/html/”:
script is a directory!”

In httpd.conf, I added (outside of any virtual host):

FastCgiIpcDir /tmp FastCgiServer /usr/local/rt3/bin/mason_handler.fcgi -idle-timeout 120 -processes 10

and where all of the other modules are loaded:

LoadModule fastcgi_module modules/mod_fastcgi.so

In my ssl virtual host definition, I added:

Alias /rt "/usr/local/rt3/share/html"
AddHandler fastcgi-script fcgi
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi/
<Location /rt>
AddDefaultCharset UTF-8
SetHandler fastcgi-script

<Directory “/usr/local/rt3”>
Order allow,deny
Allow from all

Other info: my webserver runs as user and group “apache”. My RT installation
is all owned by root and group bin, except for some which are group apache.

I could use some help figuring out what I’ve done wrong, please. I’m sure
it’s me, and not the software. :slight_smile:

If more info is needed, just ask - I’ll be glad to provide it.

-ste

Ok, now that I have mod_fastcgi installed, I’m trying to configure apache 2
to be able to access RT. I’m finding it very confusing, because the wiki
shows to do it different ways on different pages.

When I try to access the URL
https://spot.blackdogsoft.net/rt I get a 403 error page
saying I don’t have permission to access /rt, and the ssl error log says
"FastCGI: invalid (dynamic) server “/usr/local/rt3/share/html/”: script is a
directory!"

In httpd.conf, I added (outside of any virtual host):

FastCgiIpcDir /tmp FastCgiServer /usr/local/rt3/bin/mason_handler.fcgi -idle-timeout 120 -processes 10

and where all of the other modules are loaded:

LoadModule fastcgi_module modules/mod_fastcgi.so

In my ssl virtual host definition, I added:

Alias /rt "/usr/local/rt3/share/html"
I’m sure you don’t need this Alias.

AddHandler fastcgi-script fcgi
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi/
<Location /rt>
AddDefaultCharset UTF-8
SetHandler fastcgi-script

<Directory “/usr/local/rt3”>
Order allow,deny
Allow from all

Other info: my webserver runs as user and group “apache”. My RT
installation is all owned by root and group bin, except for some which are
group apache.

I could use some help figuring out what I’ve done wrong, please. I’m sure
it’s me, and not the software. :slight_smile:

If more info is needed, just ask - I’ll be glad to provide it.

 -ste

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Buy your copy of our new book, RT Essentials, today!

Download a free sample chapter from
http://rtbook.bestpractical.com

Best regards, Ruslan.

First, let’s start with perl.

My CentOS-3 (RHEL-3) system had perl 5.8.0 installed, and RT says it
needs 5.8.3 minimum. Following the ‘ComplilingPerl’ page, in the RT
Wiki, I have built perl 5.8.7 and it is installed in
/usr/local/perl-5.8.7.

By the time you replace the stock perl and mysql, you might
be ahead to update the whole system to Centos-4 which only
needs the addition of the fastcgi module to work.

Les Mikesell
les@futuresource.com

By the time you replace the stock perl and mysql, you might
be ahead to update the whole system to Centos-4 which only
needs the addition of the fastcgi module to work.

I’m not replacing the stock perl, simply adding a newer bersion for use by
RT and anything else that might want it in the future. Replacing MySQL was
trivial - I just uninstalled the stock RPMs and installed the RPMs from the
MySQL site.

Upgrading to CentOS-4 would be nice, but I’m not prepared to do that, just
yet.

-ste

Alias /rt "/usr/local/rt3/share/html"
I’m sure you don’t need this Alias.

When I removed the alias, apache was unable to find RT, so I put it back.

-ste

i got problem install RT on my CentOS 4 … afteri cp my makefile and change the top dir to /etc/httpd

i try to make or make install give me this error

[root@localhost mod_fastcgi-2.4.2]# make
Makefile:12: /etc/httpd/build/special.mk: No such file or directory
make: *** No rule to make target `/etc/httpd/build/special.mk’. Stop.

hope guys can help me with this. Thank alot
View this message in context: http://www.nabble.com/First-time-RT-install-questions.-t421406.html#a2399898

lists> i got problem install RT on my CentOS 4 … afteri cp my makefile and change the top dir to /etc/httpd
lists>
lists> i try to make or make install give me this error
lists>
lists> [root@localhost mod_fastcgi-2.4.2]# make
lists> Makefile:12: /etc/httpd/build/special.mk: No such file or directory
lists> make: *** No rule to make target `/etc/httpd/build/special.mk’. Stop.
lists>
lists> hope guys can help me with this. Thank alot

You need package httpd-devel, but secial.mk is located elsewhere… at
/usr/lib/httpd/build/special.mk.

I have packaged rt-3.4.5 for CentOs 4 (with mod_perl), see:

http://wiki.bestpractical.com/index.cgi?RPMInstall

or if you really want mod_fastcgi you can grab it from:

http://campus.fct.unl.pt/paulomatos/rt/other/

Regards,

Paulo Matos

|Sys & Net Admin | Centro de Inform�tica |
|Faculdade de Ci�ncias e Tecnologia | Tel: +351-21-2948596 |
|Universidade Nova de Lisboa | Fax: +351-21-2948548 |
|P-2829-516 Caparica | e-Mail: pjsm@fct.unl.pt |


ok new error occur… look like the mirror is down?

–> Processing Dependency: perl(XML::RSS) >= 1.05 for package: rt
–> Restarting Dependency Resolution with new changes.
–> Populating transaction set with selected packages. Please wait.
—> Downloading header for perl-Clone to pack into transaction set.
perl-Clone-0.18-2.i386.rp 100% |=========================| 0 B 00:06
http://campus.fct.unl.pt/paulomatos/rt/repository/3.4.x/i386/perl-Clone-0.18-2.i386.rpm: [Errno 4] Socket Error: timed out
Trying other mirror.
Error: failure: i386/perl-Clone-0.18-2.i386.rpm from rt-3.4.x: [Errno 256] No more mirrors to try.
[root@localhost ~]#
View this message in context: http://www.nabble.com/First-time-RT-install-questions.-t421406.html#a2417243

oh is ok now, i need to run the yum install rt rt-mail-dispatcher few time to make it work =.=;

anyway thank you for helping ^^
View this message in context: http://www.nabble.com/First-time-RT-install-questions.-t421406.html#a2417286

Sorry to ask again where can i find the way to configure /etc/rt/RT_SiteConfig.pm and
/etc/httpd/conf.d/rt.conf. I’m using CentOS 4 . Thnk you
View this message in context: http://www.nabble.com/First-time-RT-install-questions.-t421406.html#a2418068

Personally, I used cp RT_Config.pm RT_SiteConfig.pm and read the inline
notes in the file.

The info for the httpd conf file is on the Wiki at the BestPractical
site: it’s very simple - I do something like the below. That’s for
Apache 1.3, virtual host, but I’m sure you’ll see the important parts.
Note that the DocumentRoot (in the vs, or the Directory in other cases)
should relate to values you set in RT_SiteConfig

<VirtualHost 10.50.80.36:80>
ServerName rt
ServerAlias rt.easa.local
DocumentRoot "/opt/rt3/share/html/"

Options FollowSymLinks
AllowOverride None

<Directory “/opt/rt3/share/html/”>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
Allow from all

Mod-perl RT:

AddDefaultCharset UTF-8
PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl
#PerlInitHandler Apache::Reload
#PerlSetVar ReloadAll Off
#PerlSetVar ReloadModules "RT::*"


SetHandler perl-script
PerlHandler RT::Mason


DirectoryIndex index.html

UseCanonicalName On

Lee Goddard
Internet Application Analysis/Development
European Aviation Safety Agency-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Zeonz
Sent: 17 January 2006 04:28
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] First-time RT install questions.

Sorry to ask again where can i find the way to configure

/etc/rt/RT_SiteConfig.pm and
/etc/httpd/conf.d/rt.conf. I’m using CentOS 4 . Thnk you

View this message in context: Re: First-time RT install

questions.
<http://www.nabble.com/First-time-RT-install-questions.-t421406.html#a24
18068>
http://www.nabble.com/Request-Tracker---User-f572.html forum at
Nabble.com.

Hello,

I got the same problem.

“You don’t have permission to access /rt on this server”

Did you have your problem solved?

Thanks,
–Pau;
View this message in context: http://www.nabble.com/First-time-RT-install-questions.-t421406.html#a3130005