First install error, and using postfix?


#1

Hi everyone. I just made my first RT installation (1.0.7) on a Mandrake
Corporate Server 1.0.1. The main point of divergence from the install
documents is that I am running postfix as my MTA. Things went mostly
smoothly and I was able to add some users and queues using the web
interface. I then encountered two problems.

  1. When i tried to create a ticket by mailing the helpdesk address, it
    bounced the message. The mail error log showed that there was a problem
    with the sendmail options, so I went into config.pm and just commented the
    line out that had the sendmail options.

  2. On try two i actually got a response back from the server, but it was
    not the response that I wanted:

Subject: [aurora.edu #] (_rt_system) RT Error: blackboard problem
Reply-To: Christopher Kolar via RT ishelp@astra.aurora.edu
From: Christopher Kolar via RT ishelp@astra.aurora.edu
To: ckolar@aurora.edu
X-Request-ID:
X-RT-Loop-Prevention: aurora.edu
X-Sender: ckolar@aurora.edu
Date: Tue, 27 Feb 2001 11:05:54 -0600 (CST)
Sender: nobody@astra.aurora.edu

There has been an error:
There has been an error with your request:

Your message is reproduced below:

I have a problem with blackboard.

I am able to create and manipulate tickets through the web, and it is
sending outgoing email notification normally. Any suggestions as to what I
can do to get the incoming email interface to work would be much appreciated.

Thanks,

–chris

/////\\/////\\
Christopher G. Kolar
Director of Instructional Technology
Aurora University, Aurora, Illinois
ckolar@admin.aurora.eduwww.aurora.edu/~ckolar
[PGP Public Key ID: 0xC6492C72]


#2

At 11:34 AM 2/27/2001, I wrote:

Hi everyone. I just made my first RT installation (1.0.7) on a Mandrake
Corporate Server 1.0.1. The main point of divergence from the install
documents is that I am running postfix as my MTA. Things went mostly
smoothly and I was able to add some users and queues using the web
interface. I then encountered two problems.

  1. When i tried to create a ticket by mailing the helpdesk address, it
    bounced the message. The mail error log showed that there was a problem
    with the sendmail options, so I went into config.pm and just commented the
    line out that had the sendmail options.

Well, half of the problem has been solved. I spelled correspond with three
Rs in my aliases file. I would still be interested in knowing about the
postfix options for mailing stuff, but I am really happy that I can create
new tickets via email.

Thanks,

–chris