Firefox4 textbox missing

since upgrading to firefox4, when you try to reply to a ticket through the web interface, the textbox for Message does not show. The area is there for it but theres no box to type in. seeing this in ff4 on linux & win7. didn’t find any other messages on this list about it, is anyone else running ff4 and seeing this behavior?

“RK&K” and “RK&K Engineers” are registered trade names of Rummel, Klepper & Kahl, LLP, a Maryland
limited liability partnership. This message contains confidential information intended only for
the person or persons named above. If you have received this message in error, please immediately
notify the sender by return email and delete the message. Thank you.

(11/03/30 8:22), Brian Dial wrote:

since upgrading to firefox4, when you try to reply to a ticket through the web interface, the textbox for Message does not show. The area is there for it but theres no box to type in. seeing this in ff4 on linux& win7. didn’t find any other messages on this list about it, is anyone else running ff4 and seeing this behavior?

I’m using Firefox 4.0 on OS X 10.6.7 against both RT4.0.0-rc7 and
RT3.8.8. I do see the message box with either value for the “WYSIWYG
message composer” preference.

Could you tell us which version of RT you’re using?

Shawn

(11/03/30 8:22), Brian Dial wrote:

since upgrading to firefox4, when you try to reply to a ticket through the web interface, the textbox for Message does not show. The >>area is there for it but theres no box to type in. seeing this in ff4 on linux& win7. didn’t find any other messages on this list >>about it, is anyone else running ff4 and seeing this behavior?

I’m using Firefox 4.0 on OS X 10.6.7 against both RT4.0.0-rc7 and
RT3.8.8. I do see the message box with either value for the “WYSIWYG
message composer” preference.

Could you tell us which version of RT you’re using?

Shawn

3.8.9. I’ve tried clearing all the cache too on the client and that has not helped. not using any special plugins this is a pretty new install

“RK&K” and “RK&K Engineers” are registered trade names of Rummel, Klepper & Kahl, LLP, a Maryland
limited liability partnership. This message contains confidential information intended only for
the person or persons named above. If you have received this message in error, please immediately
notify the sender by return email and delete the message. Thank you.

Running Firefox 4.0/Win7 x64 and using RT 3.8.8 and it is fine for me, but I did upgrade the WYSIWYG editor to CKEditor 3.4.1 when a patch was posted on the list.-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Brian Dial
Sent: 30 March 2011 13:22
To: rt-users
Subject: [rt-users] firefox4 textbox missing

since upgrading to firefox4, when you try to reply to a ticket through the web interface, the textbox for Message does not show. The area is there for it but theres no box to type in. seeing this in ff4 on linux & win7. didn’t find any other messages on this list about it, is anyone else running ff4 and seeing this behavior?

“RK&K” and “RK&K Engineers” are registered trade names of Rummel, Klepper & Kahl, LLP, a Maryland limited liability partnership. This message contains confidential information intended only for the person or persons named above. If you have received this message in error, please immediately notify the sender by return email and delete the message. Thank you.

(11/03/30 8:50), Brian Dial wrote:

----- Original Message -----
(11/03/30 8:22), Brian Dial wrote:

since upgrading to firefox4, when you try to reply to a ticket through the web interface, the textbox for Message does not show. The>>area is there for it but theres no box to type in. seeing this in ff4 on linux& win7. didn’t find any other messages on this list>>about it, is anyone else running ff4 and seeing this behavior?

I’m using Firefox 4.0 on OS X 10.6.7 against both RT4.0.0-rc7 and
RT3.8.8. I do see the message box with either value for the “WYSIWYG
message composer” preference.

Could you tell us which version of RT you’re using?

Shawn

3.8.9. I’ve tried clearing all the cache too on the client and that has not helped. not using any special plugins this is a pretty new install

I can reproduce the problem on 3.8.9 and 3.8-trunk. I’ve filed a ticket
for you: http://issues.bestpractical.com/Ticket/Display.html?id=17000

As a temporary workaround, turning off the wysiwyg text editor in your
preferences will let you actually create and reply to tickets.

Shawn

(11/03/30 8:50), Brian Dial wrote:

----- Original Message -----
(11/03/30 8:22), Brian Dial wrote:

since upgrading to firefox4, when you try to reply to a ticket through the web interface, the textbox for Message does not show. The>>area is there for it but theres no box to type in. seeing this in ff4 on linux& win7. didn’t find any other messages on this list>>about it, is anyone else running ff4 and seeing this behavior?

I’m using Firefox 4.0 on OS X 10.6.7 against both RT4.0.0-rc7 and
RT3.8.8. I do see the message box with either value for the “WYSIWYG
message composer” preference.

Could you tell us which version of RT you’re using?

Shawn

3.8.9. I’ve tried clearing all the cache too on the client and that has not helped. not using any special plugins this is a pretty new install

I can reproduce the problem on 3.8.9 and 3.8-trunk. I’ve filed a ticket
for you: http://issues.bestpractical.com/Ticket/Display.html?id=17000

As a temporary workaround, turning off the wysiwyg text editor in your
preferences will let you actually create and reply to tickets.

Shawn

thanks!

“RK&K” and “RK&K Engineers” are registered trade names of Rummel, Klepper & Kahl, LLP, a Maryland
limited liability partnership. This message contains confidential information intended only for
the person or persons named above. If you have received this message in error, please immediately
notify the sender by return email and delete the message. Thank you.

since upgrading to firefox4, when you try to reply to a ticket through the web interface, the textbox for Message does not show. The area is there for it but theres no box to type in. seeing this in ff4 on linux& win7. didn’t find any other messages on this list about it, is anyone else running ff4 and seeing this behavior?

I just upgraded to FF4 on Windows 7 yesterday, and everything is working
fine for my installation.

Do you happen to have an add-on installed that would be causing you grief?

Or, check your settings in the preferences and try setting everything
back to defaults for the message composer, if they are changed.

Regards,
Max

As a test I have also just updated RT to use the latest CKEditor version 3.5.2 as it has fixes for IE9 and several other browser updates. Also works flawlessly.-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Alex Young
Sent: 30 March 2011 13:57
To: rt-users
Subject: Re: [rt-users] firefox4 textbox missing

Running Firefox 4.0/Win7 x64 and using RT 3.8.8 and it is fine for me, but I did upgrade the WYSIWYG editor to CKEditor 3.4.1 when a patch was posted on the list.

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com [mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Brian Dial
Sent: 30 March 2011 13:22
To: rt-users
Subject: [rt-users] firefox4 textbox missing

since upgrading to firefox4, when you try to reply to a ticket through the web interface, the textbox for Message does not show. The area is there for it but theres no box to type in. seeing this in ff4 on linux & win7. didn’t find any other messages on this list about it, is anyone else running ff4 and seeing this behavior?

“RK&K” and “RK&K Engineers” are registered trade names of Rummel, Klepper & Kahl, LLP, a Maryland limited liability partnership. This message contains confidential information intended only for the person or persons named above. If you have received this message in error, please immediately notify the sender by return email and delete the message. Thank you.

As a test I have also just updated RT to use the latest CKEditor version 3.5.2 as it has fixes for IE9 and several other browser updates. Also works flawlessly.

RT 3.8 doesn’t use CKEditor, so I’m not sure how this is relevant?

-kevin

Some versions of FCKEditor has had issues with browser detection for
newer browser versions. As far as I can tell it’s dependant on older
versions of FCKEditor being used, but as the bug has been replicated on
3.8.9 and 3.8-trunk perhaps it is not the case. Some FCKEditor users
have been updating the agent strings to detect FF4.0 and IE9 correctly.

Either way, it may be an option to try the newer CKEditor as it was such
as simple patch posted on the list a while back, and easily reverted
back to FCKEditor.From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Kevin
Falcone
Sent: 30 March 2011 16:02
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] firefox4 textbox missing

As a test I have also just updated RT to use the latest CKEditor
version 3.5.2 as it has fixes for IE9 and several other browser updates.
Also works flawlessly.

RT 3.8 doesn’t use CKEditor, so I’m not sure how this is relevant?

-kevin

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Alex
Young
Sent: 30 March 2011 13:57
To: rt-users
Subject: Re: [rt-users] firefox4 textbox missing

Running Firefox 4.0/Win7 x64 and using RT 3.8.8 and it is fine for me,
but I did upgrade the WYSIWYG editor to CKEditor 3.4.1 when a patch was
posted on the list.

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Brian
Dial
Sent: 30 March 2011 13:22
To: rt-users
Subject: [rt-users] firefox4 textbox missing

since upgrading to firefox4, when you try to reply to a ticket through
the web interface, the textbox for Message does not show. The area is
there for it but theres no box to type in. seeing this in ff4 on linux
& win7. didn’t find any other messages on this list about it, is anyone
else running ff4 and seeing this behavior?

“RK&K” and “RK&K Engineers” are registered trade names of Rummel,
Klepper & Kahl, LLP, a Maryland limited liability partnership. This
message contains confidential information intended only for the person
or persons named above. If you have received this message in error,
please immediately notify the sender by return email and delete the
message. Thank you.

How to enable FCKEditor/CKEditor in RT 3.8.9? I do not see the option
anywhere.

SimonOn Wed, Mar 30, 2011 at 8:51 AM, Alex Young <AlexYoung@housingpartners.co.uk wrote:

Some versions of FCKEditor has had issues with browser detection for
newer browser versions. As far as I can tell it’s dependant on older
versions of FCKEditor being used, but as the bug has been replicated on
3.8.9 and 3.8-trunk perhaps it is not the case. Some FCKEditor users
have been updating the agent strings to detect FF4.0 and IE9 correctly.

Either way, it may be an option to try the newer CKEditor as it was such
as simple patch posted on the list a while back, and easily reverted
back to FCKEditor.

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Kevin
Falcone
Sent: 30 March 2011 16:02
To: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] firefox4 textbox missing

On Wed, Mar 30, 2011 at 03:21:17PM +0100, Alex Young wrote:

As a test I have also just updated RT to use the latest CKEditor
version 3.5.2 as it has fixes for IE9 and several other browser updates.
Also works flawlessly.

RT 3.8 doesn’t use CKEditor, so I’m not sure how this is relevant?

-kevin

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Alex
Young
Sent: 30 March 2011 13:57
To: rt-users
Subject: Re: [rt-users] firefox4 textbox missing

Running Firefox 4.0/Win7 x64 and using RT 3.8.8 and it is fine for me,
but I did upgrade the WYSIWYG editor to CKEditor 3.4.1 when a patch was
posted on the list.

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Brian
Dial
Sent: 30 March 2011 13:22
To: rt-users
Subject: [rt-users] firefox4 textbox missing

since upgrading to firefox4, when you try to reply to a ticket through
the web interface, the textbox for Message does not show. The area is
there for it but theres no box to type in. seeing this in ff4 on linux
& win7. didn’t find any other messages on this list about it, is anyone
else running ff4 and seeing this behavior?

“RK&K” and “RK&K Engineers” are registered trade names of Rummel,
Klepper & Kahl, LLP, a Maryland limited liability partnership. This
message contains confidential information intended only for the person
or persons named above. If you have received this message in error,
please immediately notify the sender by return email and delete the
message. Thank you.

Some versions of FCKEditor has had issues with browser detection for
newer browser versions. As far as I can tell it’s dependant on older
versions of FCKEditor being used, but as the bug has been replicated on
3.8.9 and 3.8-trunk perhaps it is not the case. Some FCKEditor users
have been updating the agent strings to detect FF4.0 and IE9 correctly.

Either way, it may be an option to try the newer CKEditor as it was such
as simple patch posted on the list a while back, and easily reverted
back to FCKEditor.

The 3.8 series will not be shipping CKEditor, so if there is a problem
with FF4 that needs to be resolved with FCKEditor. I haven’t seen any
bug reports about IE9 and FCKEditor.

-kevin

How to enable FCKEditor/CKEditor in RT 3.8.9? I do not see the option anywhere.

search for RichText in your configuration files

-kevin

I noticed an issue with the Richtext editor and Fx4 when using the SphinxIntegrated addon from the wiki. This addon includes a javascript document.domain setting that goes in the InHeader file of RT. When this line is present, the Rich text editor does not load in Fx4. Without it, it works fine.
I don’t know if this is related, but I thought I’d mention it.

/Johan

I noticed an issue with the Richtext editor and Fx4 when using the SphinxIntegrated addon from the wiki. This addon includes a javascript document.domain setting that goes in the InHeader file of RT. When this line is present, the Rich text editor does not load in Fx4. Without it, it works fine.
I don’t know if this is related, but I thought I’d mention it.

The error turns out to be that CGI.pm 3.51 has started sticking a
header into the javascript which FF4 interprets strictly.

I have no insight into why the SphinxIntegrated addon breaks, but the
extension’s author reads the mailing list and may reply.

-kevin