Final fetchmailrc configuration

A brief summary of what I did to get RT mail working with Exchange 2007 without opening up plaintext passwords in Exchange. - Mike

CentOS 5.7 (Final)
RT 4.0.2
fetchmail release 6.3.21+NTLM+SSL+HESIOD+NLS
Exchange 2007

Install openssl and openssl-devel
Download latest fetchmail package
Unpack and cd to fetchmail-6.3.21
./configure --enable-NTLM --with-ssl
make && make install

add these to /etc/aliases:

Request Tracker aliases

kiss: "|/opt/smrsh/rt-mailgate --queue general --action correspond --url http://..com/"
kiss-comment: “|/opt/smrsh/rt-mailgate --queue general --action comment --url http://..com/http://<server>.<domain>.com/

this fetchmailrc worked for me:

[rt_user@x-tracker-01 ~]$ cat .fetchmailrc

Configuration created Fri Nov 18 16:22:13 2011 by fetchmailconf 1.57

set postmaster "postmaster"
set bouncemail
set no spambounce
set softbounce
set properties ""
set daemon 20
poll mail..com with proto IMAP and options no dns
user ‘rt_requests’ there with password ‘keepmefromlookingsilly’ is ‘kiss’ here options stripcr ssl
mda ‘/opt/rt4/bin/rt-mailgate --url http://..com. --queue General --action correspond’