Fetchmail URL Syntax Error

Just setup RT4 on ubuntu. I am attempting to setup fetchmail and I cannot seem to get the config file correct. My config is as follows:

set no bouncemail
set no syslog
set logfile “/var/log/fetchmail"
poll outlook.office365.com
protocol IMAP
service 993
user "tracking@domain.com" pass "somepass"
#folder Inbox ssl
mda ‘/opt/rt/bin/rt-mailgate --url http://servername --queue general –action correspond’

When I run fetchmail, i receive:
fetchmail:/home/username/.fetchmailrc:9: syntax error at --url

for the servername, I have tried the WebBaseURL, the WebURL, IP address, rtname, including/excluding http, etc but I cannot seem to get it to parse out the url without throwing that syntax error. Any thoughts?

Are those smart quotes from pasting here or are there smart quotes in the fetchmail config?

The quotes in the text is as it appears in the config.

Smart quotes are sneaky, I think you get rid of those and you should be good

I removed the quotes on the last line there and continue to receive the url syntax error. Were you referring to the single quotes on the last line for removal or other quotes as well?

In fact, I removed the url altogether and receive the same url syntax error so I may be missing something.

If i make my configuration file ~/.fetchmailrc Do I need to call that file out when running fetchmail -v or will it use it automatically as long as I’m not elevated? speaking of which, is elevation necessary? I’ve already chmod 600 ~/.fetchmailrc so I suspect the config file permissions are proper.

You have a bunch of spots in your config where the quotes are “angled” single and double. The angled ones are “smart quotes” and don’t play nice in code. You can just replace them with normal quotes

Above the first quote is smart and the second closing one is not

That did it! Thank you for your help!!!

Smart quotes are one of the dumbest ideas in the history of computing. :slight_smile: :slight_smile:

1 Like