Fedora core 3 with FAST-CGI errors (Todd McCullough)

This may not be the fix, but I ran into a similar problem using Fedora
core 3,which was a “permission denied” error in writing back to the file
system (actually it was with a wiki, but the idea is the same).

The answer - SELinux security config. RedHat bundles in a very
"helpful" security feature that sandboxes different user processes (like
httpd). And does nice, helpful things like not allowing the process to
write to the filesystem even though the permissions are absolutely and
utterly and truly correct [See admin bang head against wall].

I figured this out when I browsed the Fedora site for ideas on why my
httpd was not able to write to the filesystem…

Hope that helps.

/Glen Gyldersleve

SELINUX is enabled by default. However you can diable it or set it to ‘warn’ which will not stop anything but will inform you what it would be doing if enabled.From: Glen Gyldersleve
Date: 1/11/05 7:20 pm
To: rt-users@lists.bestpractical.com
Subj: [rt-users] RE: Fedora core 3 with FAST-CGI errors (Todd McCullough)

This may not be the fix, but I ran into a similar problem using Fedora
core 3,which was a “permission denied” error in writing back to the file
system (actually it was with a wiki, but the idea is the same).

The answer - SELinux security config. RedHat bundles in a very
"helpful" security feature that sandboxes different user processes (like
httpd). And does nice, helpful things like not allowing the process to
write to the filesystem even though the permissions are absolutely and
utterly and truly correct [See admin bang head against wall].

I figured this out when I browsed the Fedora site for ideas on why my
httpd was not able to write to the filesystem…

Hope that helps.

/Glen Gyldersleve

Today’s Topics:

  1. RE: Fedora core 3 with FAST-CGI errors (Todd McCullough)

Message: 1
Date: Tue, 11 Jan 2005 13:07:01 -0500
From: “Todd McCullough” tmccullo@n-able.com
Subject: RE: [rt-users] Fedora core 3 with FAST-CGI errors
To: “Rt-Users” rt-users@lists.bestpractical.com, "O4Tom"
2o4tom@gmail.com
Message-ID: MMEPLNOCLMIJILKDICLGMEGPCEAA.tmccullo@n-able.com
Content-Type: text/plain; charset=“us-ascii”

I double checked the permissions and still no luck…

[root@rt rt3]# ll
total 56
drwxr-xr-x 2 www rt 4096 Jan 3 16:20 bin
drwxr-xr-x 2 www rt 4096 Jan 3 18:25 etc
drwxr-xr-x 4 www rt 4096 Jan 3 16:20 lib
drwxr-xr-x 6 www rt 4096 Jan 3 16:20 local
drwxr-xr-x 2 www rt 4096 Jan 3 16:20 sbin
drwxr-xr-x 4 www rt 4096 Jan 3 16:20 share
drwxr-xr-x 5 www rt 4096 Jan 3 16:20 var

  [root@rt rt3]# cd bin/
  [root@rt bin]# ll
  total 156
  -rwxr-xr-x  1 www rt  3058 Dec 30 11:33 

mason_handler.fcgi
-rw-r–r-- 1 www rt 2283 Dec 30 11:33
mason_handler.scgi
-rwxr-xr-x 1 www rt 7706 Dec 30 11:33
mason_handler.svc
-rwxr-xr-x 1 www rt 54269 Dec 30 11:33 rt
-rwxr-xr-x 1 www rt 7443 Dec 30 11:33 rt-crontool
-rwxr-xr-x 1 www rt 21502 Dec 30 11:33 rt-mailgate
-rw-r–r-- 1 www rt 6794 Dec 30 11:33 standalone_httpd
-rwxr-xr-x 1 www rt 4193 Dec 30 11:33 webmux.pl
less /etc/group
www:x:101:rt
rt:x:502:www,apache

-----Original Message-----
From: O4Tom [mailto:2o4tom@gmail.com]
Sent: Tuesday, January 11, 2005 12:44 PM
To: Todd McCullough
Subject: Re: [rt-users] Fedora core 3 with FAST-CGI errors

I had something similar to this on my setup, but I was using
apache 1.3.x

Make sure those files are set to something that can be read
by the account that you run your webserver as. An easy way
to do that is to add your webserver user (apache, www, web,
etc) to the rt group in /etc/group

I’ve installed everything without errors but when I start
apache I get
the following errors.

I’ve using

Fedora core 3

postgresql-7.4.6-1.FC3.2

httpd-2.0.52-3.1

perl-5.8.5-9

mod_fastcgi-2.4.2-1

Here’s the errors!! Help!!!

[Sun Dec 26 04:02:10 2004] [notice] mod_python: Creating 4 session
mutexes based on 256 max processes and 0 max threads.

[Sun Dec 26 04:02:10 2004] [notice] FastCGI: process manager
initialized (pid 22080)

[Sun Dec 26 04:02:10 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 22081)

[Sun Dec 26 04:02:10 2004] [notice] Apache/2.0.52 (Fedora)
configured
– resuming normal operations

FastCGI: can’t start server “/opt/rt3/bin/mason_handler.fcgi” (pid
22081),
execle() failed: Permission denied

[Sun Dec 26 04:02:11 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" (pid 22081) terminated by calling
exit with status ‘255’

[Sun Dec 26 04:02:15 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" restarted (pid 22090)

FastCGI: can’t start server “/opt/rt3/bin/mason_handler.fcgi” (pid
22090),
execle() failed: Permission denied

[Sun Dec 26 04:02:15 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" (pid 22090) terminated by calling
exit with status ‘255’

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com

That fixed it!!!

woooo hooooo!!

Thanks for the help.

[mailto:rt-users-bounces@lists.bestpractical.com]On Behalf Of StephenSent: Tuesday, January 11, 2005 7:59 PM
To: Glen@canright.com; rt-users@lists.bestpractical.com
Subject: RE: [rt-users] RE: Fedora core 3 with FAST-CGI errors (Todd
McCullough)

SELINUX is enabled by default. However you can diable it or set it to 'warn’
which will not stop anything but will inform you what it would be doing if
enabled.

From: Glen Gyldersleve
Date: 1/11/05 7:20 pm
To: rt-users@lists.bestpractical.com
Subj: [rt-users] RE: Fedora core 3 with FAST-CGI errors (Todd McCullough)

This may not be the fix, but I ran into a similar problem using Fedora
core 3,which was a “permission denied” error in writing back to the file
system (actually it was with a wiki, but the idea is the same).

The answer - SELinux security config. RedHat bundles in a very
"helpful" security feature that sandboxes different user processes (like
httpd). And does nice, helpful things like not allowing the process to
write to the filesystem even though the permissions are absolutely and
utterly and truly correct [See admin bang head against wall].

I figured this out when I browsed the Fedora site for ideas on why my
httpd was not able to write to the filesystem…

Hope that helps.

/Glen Gyldersleve

Today’s Topics:

  1. RE: Fedora core 3 with FAST-CGI errors (Todd McCullough)

Message: 1
Date: Tue, 11 Jan 2005 13:07:01 -0500
From: “Todd McCullough” tmccullo@n-able.com
Subject: RE: [rt-users] Fedora core 3 with FAST-CGI errors
To: “Rt-Users” rt-users@lists.bestpractical.com, "O4Tom"
2o4tom@gmail.com
Message-ID: MMEPLNOCLMIJILKDICLGMEGPCEAA.tmccullo@n-able.com
Content-Type: text/plain; charset=“us-ascii”

I double checked the permissions and still no luck…

[root@rt rt3]# ll
total 56
drwxr-xr-x 2 www rt 4096 Jan 3 16:20 bin
drwxr-xr-x 2 www rt 4096 Jan 3 18:25 etc
drwxr-xr-x 4 www rt 4096 Jan 3 16:20 lib
drwxr-xr-x 6 www rt 4096 Jan 3 16:20 local
drwxr-xr-x 2 www rt 4096 Jan 3 16:20 sbin
drwxr-xr-x 4 www rt 4096 Jan 3 16:20 share
drwxr-xr-x 5 www rt 4096 Jan 3 16:20 var

  [root@rt rt3]# cd bin/
  [root@rt bin]# ll
  total 156
  -rwxr-xr-x  1 www rt  3058 Dec 30 11:33

mason_handler.fcgi
-rw-r–r-- 1 www rt 2283 Dec 30 11:33
mason_handler.scgi
-rwxr-xr-x 1 www rt 7706 Dec 30 11:33
mason_handler.svc
-rwxr-xr-x 1 www rt 54269 Dec 30 11:33 rt
-rwxr-xr-x 1 www rt 7443 Dec 30 11:33 rt-crontool
-rwxr-xr-x 1 www rt 21502 Dec 30 11:33 rt-mailgate
-rw-r–r-- 1 www rt 6794 Dec 30 11:33 standalone_httpd
-rwxr-xr-x 1 www rt 4193 Dec 30 11:33 webmux.pl
less /etc/group
www:x:101:rt
rt:x:502:www,apache

-----Original Message-----
From: O4Tom [mailto:2o4tom@gmail.com]
Sent: Tuesday, January 11, 2005 12:44 PM
To: Todd McCullough
Subject: Re: [rt-users] Fedora core 3 with FAST-CGI errors

I had something similar to this on my setup, but I was using
apache 1.3.x

Make sure those files are set to something that can be read
by the account that you run your webserver as. An easy way
to do that is to add your webserver user (apache, www, web,
etc) to the rt group in /etc/group

I’ve installed everything without errors but when I start
apache I get
the following errors.

I’ve using

Fedora core 3

postgresql-7.4.6-1.FC3.2

httpd-2.0.52-3.1

perl-5.8.5-9

mod_fastcgi-2.4.2-1

Here’s the errors!! Help!!!

[Sun Dec 26 04:02:10 2004] [notice] mod_python: Creating 4 session
mutexes based on 256 max processes and 0 max threads.

[Sun Dec 26 04:02:10 2004] [notice] FastCGI: process manager
initialized (pid 22080)

[Sun Dec 26 04:02:10 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 22081)

[Sun Dec 26 04:02:10 2004] [notice] Apache/2.0.52 (Fedora)
configured
– resuming normal operations

FastCGI: can’t start server “/opt/rt3/bin/mason_handler.fcgi” (pid
22081),
execle() failed: Permission denied

[Sun Dec 26 04:02:11 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" (pid 22081) terminated by calling
exit with status ‘255’

[Sun Dec 26 04:02:15 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" restarted (pid 22090)

FastCGI: can’t start server “/opt/rt3/bin/mason_handler.fcgi” (pid
22090),
execle() failed: Permission denied

[Sun Dec 26 04:02:15 2004] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" (pid 22090) terminated by calling
exit with status ‘255’

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT wiki at http://wiki.bestpractical.com