Fedora 4 problem with RT 3.5.5

Hi all,

Got a launching problem with a new Fedora install.
I followed all the steps described on
http://wiki.bestpractical.com/index.cgi?FedoraCore4InstallGuide and it’s
not my first RT installation.

Got :

* RT 3.5.5
* Fedora Core 4
* Apache2
* Mod_perl 2.0.1
* Mysql 4.1.12
* Perl 5.8.6
* HTML::Mason 1.3101

make fixdeps gives me a good result : nothing is missing.
make install and make initialize database : ok, no problem.

Nothing special on my RT_Siteconfig.conf and a very basic Virtual Host
in my httpd.conf

Got an error launching Apache.
My errors.log fil gives me :

[Mon Oct 10 14:10:07 2005] [error] Could not create ‘/opt/rt3/var/mason_data/obj/.__obj_create_marker’: Permission denied\nStack:\n [/usr/lib/perl5/site_perl/5.8.6/HTML/Mason/Interp.pm:185]\n [/usr/lib/perl5/site_perl/5.8.6/HTML/Mason/Interp.pm:155]\n [/usr/lib/perl5/site_perl/5.8.6/Class/Container.pm:329]\n [/usr/lib/perl5/site_perl/5.8.6/Class/Container.pm:53]\n [/usr/lib/perl5/site_perl/5.8.6/HTML/Mason/ApacheHandler.pm:624]\n [/opt/rt3/lib/RT/Interface/Web/Handler.pm:172]\n [/opt/rt3/lib/RT/Interface/Web/Handler.pm:136]\n [/opt/rt3/bin/webmux.pl:87]\nCompilation failed in require at (eval 2) line 1.\n
[Mon Oct 10 14:10:07 2005] [error] Can’t load Perl file: /opt/rt3/bin/webmux.pl for server your.rt.server.hostname:0, exiting…

Af anybody can provide some help, it would be great : )
I can’t explain this ’ permission denied '.

Thanks a lot.

Max.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Greetings Maxime!

Maxime Levasseur wrote:

[Mon Oct 10 14:10:07 2005] [error] Could not create
’/opt/rt3/var/mason_data/obj/.__obj_create_marker’: Permission
denied\nStack:\n
[/usr/lib/perl5/site_perl/5.8.6/HTML/Mason/Interp.pm:185]\n
[/usr/lib/perl5/site_perl/5.8.6/HTML/Mason/Interp.pm:155]\n
[/usr/lib/perl5/site_perl/5.8.6/Class/Container.pm:329]\n
[/usr/lib/perl5/site_perl/5.8.6/Class/Container.pm:53]\n
[/usr/lib/perl5/site_perl/5.8.6/HTML/Mason/ApacheHandler.pm:624]\n
[/opt/rt3/lib/RT/Interface/Web/Handler.pm:172]\n
[/opt/rt3/lib/RT/Interface/Web/Handler.pm:136]\n
[/opt/rt3/bin/webmux.pl:87]\nCompilation failed in require at (eval 2)
line 1.\n
[Mon Oct 10 14:10:07 2005] [error] Can’t load Perl file:
/opt/rt3/bin/webmux.pl for server your.rt.server.hostname:0, exiting…

Af anybody can provide some help, it would be great : )
I can’t explain this ’ permission denied '.

/opt/rt3/var and subdirs should be writable by user, apache is running
under.
Use something like “chown apache:apache -R /opt/rt3/var; chmod g+w -R
/opt/rt3/var”

Or maybe www:www - it’s up to distro.

SY, Danial.


Danial Klimkin,
Falk eSolutions AG Russia
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (MingW32)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFDSmW12ce6OqXQ52QRAluTAJ9xjPgt2X2T81QvZkPkTgMuSPqicQCfd1DE
Rhw/zUioo4wBt9eFFPIZZ14=
=1CX+
-----END PGP SIGNATURE-----

Af anybody can provide some help, it would be great : )
I can’t explain this ’ permission denied '.

With fedora, the first thing to check about unusual
permission problems is whether SELinux is enabled. Note
that you have to reboot to make a change in the settings
take effect.

Les Mikesell
les@futuresource.com

Maxime Levasseur wrote:

[Mon Oct 10 14:10:07 2005] [error] Could not create
’/opt/rt3/var/mason_data/obj/.__obj_create_marker’: Permission
denied\nStack:\n
[/usr/lib/perl5/site_perl/5.8.6/HTML/Mason/Interp.pm:185]\n
[/usr/lib/perl5/site_perl/5.8.6/HTML/Mason/Interp.pm:155]\n
[/usr/lib/perl5/site_perl/5.8.6/Class/Container.pm:329]\n
[/usr/lib/perl5/site_perl/5.8.6/Class/Container.pm:53]\n
[/usr/lib/perl5/site_perl/5.8.6/HTML/Mason/ApacheHandler.pm:624]\n
[/opt/rt3/lib/RT/Interface/Web/Handler.pm:172]\n
[/opt/rt3/lib/RT/Interface/Web/Handler.pm:136]\n
[/opt/rt3/bin/webmux.pl:87]\nCompilation failed in require at (eval 2)
line 1.\n
[Mon Oct 10 14:10:07 2005] [error] Can’t load Perl file:
/opt/rt3/bin/webmux.pl for server your.rt.server.hostname:0, exiting…

Af anybody can provide some help, it would be great : )
I can’t explain this ’ permission denied '.

/opt/rt3/var and subdirs should be writable by user, apache is running
under.
Use something like “chown apache:apache -R /opt/rt3/var; chmod g+w -R
/opt/rt3/var”

Or maybe www:www - it’s up to distro.

Hi Danial,

Thanks for your response … It solved my problem once SELinux disabled.
Everything works fine now : )

Max.