FastCGI question


I’ve got 2 rt servers. The production one is running on Fedora Core 3
with Apache 2 and mod_perl2 (the 1.99 version) (rt). The other is a test
box with Fedora Core 4 with Apache 2 and FastCGI (rt-test). Currently,
both have 3.4.3 and are sharing a mysql database. All this is fine. Web
UI works, email in, etc.

The FC3 server works perfectly 100% of the time. On FC4, I can’t get the
logout link to work, I end up here:


Instead of the login page.

Is this perhaps a problem with the handling of NoAuth pages? The
WebNoAuthRegex setting is the same on both boxes, which is the out of
the box value:

Set($WebNoAuthRegex, qr!^(?:/+NoAuth/|
/+REST/\d+.\d+/NoAuth/)!x );

The config in the httpd.conf file on FC4 looks like this:

<VirtualHost *:80>
ServerAdmin root
ServerAlias rt-test
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

Adding the following for RT (the ticket tracker)

AddHandler fastcgi-script fcgi
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

Pass through requests to for noauth

Alias /NoAuth/ /opt/rt3/share/html/NoAuth/

ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

FastCgiIpcDir /tmp
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
-processes 4

I can find no other references to this problem. I’ve checked and set
permissions all over the place. Anyone any ideas?


Gary Holmes
SurfControl - Enterprise Threat Protection

Get the latest news on SurfControl and our products,
subscribe to our monthly e-newsletter, SurfAdvisory at:

The information in this email is confidential and may be legally
privileged. It is intended solely for the addressee. Access to this
email by anyone else is unauthorized. If you are not the intended
recipient, any disclosure, copying, distribution or any action taken
or omitted to be taken in reliance on it, is prohibited and may be
unlawful. If you believe that you have received this email in error,
please contact the sender.