External email notification to external non-actors failing


I admin a RT 4.4.1 VM, running in AWS. We have a requirement to send email notification to an external supplier and simultaneously an internal email address (not handled by the same box - this box just does RT).

I got this working by installing the SendEmail action in our database, and then creating a scrip to utilise this action to send a custom template to the external supplier. The template had their email address explicitly defined at the top as a “To:” address, along with our internal email address (comma delimited).

This worked very well to send the emails to the external supplier, but then a colleague informed me that the notifications to the internal email address we not being received. I checked and found a load of non-deliverable emails in the www-data user mailbox, all of which were informing me that the local emails could not be delivered. I reckoned this was because the postfix main.cf had our email domain defined in ‘mydestination’. I removed it, restarted postfix and since then, the external notifications haven’t worked.

Obviously, I reverted the change back, but it’s still the same - Autoreplies work fine, email on resolutions work fine, sending email manually through postfix works fine, but if i watch the syslog as a new ticket comes into the queue, I can see the following logs:

[4963] rt-4.4.1-4963-1498813801-1249.189-26-0@bookings.somecompany.com #189/2835 - Scrip 26 notification of
new ticket
[4963] rt-4.4.1-4963-1498813801-1249.189-26-0@bookings.somecompany.com No recipients found. Not sending.

And it’s the same no matter what I do. Anyone have any ideas ?



Fixed it. For those that have a similar issue, it appears that despite the one relevant kb article I could find on this, the explicit email addresses in the template MUST be on the very top line of the template.

Also, looking through previous snapshots for AWS VM, there was a field of ‘relayhost =’ in the old main.cf, which wasn’t there in the live system. I recreated that in the live main.cf too, so that may have had an effect I guess…