Extension not able to install due to perl error

Hi everyone, I am trying to install RT-Extension-MandatoryFields-0.5 ,
however it requires me to upgrade my perl version 5.8.8. So I went to this
website and followed this guide http://blog.tuxforge.com/centos-5-perl-5-10/

I have successfully upgraded to 5.14.2 , typing this command “perl
–version” returns below:

This is perl 5, version 14, subversion 2 (v5.14.2) built for

So I went back to try and install RT-Extension-MandatoryFields-0.5 by typing
“perl Makefile.PL” but it returns an error below:

Cannot find the location of RT.pm that defines $RT::LocalPath in: etc etc

It is asking me the Path to directory containing your RT.pm:
I have tried all the locations, /opt/rt4/, /opt/rt4 , /opt/rt4/lib/ ,
/opt/rt3/ , /usr/src/rt-4.0.5 , etc.

But for some reason it is not accepting the path. I even tried setting the
variable RTHOME to /opt/rt4/
But still it is not able to find the RT.pm

My suspect is perl is not upgraded properly. But I did not receive any
errors during the upgrade.

Anyone had any idea, please shed some light?

Thank you in advance.
View this message in context: http://old.nabble.com/Re%3A-Extension-not-able-to-install-due-to-perl-error-tp33485022p33485022.html